cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Highlighted
witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Hi thought i would make this guide as i when i was looking for the settings for getting my Cisco Router online with Plusnet i had to look around to get the necessary settings needed so i thought i would write a guide, please can someone place this as a sticky or some form of plusnet wiki article to help others.

 

I will break this guide up into the below sections, for configuring the router i have provided a template that you can copy and paste into notepad and alter for your setup and then paste into your router.

 

***NOTE: If you are not sure if the router has been reset back to factory defaults i would recommend following the reset procedure for router before going further, this ensures when we configure it, their is no pre-existing config that will conflict with what we are going to put on***

 

1. You will need

2. Connecting the router up

3. Configuring the router

 

1. You will need:

  • Cisco Router and power cable
  • DSL Cable (RJ11)
  • Cisco RS232 Console cable (for connecting to router via console)
  • RS232 to USB adapter (for connecting to router via console)
  • Terminal program such as Putty or Secure CRT
  • Your Broadband username and password to allow your router to authenticate to the ISP and receive a public IP address

 

 

2. Connecting the Router up:

2.1 - Plug in your power adapter and power on the Router

2.2 - This guide assumes you are using a cisco 887VA, 897VA or another Cisco Router that has a VDSL/ADSL port on the back of the router, they look like this:

VDSL/ADSL POTS Port

2.3 - The DSL cable that Plusnet provide with your Broadband router plugs into the VDSL/ADSL over POTS port, the other end of the cable will then plug into your Telephone and Broadband Master socket connect these up, see image below:

VDSL Master socket connection

 

3 - Configuring the router

3.1 - Then you need to console into the router to be able to configure it to do this connect together the RS232 console cable and USB adapter, plug the console cables RJ45 connector into the Console port on your router and plug the USB port into your PC, see images in the link below:

Console connectivity

3.2 - Once you have the console cable connected to the router and your PC you need may need to allow the drivers for the USB adapter to install, once this is done go into device manager and look for Ports (COM & LPT) and then look for a USB to serial comm port adapter make a note of the COM number, in my case it's COM9, see image below:

COM Port Number

3.3 - Then download a Terminal program such as Putty (google this), open putty up and go to Serial and enter in your com port number, if your terminal program requires settings for serial the settings are below, once you have clicked open you should have a black screen with output from the Router (you may need to hit the enter key a few times) (see images in link below)

- Speed/Baud = 9600

- Data Bits = 8

- Stop bits = 1

- Parity = None

- Flow Control = XON/XOFF

Putty

 

3.4 - Now it's time to start configuring the router, you will more than likely be asked "Would you like to enter the initial configuration dialog?" always choose No for this.

The router will then do some more things and you will end up with a prompt that is displayed Router>

Type in enable and hit enter and then type in conf t and hit enter

You are now in the global configuration mode and can start to copy and paste in a template the prompt should look like this Router(config)#

 

3.5 - *** Replace the Hashes in the below template with the information for you and copy and paste this into the Router section by section ***

 

Cisco 887VA Template:

 

== Section 1 - copy and paste in the below this will setup your virtual ethernet interface and tell it to use 0.101 for VLAN 101 which is what Plus/BT/Sky use for VLAN tagging ==

!
hostname Broadband-Router
!
!
interface Ethernet0
no ip address

no shutdown
!
!
interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
no ip redirects
no ip proxy-arp
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1

no shutdown
!

exit

!

== Section 2 - Replace the hashes in the username and password field for your broadband username and broadband password, your broadband username is the one you use to log into your plusnet account @ plusdsl.net, plus net should provide you with your broadband password, leave everything else the way it is especially the MTU if you change these values you can end up with very poor performance ==

interface Dialer0
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname #######@plusdsl.net
ppp chap password #############
ppp ipcp address accept
ip forward-protocol nd

no shutdown

!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive

exit
!

!

ip route 0.0.0.0 0.0.0.0 dialer0

!

!

 

== After doing this you should receive an IP address on your dialer interface from Plusnet and the Status lights on the front of your Router should show PPP and CD as green this may take a few minutes ==

 

== Section 3 - The next part is dependant upon you and how you want to set things up, if you want to connect devices up to the ports on the back of the router and have the router hand out IP address configs by DHCP then copy and paste in the below template i have created for you ==

!
interface FastEthernet0
switchport mode access
switchport access vlan 10
no ip address
!
interface FastEthernet1
switchport mode access
switchport access vlan 10
no ip address
!
interface FastEthernet2
switchport mode access
switchport access vlan 10
no ip address
!
interface FastEthernet3
switchport mode access
switchport access vlan 10
no ip address
!

ip dhcp pool LAN
network 192.168.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.1.0

!

ip dhcp excluded-address 192.168.1.254

ip dhcp excluded-address 192.168.1.10

!

!

ip nat pool LAN 192.168.1.0 192.168.1.254 netmask 255.255.255.0
ip nat inside source list LAN interface Ethernet0.101 overload

!

!

!
interface Vlan1
no ip address
ip nat inside
ip virtual-reassembly in
!
interface Vlan10
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in

no shutdown

exit
!

!

!

This will give your router a setup where you will be able to connect devices to the Ethernet ports on the back of the router and will have the following:

- Devices IP settings configured by the router

- Access to the internet to many devices using NAT overload

 

 

== Section 4 - Now create the SSH keys, protect the Routers console port, SSH connectivity and enable mode with usernames and passwords, we will create one username and password for the console and SSH and will create a separate password for the enable mode ===

Amend and then copy and paste the below:

!
ip domain-name home-network
!
!
crypto key generate rsa modulus 2048
!
ip ssh version 2
!

username (your chosen username) privilege 15 secret (Your chosen password)

!

!
ip access-list standard SSH_ACCESS
!
!
permit 192.168.1.0 0.0.0.255
exit
!

!
line con 0
logging synchronous
login local
line vty 0 4
access-class SSH_ACCESS in
logging synchronous
login local
transport input ssh
exit
!
!

enable secret (your chose secret)

!

!

exit

exit

wr mem

!

!

== Now whenever you log into the router via SSH or the console port you should be asked for a username and password and when you enter enable mode you will be asked for the enable mode password ==

 

 I am going to add in the text file template and complete the 897va section.

Please let me know what you think for now.

Moderator's note by Mike (Mav): Post released from Spam Filter.

10 REPLIES 10
Moderator
Moderator
Posts: 19,660
Thanks: 3,420
Fixes: 331
Registered: ‎06-04-2007

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Moderator's Note(s)

Thread moved from My Router to Tech Help as it is not a Plusnet router.

Forum Moderator and Customer
Courage is resistance to fear, mastery of fear, not absence of fear - Mark Twain
He who feared he would not succeed sat still

Baldrick1
Hero
Posts: 3,194
Thanks: 1,375
Fixes: 87
Registered: ‎30-06-2016

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide


@witherford wrote:

Please let me know what you think

I hope that it's worth all this hassle to you and your fellow Cisco users..


 

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Thanks, is it possible for myself to create the guides/articles that on this forum?

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Just trying to provide something that i had to look in multiple places for in one place that someone can copy, amend and paste.

Baldrick1
Hero
Posts: 3,194
Thanks: 1,375
Fixes: 87
Registered: ‎30-06-2016

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide


@witherford wrote:

Thanks, is it possible for myself to create the guides/articles that on this forum?


Yes, I have produced a few myself and I think that people find them very helpful. My remark was a bit tongue in cheek but I was nor decrying the usefulness to other Cisco users.

Baldrick1
Hero
Posts: 3,194
Thanks: 1,375
Fixes: 87
Registered: ‎30-06-2016

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

@witherford 

I see that it has now been pinned to the top of this board as a reference document by one of the mods.

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Excellent,

 

Do you know if it's possible to amend my original post so i can make changes?

 

It does not seem to let me, can a Mod grant this? i want to keep making this better.

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

For anyone who knows what they are doing in regards to configuring the router for their LAN and just needs the bits for getting the router authenticated to the WAN here they are:


interface Ethernet0
no ip address
no shutdown

interface Ethernet0.101
description Tagging for PPPoE (VDSL 0)
encapsulation dot1Q 101
no ip redirects
no ip proxy-arp
ip virtual-reassembly in
pppoe enable group global
pppoe-client dial-pool-number 1
no shutdown

interface Dialer0
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication pap chap ms-chap callin
ppp chap hostname #######@plusdsl.net <-- Your broadband username here
ppp chap password ############# <-- Your broadband Password here
ppp ipcp address accept
ip forward-protocol nd
no shutdown


interface ATM0
no ip address
shutdown
no atm ilmi-keepalive

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Attached is a template text file that you can use for a Cisco 887VA, feel free to change things as you wish as long as you know what you are doing.

witherford
Dabbler
Posts: 20
Thanks: 3
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

I noticed i forgot the access-list for the NAT traffic in the guide, i have included it on the attached template file i have provided.

ip access-list standard NAT

permit 192.168.1.0 0.0.0.255