cancel
Showing results for 
Search instead for 
Did you mean: 

How to upgrade/ downgrade the firmware on the Thomson 585v7 & v8

How to upgrade/ downgrade the firmware on the Thomson 585v7 & v8

How to upgrade/ downgrade the firmware on the Thomson 585v7 & v8

This article shows you how to re-flash the firmware on the Thomson 585v7 and 585v8. You may want to do this if you're running an old version of the firmware, you suspect the firmware on your device has become corrupted or if you are having problems using a PPTP-based VPN solution. * A firmware update can also fix certain wi-fi connectivity problems affecting older revisions of the 585v8. **
* The PPTP ALG is not present in the 585v7 v8.2.23.0 firmware that shipped between November 2009 and May 2010. If you're using this firmware build then there's a possibility that you will not be able to connect to PPTP-based VPN solutions (quite commonly provided by Microsoft). To fix this problem we recommend you upgrade to v8.2.6.5 which *does* support the PPTP ALG.
** The  585v8 v8.2.7.7 firmware is known to cause wi-fi connectivity problems with certain Apple computers. To fix this problem we recommend that you upgrade to v8.2.7.8 that features updated wi-fi drivers from the chipset manufacturer. No official upgrade tool exists for Apple computers so you may need to reflash the firmware using a Windows computer instead.

Things to consider

  • Before starting, make sure the router is powered up and connected to your computer using the provided ethernet cable connected to the first port on the back of the router.
  • Do *not* attempt the firmware upgrade from a computer that is connected wirelessly.
  • Do *not* interrupt the router's/computer's power supply whilst the upgrade is in progress.

Downloads
Thomson 585v7/585v8 firmware flashing utility ~ Windows 7 users, use the version here instead.
Windows 8 users - sorry no update tool is currently available for this operating system.
However some users report the Windows 7 version works in Windows 7 compatibility mode.
Note: These update tools can also be used to update the firmware on the TG582n. However the firmware mentioned below is NOT for that router - see here for TG582n firmware.
585v7 version 7.4.4.7 firmware (Plusnet branded) ~ PPTP ALG enabled / WPS disabled / *not* patched against XSS vulnerability
585v7 version 8.2.23.0 firmware (Plusnet branded) ~ PPTP ALG disabled / WPS enabled / patched against XSS vulnerability
585v7 version 8.2.6.5 firmware (Plusnet branded) ~ PPTP enabled / WPS disabled / patched against XSS vulnerability
585v7 version 8.2.6.5 release notes
585v8 version 8.2.7.7 firmware (Plusnet branded) ~ PPTP enabled / WPS disabled / patched against XSS vulnerability
585v8 version 8.2.7.8 firmware (Plusnet branded) ~ PPTP enabled / WPS disabled / patched against XSS vulnerability / updated wi-fi drivers
Before you start
Download a copy of the flashing utility and unpack it to a location on your hard drive. You'll also need to download a copy of the firmware you're wanting to upgrade/downgrade to.
Establish which router model you have
If your router was dispatched after 18th October 2010 then you are likely to have a 585v8. If your router was dispatched prior to this then you're likely to have a 585v7. There are some discernible  differences between the two units making it pretty simple to establish which model you have.
You could check the model number on the base of the router:
585_label
There are also aesthetic and design differences between the two units. The 585v8 has no ethernet LED's on the back, the power switch has been realigned to make it more accessible, and there are air vents down the side of the unit:
585_compare
 The Thomson firmware builds linked at the top of this article are not cross-device compatible i.e. 585v7 firmware will *not* work  on a 585v8 device and vice versa.
Checking your firmware version
You can check the version of the firmware you're using by browsing to http://192.168.1.254 (you may need to enter the router administration username and password; if you don't know what these are see the TG585 FAQs page here).
firmware_version
Re-flashing the firmware

  1. Navigate to the firmware flashing utility you saved to your computer earlier and double-click the setup.exe file.
    setup_icon
  2. Choose 'English' as the preferred language and click 'OK'.
    setup_language_selection
  3. You should be presented with the following splash screen. Click 'Upgrade your Thomson Gateway'.setup_splash_screen
  4. On the following screen, click 'Next'. If you're prompted to login then enter the router administration username and password again.
    setup_one
  5. Wait for the program to finish checking your router and then click 'Next'.
    setup_two
  6. On the next page you'll be prompted for the firmware image you're wanting to use.
    setup_three
  7. Click 'Have Disk' then 'Browse' and navigate to the firmware image you should have saved to your hard drive earlier.
    setup_four
    setup_five
    setup_six
  8. Highlight the firmware image by single-clicking it and click 'Next'.
    setup_seven
  9. Now sit back and wait whilst the new firmware is installed. Remember not to turn your router or computer off whilst this is taking place.setup_eight
  10. Once complete, click the 'Finish' button.
    setup_nine

Other things to consider

  • Whilst upgrading/downgrading the firmware should retain your original settings, it is important to note that the default username and password for the router are different depending on the firmware revision you have installed. If you ever reset the router to factory defaults you will need to know what this username and password are else you may be unable to access the router configuration pages.The default username for the version 7 firmware is 'Administrator' and the password field should be left blank. The default username for the version 8 firmware is 'admin' and the password is the serial number from the bottom of the router (without the 'SN:' prefix and the two characters in brackets at the end). Note that this username and password change refers to the firmware version and not the model of router. The v7 router can have specific v8.x.x.x firmware on it.
  • After the firmware upgrade you may find that some of the router configuration pages fail to display properly or have an overlay visible in the background. This is due to your browser 'caching' images and can be resolved by browsing to one of the pages and holding CTRL and F5 on your keyboard to force a page refresh.
  • If you are downgrading from version 8 to version 7 then we strongly recommend that you change the admin password for the router once the firmware downgrade has been completed by following the instructions here.
0 Thanks
85 Comments
50175 Views
85 Comments
Grafter
The flashing utility can be downloaded from:
http://www.binarybob.plus.com/thomson/TG_UPGRADE.zip
Superuser
I've corrected the link to that in the article.
Ive just done this on my router and now the interface is very very sluggish.Also my gaming consoles that ive hooked up,xbox 360 and a wii console dont seem to be remembered now unless they are online then they are viewable in the interface and when off line they are not there?
Might be worth flushing your browser cache to see if it improves the responsiveness. I'm not using a 585v7 at the moment so I can't comment on the latter of the points you raise - does it cause you problems?
No it's not causing problems,all is working well just thought id say what's happened,overall great instructions and worked for me.
Community Veteran
So what does V8 of the firmware offer? What bugs has it fixed and does it offer any really good new features?
The main change was to patch a known XSS vulnerability. At the same time the PPTP ALG was removed meaning you can't use PPTP-based VPN solutions with the v8 firmware. I believe the v8 firmware also supports WPS as long as your wireless client does. RTM to see what WPS is - http://www.thomsontelecompartner.com/getfile.php?id=5117
Grafter
Worked a treat here on win7 (the link for the win 7 didnt work)
However when clicking setup, the compatability window pops up, select the first option and it ran a treat.
Didnt save the configuration properly tho, using a different IP (which it lost), also it didnt save the login details correctly, and went to expect the auto system to set it up (turned off)
Also hasnt saved my port forwards ... so what did it save? heh..
V8 interface seems to be much smoother imo, seems to lag only rarely.
The Windows 7 link should be fixed now Matt
Just followed all the instructions to the letter now I have a router that doesn't connect properly and web addresses do not resolve. Luckily I had my old NetGear router to replace it with.
does a hard reset help codenumpty? (i.e. sticking a pin into the hole at the back of the unit until the lights go off/on)
I am trying to connect to my employer's network using VPN, which requires the PPTP protocol.
I installed firmware version 7 as above (release 7.4.4.7) but the connection keeps failing with error 721. My Windows firewall is
I independently inquired with Thomson. They sent me a doc "open ports/port forwarding". Do I need this?
Thanks,
[ follow up to previous message ]
I meant to say that my Windows firewall was ON.
The error persists when the firewall is OFF (the error code is 721 or 619).
Thanks.
@avramidis, we've got an updated version of the v8 firmware now with the PPTP ALG re-enabled. You could try flashing with that to see if it helps. I'm going to update this article to include a link to the new build (v8.2.6.5), in the meantime though you'll find a copy here -
http://www.binarybob.plus.com/thomson/firmware/branded_R8265.bin
I've updated the article now to include download links to the new firmware builds.
Bob, it is now working! Thanks!
Glad to hear it! Smiley
N/A
I also lost my internet connection after downgrading from 8.2.23.0 > 8.2.6.5, according to the internet connectivity test everything was working except for the internet.
I found by having some patience and waiting ~5 minutes for a website to load that I was being forwarded to somewhere on the plus.net website to complete setup, and after entering my username and password everything started working again. However this setup page was very slow to load and actually failed with "webpage not available" most times, hence the long wait to realize there was an attempt at redirection.
Sounds like the firmware reflash reset your dsl login details to connect to our TR069 platform. If you'd checked and re-entered these then there would have been no need for the redirect to the Plusnet website.
Normally the router will configure itself automatically when this happens but that's dependent on it being scanned by the warehouse when it was originally dispatched (which I'm guessing yours wasn't).
Grafter
Is 8.2.23.0 newer than 8.2.6.5? The numbering indicates it might be, but hard to tell with thomson Smiley
I'm on 8.2.6.5, but it's flaky like hell. By that, I mean that if I have plug and play enabled, and wireless, the router will do a warm reboot for no reason at all. Even adding a static DNS entry on the devices menu can cause the router to reboot.
-- gyre --
Community Gaffer
Hi Gyre, 8.2.6.5 is the newest version although I understand the confusion!
I'll let our hardware guys know about the problems you're having.. has this only occurred with 8.2.6.5?
Have any of you people managed to Flash with the Unbranded firmware. I get about 2/3 of the way through the firmware install and it gives up.
I need to be able to set things like the ability to access the router from the Internet using the DynDNS service and in the branded firmware I am unable to get to the config options I need
N/A
Hi,
I had a problem connecting via my Cisco VNC to my work microsoft outlook server account. The PlusNet Technical helpdesk told me to upgrade the firmware to 8.2.6.5 which i have done but the problem still exists in that although i can connect to the VNC , it will not pull down any messageson my email server.
The VNC has worked on every other wireless router i have tried. HELP!!!!
Thanks
Stuart
You might want to give version 7 a go if you haven't already Stuart? Also, have you tried a factory reset?
@john, not aware of any probs however i guess the file could be corrupted? I'm not in a position to try it at the mo. TBH I thought the web interface was identical navigation-wise, perhaps what you're trying to do needs to be done using the CLI?
N/A
Hi Bob,
Yep, i have gone back to v7 and done a factory reset and neither v7 or v8 work. I am now back on 7.4.4.7 and havene't gone back up to v8. Any ideasHuh?
Thanks
Stuart
N/A
Sorry Bob, just to clarify i am talking about VPN problems and not VNC!
Stuart, bit miffed then TBH - do you know whether or not the Cisco VPN is reliant on PPTP as I'd expect it to be IPSec based or similar?
When you say you can't pull down emails, what client are you using and what happens when you try?
Am I right in assuming that you can swap in a non-Thomson router and everything works fine?
N/A
Hi Bob,
I tried a Siemens modem over the weekend and that didn't work either!
I will check with work re PPTP and IPSEC, and will coem back to you.
Thanks
Stuart
Stuart, I've just had a thought. You haven't got our server-side firewall switched on have you? - https://portal.plus.net/my.html?action=firewall
N/A
Hi Bob,
The Cisco VPN uses ipsec i am reliably informed.
I have tried the modem in both (firewall) enabled and disabled mode.
Still no joyHuh?
My IT guys have asked me to ask you to confirm that the Plusnet network accepts VPN. I'm sure the answer is in the positive otherwise you would have told me already, but please confirm.
Cheers
Stuart

Thanks
Stuart
Hi Stuart,
It was the firewall on our website you disabled and not the one on the router/your computer wasn't it?
Yes, our network does support VPN. I use it to connect to our Cisco based implementation at work.
I've tried flashing the 585 with all versions on this page in an attempt to enable PPTP
v7 wouldn't let me online and locked me out of my router even when I used the defualt v7 username/pw
8.2.6.5 unbranded sent me to a BT login page instead of the PNET one so I cannot confirm if this works
8.2.6.5 branded worked fine but again couldn't connect to VPN
I called up PNET and the chap said they have a new router which supports PPTP. I received it today and it's exactly the same as the one I had before with the 8.2.23.0 FW which also won't let me connect. (Was I charged for that BTW?)
So I'm wondering is there anything left to try?
N/A
Hi Bob,
OK i set the firewall through your link to OFF and disabled the firewall on the modem too.
I have done this on both v7 and v8 and still no joy!!!!
Any other hints, advice etcHuh
Thanks
Stuart
@stuboo, i'm running out of ideas TBH. The fact that you couldn't get things working with the Siemens modem either doesn't bide too well.
You mention that you can connect to the VPN itself but just can't pull emails down? I'm beginning to think that it might be your IT bods who are going to be best off diagnosing the problem from here onwards although I'm happy to answer any questions about our service that they might have.
Do you have a laptop or a desktop? If it's a laptop have you been round to a friend/family members house to see if you can get the mail account working over the VPN from their connection?
@oscar18, what account type are you on and have you tried disabling our server-side firewall? - https://portal.plus.net/my.html?action=firewall
Not sure what you mean by account type Bob, I'm on Plusnet Value if that helps.
Yes my firewall is off.
@oscar18, i asked because VPN is rate limited on the Value package - http://www.plus.net/support/broadband/speed_guide/download_speeds.shtml#valueSpeeds
Having said that it shouldn't outright prevent you from being able to connect. I'd be interested to know how you get on with a non-Thomson router. Are you able to source one from anywhere?
Grafter
@andrew b, the flakiness is on both 7.4.4.7 and the latest firmware. I have 2 plusnet branded 585v7s and they have similar amounts of flakiness.
However... putting the router into bridge mode and turning off wireless, they seem to be rock solid. So, I'm doing that for now Smiley
Bob Pullen, you are a star, VPN up and running. Thank you!
@Bloz, you don't *have* to upgrade but if you don't I'd suggest you change the default username/password for the router interface - http://community.plus.net/library/browsing/changing-the-default-password-on-a-thomson-585v7/
If you do decide to upgrade then go with the Version 8.2.6.5 build
N/A
Bob, great article. I'm using the 1-port wired ST516v6 (BANT-V). Would you be able to post the update tool and latest Plusnet firmware for that, and possibly lay your hands on firmware 7.447 or newer? I don't really mind whether it's Plusnet or Thompson branded but I suspect that the version 7.447 that I found elsewhere is not really the latest available for those in the know. Thanks in advance!
Hi Ben, AFAIK the latest version *is* 7.4.4.7. You can download a branded version here - www.binarybob.plus.com/thomson/firmware/516v6_branded_7.4.4.7.bin
The firmware upgrade tool linked in the article should work for the 516v6 too.
N/A
Hi Bob, many thanks for your rapid response and for posting the firmware. My current ST516v6 (received earlier this month) has Plusnet-branded firmware version 7.6.10.0, though I am led to believe from comments on other forums that this rather large jump actually reflects only a minor customisation, and that 7.4.4.7 is indeed the latest officially supported version as you mention. Have you heard of 7.6.10.0 and can you comment on what the modifications are versus 7.4.4.7? At any rate it seems I don't need to update my router after all if I already have the latest available firmware, although it's good to have 7.4.4.7 from a reputable source as a backup. Thanks again!
Hi Ben, no I wasn't aware of the v7.6.10.0 build but I must admit I don't follow the 585v6 as closely. I'll give Thomson a shout and get back to you...
@maccoylton, have you tried using the Windows 7 version?
Dabbler
Hi,
Is there a firmware flashing utility that can run on OS X?
Alternatively, can I push the bin file to the device over SSH or telnet and have it flash from the command line?
Thanks,
//ian
Hi Ian,
I can't speak for it's validity/success rate (as AFAIK Thomson have not released an official version), but there's a MAC flashing utility on Be Broadband's website here - http://beusergroup.co.uk/technotes/index.php/Modem_Firmware#Mac
If you try using that though, you'd be doing so at your own risk.
You /can/ use bootp/tFTP to flash the device as well. There's a guide at the aforementioned URL, however it does contain references that are specific to Be's firmware builds/routers.
If you do fancy writing a Plusnet-specific guide then feel free. Anyone is welcome to write support articles on this website.
Grafter
The links to the firmware builds do not work?
Superuser
Hmm,it looks like that server might be down.
David
nope, i (unintentionally) broke the links with an .htaccess file (doh!) - should be sorted now.