cancel
Showing results for 
Search instead for 
Did you mean: 

flent install archpi

FIXED
Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

flent install archpi

Anybody help with installing flent on arch-raspberry pi.

Works ok in Mint-Gui and console mode but I can't figure out how to install it on the pi with an arch build.

It's not in the rasbpian repo or the arch repo, so a little stuck!

I have..

 ls
BUGS README.rst flent-mime.xml man setup.py
MANIFEST.in batchfile.example flent.desktop misc unittests
Makefile doc flent.egg-info packaging
PKG-INFO flent flentrc.example setup.cfg
@alarmpi flent-1.0.1]$ cd flent
@alarmpi flent]$ ls
__init__.py combiners.py metadata.py settings.py util.py
__main__.py error_ellipse.py plotters.py testenv.py
aggregators.py formatters.py resultset.py tests
batch.py gui.py runners.py transformers.py
build_info.py loggers.py scripts ui

 

Do I need to install the dependacies first ?

I've also tried the PKGBUILD as well Sad

Or am I just going about this the wrong way ?

7 REPLIES
Community Veteran
Posts: 4,987
Thanks: 1,154
Fixes: 29
Registered: 16-10-2014

Re: flent install archpi

Fix

Can't you just use pip or pip3 install flent?

Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

Re: flent install archpi

sudo pacman -S python-pip
resolving dependencies...
looking for conflicting packages...

Packages (7) python-3.6.2-1  python-appdirs-1.4.3-1  python-packaging-16.8-2
             python-pyparsing-2.2.0-1  python-setuptools-1:36.2.7-1
             python-six-1.10.0-3  python-pip-9.0.1-2

Total Download Size:    18.31 MiB
Total Installed Size:  111.39 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 python-3.6.2-1-armv6h     16.6 MiB  3.86M/s 00:04 [######################] 100%
 python-pyparsing-2....    92.3 KiB  1845K/s 00:00 [######################] 100%
 python-six-1.10.0-3-any   17.9 KiB  0.00B/s 00:00 [######################] 100%
 python-packaging-16...    28.7 KiB   718K/s 00:00 [######################] 100%
 python-appdirs-1.4....    13.6 KiB  1356K/s 00:00 [######################] 100%
 python-setuptools-1...   270.5 KiB  1229K/s 00:00 [######################] 100%
 python-pip-9.0.1-2-any  1367.5 KiB  1140K/s 00:01 [######################] 100%
(7/7) checking keys in keyring                     [######################] 100%
(7/7) checking package integrity                   [######################] 100%
(7/7) loading package files                        [######################] 100%
(7/7) checking for file conflicts                  [######################] 100%
(7/7) checking available disk space                [######################] 100%
:: Processing package changes...
(1/7) installing python
Optional dependencies for python
    python-setuptools [pending]
    python-pip [pending]
    sqlite [installed]
    mpdecimal: for decimal
    xz: for lzma [installed]
    tk: for tkinter
(2/7) installing python-pyparsing
(3/7) installing python-six
(4/7) installing python-packaging
(5/7) installing python-appdirs
(6/7) installing python-setuptools
(7/7) installing python-pip
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[barclay@alarmpi ~]$ pip install flent
Collecting flent
  Downloading flent-1.0.1-py2.py3-none-any.whl (246kB)
    100% |################################| 256kB 212kB/s
Installing collected packages: flent
Exception:
Traceback (most recent call last):
  File "/usr/lib/python3.6/site-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/lib/python3.6/site-packages/pip/commands/install.py", line 342, in run
    prefix=options.prefix_path,
  File "/usr/lib/python3.6/site-packages/pip/req/req_set.py", line 784, in install
    **kwargs
  File "/usr/lib/python3.6/site-packages/pip/req/req_install.py", line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
  File "/usr/lib/python3.6/site-packages/pip/req/req_install.py", line 1064, in move_wheel_files
    isolated=self.isolated,
  File "/usr/lib/python3.6/site-packages/pip/wheel.py", line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/usr/lib/python3.6/site-packages/pip/wheel.py", line 316, in clobber
    ensure_dir(destdir)
  File "/usr/lib/python3.6/site-packages/pip/utils/__init__.py", line 83, in ensure_dir
    os.makedirs(path)
  File "/usr/lib/python3.6/os.py", line 220, in makedirs
    mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.6/site-packages/flent-1.0.1.dist-info'
Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

Re: flent install archpi

baaaaaaaaaaaaaaaaaah tired eyes

 

 

sudo pip install flent
[sudo] password for barclay:
Collecting flent
Downloading flent-1.0.1-py2.py3-none-any.whl (246kB)
100% |################################| 256kB 210kB/s
Installing collected packages: flent
Successfully installed flent-1.0.1

Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

Re: flent install archpi

sudo pip install matplotlib
Collecting matplotlib
  Downloading matplotlib-2.0.2.tar.gz (53.9MB)
    100% |################################| 53.9MB 1.2kB/s
    Complete output from command python setup.py egg_info:
    IMPORTANT WARNING:
        pkg-config is not installed.
        matplotlib may not be able to find some of its dependencies
    ============================================================================
    Edit setup.cfg to change the build options

    BUILDING MATPLOTLIB
                matplotlib: yes [2.0.2]
                    python: yes [3.6.2 (default, Jul 22 2017, 20:34:44)  [GCC
                            7.1.1 20170516]]
                  platform: yes [linux]

    REQUIRED DEPENDENCIES AND EXTENSIONS
                     numpy: yes [not found. pip may install it below.]
                       six: yes [using six version 1.10.0]
                  dateutil: yes [dateutil was not found. It is required for date
                            axis support. pip/easy_install may attempt to
                            install it after matplotlib.]
               functools32: yes [Not required]
              subprocess32: yes [Not required]
                      pytz: yes [pytz was not found. pip will attempt to install
                            it after matplotlib.]
                    cycler: yes [cycler was not found. pip will attempt to
                            install it after matplotlib.]
                   tornado: yes [tornado was not found. It is required for the
                            WebAgg backend. pip/easy_install may attempt to
                            install it after matplotlib.]
                 pyparsing: yes [using pyparsing version 2.2.0]
                    libagg: yes [pkg-config information for 'libagg' could not
                            be found. Using local copy.]
                  freetype: no  [The C/C++ header for freetype2 (ft2build.h)
                            could not be found.  You may need to install the
                            development package.]
                       png: no  [pkg-config information for 'libpng' could not
                            be found.]
                     qhull: yes [pkg-config information for 'qhull' could not be
                            found. Using local copy.]

    OPTIONAL SUBPACKAGES
               sample_data: yes [installing]
                  toolkits: yes [installing]
                     tests: no  [skipping due to configuration]
            toolkits_tests: no  [skipping due to configuration]

    OPTIONAL BACKEND EXTENSIONS
                    macosx: no  [Mac OS-X only]
                    qt5agg: no  [PyQt5 not found]
                    qt4agg: no  [PySide not found; PyQt4 not found]
                   gtk3agg: no  [Requires pygobject to be installed.]
                 gtk3cairo: no  [Requires cairocffi or pycairo to be installed.]
                    gtkagg: no  [Requires pygtk]
                     tkagg: yes [installing; run-time loading from Python Tcl /
                            Tk]
                     wxagg: no  [requires wxPython]
                       gtk: no  [Requires pygtk]
                       agg: yes [installing]
                     cairo: no  [cairocffi or pycairo not found]
                 windowing: no  [Microsoft Windows only]

    OPTIONAL LATEX DEPENDENCIES
                    dvipng: no
               ghostscript: no
                     latex: no
                   pdftops: no

    OPTIONAL PACKAGE DATA
                      dlls: no  [skipping due to configuration]

    ============================================================================
                            * The following required packages can not be built:
                            * freetype, png

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-dw84lyz6/matplotlib/

off to bed....

Community Veteran
Posts: 4,987
Thanks: 1,154
Fixes: 29
Registered: 16-10-2014

Re: flent install archpi

@30FTTC06 - You're unable to build some requirements so start by installing the build tools:

sudo pacman -S --needed base-devel

And as you have Python 3.6 installed if it's not there already install pip3 and then re-try a matplotlib using it:

sudo pip3 install matplotlib

pip3 is the preferred installer when using python 3

Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

Re: flent install archpi

Cheers @Mook got there in the end..

sudo pacman -S python-matplotlib

 

 sudo pacman -S  python-matplotlib
resolving dependencies...
looking for conflicting packages...

Packages (8) blas-3.7.1-1  cblas-3.7.1-1  lapack-3.7.1-1  python-cycler-0.10.0-2
             python-dateutil-2.6.1-1  python-numpy-1.13.1-2  python-pytz-2017.2-1
             python-matplotlib-2.0.0-1

Total Download Size:   10.74 MiB
Total Installed Size:  47.74 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 blas-3.7.1-1-armv6h               70.8 KiB  1771K/s 00:00 [################################] 100%
 lapack-3.7.1-1-armv6h           1483.8 KiB  3.53M/s 00:00 [################################] 100%
 cblas-3.7.1-1-armv6h              25.3 KiB  2.47M/s 00:00 [################################] 100%
 python-numpy-1.13.1-2-armv6h       2.2 MiB  3.30M/s 00:01 [################################] 100%
 python-pytz-2017.2-1-any         157.6 KiB  3.85M/s 00:00 [################################] 100%
 python-dateutil-2.6.1-1-any      219.8 KiB  3.58M/s 00:00 [################################] 100%
 python-cycler-0.10.0-2-any        11.0 KiB  0.00B/s 00:00 [################################] 100%
 python-matplotlib-2.0.0-1-a...     6.6 MiB  3.80M/s 00:02 [################################] 100%
(8/8) checking keys in keyring                             [################################] 100%
(8/8) checking package integrity                           [################################] 100%
(8/8) loading package files                                [################################] 100%
(8/8) checking for file conflicts                          [################################] 100%
(8/8) checking available disk space                        [################################] 100%
:: Processing package changes...
(1/8) installing python-pytz                               [################################] 100%
(2/8) installing blas                                      [################################] 100%
(3/8) installing lapack                                    [################################] 100%
(4/8) installing cblas                                     [################################] 100%
(5/8) installing python-numpy                              [################################] 100%
Optional dependencies for python-numpy
    python-nose: testsuite
(6/8) installing python-dateutil                           [################################] 100%
(7/8) installing python-cycler                             [################################] 100%
(8/8) installing python-matplotlib                         [################################] 100%
Optional dependencies for python-matplotlib
    python-gobject: for GTK3Agg/GTK3Cairo backend
    python-cairocffi: for GTK3Agg/GTK3Cairo backend
    python-pyqt4: for Qt4Agg backend
    tk: used by the TkAgg backend
    ghostscript: usetex dependencies
    texlive-bin: usetex dependencies
    python-tornado: for webagg backend
    python-pillow: for reading/saving .jpg/bmp/tiff files
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
 

~]$ flent tcp_download -p totals -l 60 -H netperf.bufferbloat.net -t text-to-be-included-in-plot -o bob.png Started Flent 1.0.1 using Python 3.6.2. Starting tcp_download test. Expected run time: 70 seconds. Data file written to ./tcp_download-2017-08-08T192010.844588.text_to_be_included_in_plot.flent.gz. Initialised matplotlib v2.0.0 on numpy v1.13.1.

 

Community Veteran
Posts: 2,255
Thanks: 101
Fixes: 4
Registered: 18-02-2013

Re: flent install archpi

I quite like this flent...

Edit: RPI gives a rubbish graph hmmm.

both.png

 

Fast pc...

 

better.png