cancel
Showing results for 
Search instead for 
Did you mean: 

BT Smart Hub 2 not connecting.

FIXED
Highlighted
Hooked
Posts: 7
Fixes: 1
Registered: ‎10-10-2019

BT Smart Hub 2 not connecting.

Hi, I've purchased a new BT Smart Hub 2 from ebay, however cannot seem to connect to the internet with it. It tries to connect but fails, have changed username and password (myusername@plusdsl.net) as per pinned Plusnet with Home Hub 6 instructions, factory reset performed and username/password re-entered again.

 

The Smart Hub 2 I have has the BT in a small circle logo rather than what i believe is the slightly older model with the BT+logo in a larger circle.

 

I've read on the forums here that this hub should work ok, however there are also some indications that it is locked to BT and won't work, does anyone know for sure if it should work? There doesn't seem to be many options/settings required other than changing the username/password?

Plugging the old hub back on and it connects straight away.

 

Firmware version v0.17.01.12301-BT

 

Getting PPP: Chap authentication failed in the event log.

6 REPLIES 6
Highlighted
Seasoned Hero
Posts: 5,504
Thanks: 2,443
Fixes: 163
Registered: ‎30-06-2016

Re: BT Smart Hub 2 not connecting.

Fix

@markbedwards 

Three things:

1. Have you confirmed that you are using the correct user name and password by using them to log into your Plusnet account?

2. Are you leaving the DSL cable unplugged until after you have changed your username and password? If you don't it will reset to the default BT one.

3. Have you got any special characters in your Plusnet password? If so go into your account and change it to using only alpha numeris characters. Ignore instructions to use a special one.

Hooked
Posts: 7
Fixes: 1
Registered: ‎10-10-2019

Re: BT Smart Hub 2 not connecting.

I'm certain the username/password is correct, there is a special character so I will change that and try again.

 

The username/password is saved as it is still kept after a power cycle of the Smart Hub 2.

 

Many thanks for the quick reply, will update thread after password change.

Highlighted
Hooked
Posts: 7
Fixes: 1
Registered: ‎10-10-2019

Re: BT Smart Hub 2 not connecting.

Uh, I'm not 100% sure of the fix there. I logged in and changed my password, turned around to change it on the Smart Hub 2 and it is showing as connected!

Yesterday, while I was trying to get it working I was using the provided filter that came with the new Smart Hub 2, today I have used the existing one from my old hub - it could be that or it could be the change of password - when I changed password via the Plusnet web portal it indicated that the password would automatically change on the Hub if it was connected, if not you have to manually change it. So I've turned around to change it on the hub and its already connected.

 

Highlighted
Seasoned Hero
Posts: 5,504
Thanks: 2,443
Fixes: 163
Registered: ‎30-06-2016

Re: BT Smart Hub 2 not connecting.

@markbedwards 

I guess there are a few explanations.

1. When you first connected it spent time updating the firmware and you gave up waiting, believing it had failed to connect. You can check this by logging in and seeing when the firmware last updated.

2. As you say, you might have a duff filter.

3. It has automatically picked up your new password.  To be honest I'm sceptical about this. I recommend that you log in and check the password as if it hasn't changed you will probably find that if it reboots it will not reconnect until the password is beought up to date. Remember to unplug the DSL cable or select Disconnect/connect before and after changing this

Highlighted
Hooked
Posts: 7
Fixes: 1
Registered: ‎10-10-2019

Re: BT Smart Hub 2 not connecting.

Looks like the firmware only updated after the connection was made and the connection was made before I changed the password, so currently looking like I had a duff filter - I will test this later.

 

Some of the log entries - the last one is immediately before connection where it picked up the NTP:

10:21:43, 14 Oct.Hub is waiting to apply new firmware.
10:21:43, 14 Oct.download firmware image success
.
.
10:05:04, 14 Oct.WAN Auto-sensing last connection port: DSL WAN
00:44:55, 01 Oct.2.4G client Mac: 90:02:18:A5:20:24 Deauthentications (Reason:Class 2 frame received from nonauthenticated station)

 

Looks like it connected as I was typing out the original post, typical!

Thanks for your help with this.

Highlighted
Seasoned Champion
Posts: 1,278
Thanks: 551
Fixes: 28
Registered: ‎07-07-2009

Re: BT Smart Hub 2 not connecting.

@markbedwards  I don't think it is anything to do with the filter. The router will not have updated with your new account password as it will not be registered on the Plusnet management platform so I agree with @Baldrick1  that you will now have a mismatch between your router and account passwords which you will need to correct, or risk failure to reconnect if for any reason the current connection is lost. 🙄