cancel
Showing results for 
Search instead for 
Did you mean: 

Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Community Gaffer
Community Gaffer
Posts: 5,384
Thanks: 721
Fixes: 6
Registered: ‎04-04-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

We're still not really sure what the problem is.  Ignoring Fingus and his packet loss on traces to WoT servers, the latencies for the FFXIV traces seem about what we expect for the transatlantic hop and the problems you are describing sound like delays much greater than those latencies suggest.
Have any of you used wireshark before?  If you can get us a good sample of your traffic while playing we might be able to work out why it's lagging.
Kelly Dorset
Broadband Service Manager
shadowff6
Grafter
Posts: 100
Registered: ‎10-07-2010

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Aren't BT/SKY/Virgin users all showing about 100ms compared to the 180+ we're seeing with Plus.net?
I'll have a look at the Wireshark thread tonight and hopefully set it up to capture whilst I'm playing either tonight/tomorrow.
Tremaine2000
Newbie
Posts: 7
Registered: ‎17-10-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Hang on,  looking at my tracert from last night I'm sitting on a 39% packet loss (if I'm reading it right). Thats huge and more than accounts for the lag. Also looking at the route, I'm jumping from an avg 16ms to 94ms in a london hop, not the transatlantic one.
Community Gaffer
Community Gaffer
Posts: 5,384
Thanks: 721
Fixes: 6
Registered: ‎04-04-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote from: Tremaine2000
This is my tracert as of this evening.

I'm not sure I'm understanding this screengrab.  Is that showing your first hop (router) being really variable?  If so, anything else beyond there is going to be bad?
Kelly Dorset
Broadband Service Manager
Community Gaffer
Community Gaffer
Posts: 5,384
Thanks: 721
Fixes: 6
Registered: ‎04-04-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote from: shaone
Back again for me too in a major way.
Tracing route to 199.91.189.21 over a maximum of 30 hops
  1    83 ms   101 ms    97 ms  dsldevice.lan [192.168.1.254]
  2    31 ms    18 ms    10 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    11 ms    10 ms    13 ms  link-b-central10.pcl-gw02.plus.net [212.159.2.170]
  4    13 ms    10 ms    13 ms  xe-10-2-0.pcl-cr02.plus.net [212.159.0.202]
  5    11 ms    12 ms    10 ms  ae2.pcl-cr01.plus.net [195.166.129.6]
  6    10 ms    11 ms    10 ms  xe-11-2-0.edge3.London2.Level3.net [212.187.201.213]
  7    18 ms    18 ms    16 ms  ae-3-3.ebr1.Paris1.Level3.net [4.69.141.86]
  8    17 ms    19 ms    19 ms  ae-91-91.csw4.Paris1.Level3.net [4.69.161.90]
  9    48 ms    16 ms    19 ms  4.69.168.200
10    18 ms    17 ms    20 ms  ix-20-0.tcore1.PVU-Paris.as6453.net [80.231.153.65]
11   107 ms   134 ms   108 ms  if-12-2.tcore1.PYE-Paris.as6453.net [80.231.154.69]

12   109 ms   108 ms   141 ms  if-3-6.tcore1.L78-London.as6453.net [80.231.130.85]
13   108 ms   109 ms   108 ms  if-2-2.tcore2.L78-London.as6453.net [80.231.131.1]
14   106 ms   105 ms   108 ms  if-20-2.tcore2.NYY-NewYork.as6453.net [216.6.99.13]
15   110 ms   107 ms   113 ms  if-5-2.tcore2.MTT-Montreal.as6453.net [216.6.99.30]
16   113 ms   119 ms   106 ms  if-0-2.tcore1.MTT-Montreal.as6453.net [216.6.115.89]
17   110 ms   110 ms   107 ms  if-5-2.tcore1.W6C-Montreal.as6453.net [64.86.31.6]
18   157 ms   161 ms   169 ms  66.198.96.50

19   165 ms   168 ms   170 ms  192.34.76.2
20   179 ms   175 ms   178 ms  199.91.189.234
21   173 ms   169 ms   173 ms  199.91.189.21

Just looking back at this trace, I've bolded the two hops which seem problematic.  One appears to be within Tata, in Paris.  This could well be congestion, and could well be the problem.  The second bold I've just seen when I've tracerouted from my desktop, but isn't there on some of the other traces which suggest it could be periodic congestion causing it, rather than just a long hop. 
It looks like you guys aren't alone on this:
http://forum.square-enix.com/ffxiv/threads/110929-FOR-THE-LOVE-OF-GOD-PLEASE-FIX-THIS-MASSIVE-LAG-PR...
If the problem is caused by Tata, we are dependant on them for a fix.  We're evaluating if we can route a different way, but that's not an overnight thing.

Kelly Dorset
Broadband Service Manager
Tremaine2000
Newbie
Posts: 7
Registered: ‎17-10-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote
Quote from: Tremaine2000 on 22/10/2013, 20:53
This is my tracert as of this evening.
I'm not sure I'm understanding this screengrab.  Is that showing your first hop (router) being really variable?  If so, anything else beyond there is going to be bad?

I'm in no way an expert, but if everything else is going to be bad, why then (apart from hop 1) are the next 6 an average of 9ms in 413 traceroutes?
I'm not sure why my initial hop is so variable either, but apart from to FFXIV at prime time, my connection has been working really nicely.
As an aside, I've tried http://www.wtfast.com/ which is a vpn. It worked really nicely last night with latency of 88ms. There is a free trial for 1 month, then you have to pay. I don't want to go this route, especially as I'm paying for better  connection specifically for gaming already. However, it should tide me over until this gets sorted. If not, then I will sadly look at leaving plusnet after almost 12 years custom.
Community Gaffer
Community Gaffer
Posts: 5,384
Thanks: 721
Fixes: 6
Registered: ‎04-04-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote from: Kelly

10    18 ms    17 ms    20 ms  ix-20-0.tcore1.PVU-Paris.as6453.net [80.231.153.65]
11   107 ms   134 ms   108 ms  if-12-2.tcore1.PYE-Paris.as6453.net [80.231.154.69]


Looks to be the same lift on the traces on this threads too:
http://community.plus.net/forum/?topic=118180.msg1022742
Kelly Dorset
Broadband Service Manager
Aesir
Newbie
Posts: 3
Registered: ‎22-10-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote from: Kelly
We're still not really sure what the problem is.  Ignoring Fingus and his packet loss on traces to WoT servers, the latencies for the FFXIV traces seem about what we expect for the transatlantic hop and the problems you are describing sound like delays much greater than those latencies suggest.
Have any of you used wireshark before?  If you can get us a good sample of your traffic while playing we might be able to work out why it's lagging.

I can get a wireshark grab tonight. I was trying to get one whilst I was raiding last night, but have lost the data from it now. If i can i'll try and grab some data when there is no lag and when there is.
The weird thing for me is that the latency is all one sided. As in according to my free company I'm still running around and acting like normal. I managed to heal turn 1 apparently fine, couldn't see any of the fight, my team mates were calling out various moves, When the boss died, everything speed up and i saw the whole fight in super fast vision.
enekomh
Dabbler
Posts: 11
Registered: ‎30-04-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

I've just done a 30 minute wireshark test.
How should I upload it?
Community Gaffer
Community Gaffer
Posts: 5,384
Thanks: 721
Fixes: 6
Registered: ‎04-04-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Wow.  How big is it?  You could just put it on a file locker or something for us to get at tomorrow.
Kelly Dorset
Broadband Service Manager
dragona
Grafter
Posts: 218
Thanks: 1
Registered: ‎31-07-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Just done a wireshark capture running from 1 end of the map to the other and was fortunate to have a 10+ second spike where every other person froze on screen.
shortly after i did a trace route and got the following results with a spike that caused me to dc after about 1 min of no movement from other characters
Tracing route to 199.91.189.19 over a maximum of 30 hops
  1    <1 ms     1 ms     1 ms  router.asus.com [192.168.1.1]
 2    17 ms   108 ms    30 ms  lo0-central10.ptn-ag03.plus.net [195.166.128.192
]
 3    31 ms    17 ms    56 ms  link-a-central10.ptn-gw01.plus.net [212.159.2.13
6]
 4    61 ms    16 ms   106 ms  xe-5-3-0.ptw-cr01.plus.net [212.159.0.108]
 5    17 ms   113 ms    17 ms  te-3-4.car5.London1.Level3.net [217.163.45.181]
 6    33 ms    16 ms    17 ms  ae-52-52.csw2.London1.Level3.net [4.69.139.120]
 7    16 ms    16 ms    17 ms  ae-228-3604.edge3.London1.Level3.net [4.69.166.1
58]
 8    17 ms    22 ms    17 ms  ix-20-0.tcore1.LDN-London.as6453.net [195.219.83
.101]
 9   119 ms   109 ms   114 ms  if-17-2.tcore1.L78-London.as6453.net [80.231.130
.129]
10   107 ms   106 ms   107 ms  if-1-2.tcore2.L78-London.as6453.net [80.231.130.
122]
11   107 ms   110 ms   112 ms  if-20-2.tcore2.NYY-NewYork.as6453.net [216.6.99.
13]
12   109 ms   114 ms   110 ms  if-5-2.tcore2.MTT-Montreal.as6453.net [216.6.99.
30]
13   109 ms   109 ms   125 ms  if-0-2.tcore1.MTT-Montreal.as6453.net [216.6.115
.89]
14   142 ms   109 ms   111 ms  if-5-2.tcore1.W6C-Montreal.as6453.net [64.86.31.
6]
15   120 ms   116 ms   106 ms  66.198.96.50
16   206 ms   171 ms     *     192.34.76.2
17   109 ms   113 ms   118 ms  199.91.189.234
18   116 ms   101 ms     *     199.91.189.19
19   144 ms     *      129 ms  199.91.189.19
Trace complete.

Tried to attach but it doesnt seem to even if zipped (1.5MB) will put it on personal space in a min
Edit:
URL is http://www.dragona.plus.com/FFXIV/wireshark/
xand49
Dabbler
Posts: 19
Registered: ‎25-09-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

I'm also getting really bad lag to Odin for the last 2 days, this however does seem related to some data centre issues on their end.
as far as the first page mentioning hard mode primal fights, i do experience lag in those fights, consistently, on and off peak
enekomh
Dabbler
Posts: 11
Registered: ‎30-04-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

Quote from: Kelly
Wow.  How big is it?   You could just put it on a file locker or something for us to get at tomorrow.

It's not really that big. Just 2,300 KB. FFXIV:ARR is a really light game bandwidthwise.
You can download the file here:
http://www.putlocker.com/file/B6CD44AC759594E7
I've been looking at it and all the downstream traffic (everything coming from the servers) is tagged as GOLD. Please, note that I am a PRO user (I added that addon yesterday) but I noticed lag both on FATEs and while playing solo (not that many when soloing though).
dragona
Grafter
Posts: 218
Thanks: 1
Registered: ‎31-07-2007

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

also uploaded one "2 large lags and disconnection" started in the middle of a  large lag, seemed to recover from it to get another large lag and disconnection form the server disconnect occurred at line 8690 approx
Aesir
Newbie
Posts: 3
Registered: ‎22-10-2013

Re: Final Fantasy XIV: Realm Reborn - Lag/Packet loss?

I've uploaded two separate traces. One whilst in an instance (this one is quick as I couldn't heal with the lag) and the second in a town.
http://www.putlocker.com/file/3B0D07DC709A39C9
http://www.putlocker.com/file/2AD4A3FFF5851E48