Showing results for 
Search instead for 
Did you mean: 

Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

Posts: 2
Registered: ‎29-10-2020

Re: Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

Thank you for posting.
I have made two backups.
One of them restored to VR9 prompt after U-BOOT. Before and when depressing the power on button, I hit the return key a few times to get this.
The other one restored but at the end of restoration failed to set U-BOOT to enable serial link. It tried the correct key but failed.

Trouble: neither of my nanddump files reboot into stock firmware after successful restoration.

Does it mean that I will permanently loss my Netowrk->Wireless (WiFi) functionality?

Below is screen log when running the "prepare" script:

Starting installation...
TRYING to decrypt u-boot env with key B1D3B4BD0970FCA9261E23C2170DB8E52407C71DAC06098678C0885BC7E68CCD
TRYING to decrypt u-boot env with key 86fd5557bab554172a97eaec65680745d4ec2efe723decb956a50bd9bc13e1a8
TRYING to decrypt u-boot env with key 3E4CA8114D15BFC653B2BF9519EF2B94200E30345503B125C1D0BE776698B950
WARNING: U-boot environment could not be decrypted! (the second key was the correct key)

'bootcmd' will be reset to default values.  When the HH5A starts up after
installing LEDE, the boot process will halt at the VR9# u-boot prompt.

To update 'bootcmd' variable refer to the guide on the web page hosting the
install image.

Erasing 128 Kibyte @ 0 -- 100 % complete
Press any key to continue...

REMOVING ubi volume OpenRG...

REMOVING ubi volume [-Censored-]...

Preparation completed!

Your attached USB media is mounted as a subdirectory at /tmp/mounts/

Moderator's note by Mike (Mav): Post released from Spam Filter.
Posts: 8
Thanks: 1
Registered: ‎27-09-2014

Re: Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

I've been running a Home Hub 5A with OpenWRT for a long time and now v20.02 is in beta test and I took a chance.


Upgrading my OpenWRT to v21.01.01-rc2 went well

I have not come across any problems, but OpenWRT has changed internally in ways which affect some settings and add-ons. The Home Hub 5A is an old enough design to be getting slow for faster connections but this has dropped some obsolete security standards and allows WPA-3.

It's a test version, but it's doing what I want. Some of the sources of a Home Hub 5A with OpenWRT already installed are already advertising this version. These packages are an OK option but I'd wait for the formal release of v20.02 

I have found this hardware/firmware to be reliable but it is a 2013 hardware design. The zeroth law applies: if it works don't fix it.

OpenWRT website 


Posts: 14
Registered: ‎01-01-2017

Re: Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

I took the plunge and updated OpenWrt 19.07.8 to 21.02.1 with no problems, I uploaded the .bin file via LuCI and it retained all my settings ok. I like the new dark theme.

I also gave up on using pihole as a DNS server because the SD card in a Pi can corrupt if there's a power cut, so now I just use a hosts file on the router to block ads; seems to do much the same job.

Rising Star
Posts: 285
Thanks: 42
Registered: ‎15-10-2016

Re: Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

I have had my 5a installed and working fine, almost since I came to PN, but around three weeks ago something weird happened....

One Saturday my connection began cutting on and off, by late evening it cut off and remained off. I swapped the 5a for my original PN router, which was also unable to connect, checked the phone which was still working, then waited until next morning to ring PN tech.

PN reconfigured something, gave me a new broadband password and off I went again, still using the PN router.

The problem with the PN router is it is limited to its range of internal IP's for the LAN, so I tried to reconfigure the 5a to new password. That didn't connect, so I then did a factory reset and started from scratch to reconfigure it. All seemed fine, until I got to trying to set up the wifi, where I was not able to set the wifi password - it kept on rejecting the wifi password I tried to set up, the box around the password showed as red. It refused to accept any password, no mater how simple, how complex. 


At which point I gave up on the 5a and reconfigured everything on my network from 10.???.???.???, to a range acceptable to the PN router.

My guess is that there was some sort of glitch on the line (FTTC), which damaged my 5a router and maybe the port or what ever at the box or exchange.

Posts: 8
Thanks: 1
Registered: ‎27-09-2014

Re: Running OpenWRT on the Plusnet Hub One (& BT Home Hub 5a)

Information updatre.

OvenWRT v21.02 and v19.07 have both updated to v21.02.2 and v19.07.9 which both involve security updates. There are differences between the two versions, and v21.02 can be problematic with different details.

You should be cautious transferring from v19.07 to v21.02 and using the factory reset is recommended. v21.02 makes some big internet changes, including to DSA code, which make for better operation but may be tripped up by copying configs.

Both these versions use the standard OpenWRT factory reset system, which has been very useful for me after problems. I can confirm this works, as in the linked instructions failsafe and factory reset. The relevant reset button is the recessed one on the back above the power socket.