cancel
Showing results for 
Search instead for 
Did you mean: 

OpenWRT and Plusnet

FrazUK
Grafter
Posts: 37
Registered: 20-10-2015

OpenWRT and Plusnet

I've installed OpenWRT on my TP-Link W9980 which seems to have gone well except I don't have any internet connection. The modem isn't synced/status is down and there's no green LED. I've set up the basic settings from the admin panel (PPP, username/password) and followed the guide here for a device with a built in modem https://wiki.openwrt.org/doc/howto/internet.connection. The two commands

uci set network.adsl.fwannex='a'

 

and 

 

uci set network.adsl.annex='a2p'

 

Both give an 'invalid argument' error.

 

Does anyone here knew how to get OpenWRT setup for vdsl on Plusnet?

 

Cheers!

7 REPLIES
Krazeh
Grafter
Posts: 84
Registered: 06-02-2013

Re: OpenWRT and Plusnet

I've never used the uci commands so not sure exactly how to use them. But the following is the relevant section from my '/etc/config/network' file. If you copy them into yours (overwriting any existing 'dsl' or 'wan' sections) and add your username/password, it should work. Obviously remember to back up the original config file first.

 

config dsl 'dsl'
        option annex 'b'
        option xfer_mode 'ptm'
        option line_mode 'vdsl'

config interface 'wan'
        option ifname 'ptm0.101'
        option proto 'pppoe'
        option username '<username>'
        option password '<password>'
        option ipv6 'auto'
FrazUK
Grafter
Posts: 37
Registered: 20-10-2015

Re: OpenWRT and Plusnet

Thanks Krazeh,

 

I've just changed those settings using uci commands but still have no connection. How do you access the files to edit manually?

 

Cheers!

FrazUK
Grafter
Posts: 37
Registered: 20-10-2015

Re: OpenWRT and Plusnet

OK, I've figured out how to edit the file and I've applied the settings you gave but i still have no sync. Is there something I'm missing? All I've done so far, is install OpenWRT and made these config changes.

 

EDIT: The device is a VDSL Modem and Router combo. Is the config you provided for this or for an external modem?

Krazeh
Grafter
Posts: 84
Registered: 06-02-2013

Re: OpenWRT and Plusnet

Can you post the entire contents of your /etc/config/network file? That might point out where something is going wrong.

FrazUK
Grafter
Posts: 37
Registered: 20-10-2015

Re: OpenWRT and Plusnet

Here's the full config file. This is how it was by default with just the wan and dsl interfaces replaced with yours...

 

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6e:985a:5989::/48'

config interface 'lan'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'eth0.1'
option macaddr 'f4:f2:6d:bf:f5:33'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 2 4 5 6t'

config atm-bridge 'atm'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option vpi '8'

config interface 'wan'
option ifname 'ptm0.101'
option proto 'pppoe'
option username 'usernameremoved'
option password 'passwordremoved'
option ipv6 'auto'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

config dsl 'dsl'
option annex 'b'
option xfer_mode 'ptm'
option line_mode 'vdsl'
adamsutton2101
Newbie
Posts: 7
Registered: 03-03-2016

Re: OpenWRT and Plusnet

@FrazUK for reference here is my configuration file (relevant bits) which does have a few differences compared to yours:

config interface 'wan'                            
        option ifname 'ptm0.101'                  
        option proto 'pppoe'                      
        option username 'USERNAME'
        option password 'PASSWORD'           
        option ipv6 'auto'          
        option keepalive '5'        
        option auto '1'                       

config vdsl 'dsl'                               
        option annex 'b'                        
        option firmware '/lib/firmware/vdsl.bin'
        option tone 'av'      
        option xfer_mode 'ptm'

So looks like the WAN configuration is the same. I can't remember if ATM relates to the VDSL (it's ages since i did this, but I vaguely remember this related to a possible alternative configuration, so guessing it's redundant here).

 

I haven't specified line_mode, maybe 'vdsl' is the default. And I've explicitly specified the firmware path, not sure if that has a default. I also can't remember where the firmware came from and whether it had to be manually inserted rather than part of the default binary.

 

So possibly a couple of things to check.

 

Adam

 

Krazeh
Grafter
Posts: 84
Registered: 06-02-2013

Re: OpenWRT and Plusnet

FrazUK, the only difference between your config and mine appears to be that I have a 'wan_dev' section.

 

config device 'wan_dev'
        option name 'ptm0'
        option macaddr '<macaddr>'

 

Did your original config file have anything similar? You should be able to use

 

config device 'wan_dev'
        option name 'ptm0'
        option macaddr 'f4:f2:6d:bf:f5:34'

Add that in and give it a try.