cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

TurboApples
Newbie
Posts: 3
Registered: ‎17-10-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Was just typing this as it notified me you had replied - I managed to get my working - I had somehow missed off the ip route command. :rolleyes:

However, I needed to make some changes to the NAT configuration from your original guide as it just would not work for me with those settings. Also, in the original guide I believe there is an error with the dhcp config, the default-router should be 192.168.1.254.

Below is my config incase it helps anyone else and thanks for doing the orignial guide in the first place!

 

!
hostname PlusNetRouter
!
!         
ip source-route
!
!
!
ip cef
no ipv6 cef
!
!
!
vtp mode transparent
!
!
!
!
controller VDSL 0
!
!
interface Ethernet0
 no ip address
!
interface Ethernet0.101
 description Tagging for PPPoE (VDSL 0)
 encapsulation dot1Q 101
 no ip redirects
 no ip proxy-arp
 ip virtual-reassembly in
 pppoe-client dial-pool-number 1
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 switchport access vlan 10
 no ip address
!
interface FastEthernet1
 switchport access vlan 10
 no ip address
!
interface FastEthernet2
 switchport access vlan 10
 no ip address
!
interface FastEthernet3
 switchport access vlan 10
 no ip address
!
interface Vlan1
 no ip address
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan10
 description locals
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
interface Dialer0
 mtu 1492
 ip address negotiated
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1
 ppp authentication pap chap ms-chap callin
 ppp chap hostname username@plusdsl.net
 ppp chap password 0 Password
 ppp ipcp address accept
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool LAN
 network 192.168.1.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4
 default-router 192.168.1.254
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
!

 

witherford
Grafter
Posts: 41
Thanks: 5
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Was just typing this as it notified me you had replied - I managed to get my working - I had somehow missed off the ip route command. Roll eyes

 

That was my first guess in my response :rolleyes:

 

 

witherford
Grafter
Posts: 41
Thanks: 5
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

HI did you have any chance to try my suggestions?

Pr0NKula
Dabbler
Posts: 18
Registered: ‎10-10-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Hi, Sorry I haven't got a chance so far to test it again, I was setting up my server cabinet and getting everything working with that, also a new wireless network.

I'll hopefully try and get back at it tonight, I've talked with one of my lecturer's and he thinks it might be NAT that isn't configured correctly, though I'm using your config and it seems like that's fine?

Pr0NKula
Dabbler
Posts: 18
Registered: ‎10-10-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

My lecturer pointed something out than your config for the 887 had a NAT pool, he said it looked like it was pointing to another router or a modem.

TurboApples
Newbie
Posts: 3
Registered: ‎17-10-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Maybe you need to make the same changes I did. Dont use a NAT pool command, make sure the default-router in DHCP points to 192.168.1.254 and that Dialer0 is used in the NAT settings rather than Ethernet0.101

Basically replace DHCP and NAT settings with this: (use whatever DNS servers you want)

 

ip dhcp pool LAN
 network 192.168.1.0 255.255.255.0
 dns-server 8.8.8.8 8.8.4.4
 default-router 192.168.1.254
!
ip nat inside source list 1 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 Dialer0
!
access-list 1 permit 192.168.1.0 0.0.0.255

witherford
Grafter
Posts: 41
Thanks: 5
Registered: ‎19-07-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

I do need to correct some errors with my NAT but i cannot amend the post unfortunately.

Pr0NKula
Dabbler
Posts: 18
Registered: ‎10-10-2019

Re: Cisco 887VA or 897VA Router setup on Plusnet FTTC guide

Well, I was kind of sick of having to try to set this up and pulling my hair out so I bought a Cisco RV130W and it took literally less than 10 seconds to set up and have a working connection.