cancel
Showing results for 
Search instead for 
Did you mean: 

Edgerouter POE unable to connect to internet

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Edgerouter POE unable to connect to internet

I'm new to the forum, and to the world of routers.

I've tried to configure thig futer, but have no internet connection. I set router up using the WAN+2LAN2 wizard.

Looking at other posts, its notable that my pppoE IP address is 172.22.37.29/32. This suggests it is in the private range, and implies a username or password error, however both appear to be correct.

Downloading the config file, and comparing with others posted, its noticeable that section showing port forwarding, hairpin enable, wan-interface pppoe is missing, but I may just be misunderstanding the example config file. 

The log file shows 

 

I am not seeing any outbound or inbound traffic

All help gratefully received!

20 REPLIES
killsta
Dabbler
Posts: 18
Thanks: 1
Registered: 11-01-2017

Re: Edgerouter POE unable to connect to internet

Can you post your config?

 

Here is mine for PPPOE authentication:

 

ethernet eth0 {
description "Internet (PPPoE)"
duplex auto
pppoe 0 {
default-route auto
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
mtu 1492
name-server auto
password ****************
user-id xxx@plusdsl.net
}

Community Veteran
Posts: 38,244
Thanks: 933
Fixes: 54
Registered: 15-06-2007

Re: Edgerouter POE unable to connect to internet

What actually are you trying to do and what are you connecting it to as this unit is neither an ADSL or FTTC capable router

killsta
Dabbler
Posts: 18
Thanks: 1
Registered: 11-01-2017

Re: Edgerouter POE unable to connect to internet

These are enterprise routers, it will be connected to a DSL model Smiley (Hopefully!)

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

The Router is connected to a BT Openreach fibre broadband modem.

Community Veteran
Posts: 38,244
Thanks: 933
Fixes: 54
Registered: 15-06-2007

Re: Edgerouter POE unable to connect to internet

what format are you using for the username as it should be username@plusdsl.net with your normal account password

Plusnet Staff
Plusnet Staff
Posts: 183
Thanks: 43
Fixes: 4
Registered: 29-04-2013

Re: Edgerouter POE unable to connect to internet

Good Afternoon,

 

Can you PM me your Plusnet username please. If you're getting a 172.x.x.x IP address, this generally infers that the DSLAM has placed you in the walled garden due to repeated failed connection attempts.  With your username, I can access your account and check that for you.

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

My config;

 

ubnt@ubnt:~$ cat /config/config.boot                                           

firewall {                                                                     

    all-ping enable                                                            

    broadcast-ping disable                                                     

    ipv6-receive-redirects disable                                             

    ipv6-src-route disable                                                     

    ip-src-route disable                                                       

    log-martians enable                                                        

    name WAN_IN {                                                              

        default-action drop                                                    

        description "WAN to internal"                                          

        rule 10 {                                                              

            action accept                                                       

            description "Allow established/related"                            

            state {                                                            

                established enable                                              

                related enable                                                 

            }                                                                  

        }                                                                       

        rule 20 {                                                              

            action drop                                                        

            description "Drop invalid state"                                    

            state {                                                            

                invalid enable                                                 

            }                                                                  

        }                                                                      

    }                                                                          

    name WAN_LOCAL {                                                           

        default-action drop                                                    

        description "WAN to router"                                            

        rule 10 {                                                              

            action accept                                                       

            description "Allow established/related"                            

            state {                                                            

                established enable                                              

                related enable                                                 

            }                                                                  

        }                                                                       

        rule 20 {                                                              

            action drop                                                        

            description "Drop invalid state"                                    

            state {                                                            

                invalid enable                                                 

            }                                                                  

        }                                                                      

    }                                                                          

    options {                                                                  

        mss-clamp {                                                            

            mss 1412                                                           

        }                                                                       

    }                                                                          

    receive-redirects disable                                                  

    send-redirects enable                                                      

    source-validation disable                                                  

    syn-cookies enable                                                         

}                                                                               

interfaces {                                                                   

    bridge br0 {                                                               

        address 192.168.1.1/24                                                 

        aging 300                                                              

        bridged-conntrack disable                                              

        description "Local Bridge"                                              

        hello-time 2                                                           

        max-age 20                                                             

        priority 32768                                                          

        promiscuous enable                                                     

        stp false                                                              

    }                                                                           

    ethernet eth0 {                                                            

        address dhcp                                                           

        description "Internet (PPPoE)"                                          

        duplex auto                                                            

        poe {                                                                  

            output off                                                         

        }                                                                       

        pppoe 0 {                                                              

            default-route auto                                                 

            firewall {                                                         

                in {                                                           

                    name WAN_IN                                                

                }                                                              

                local {                                                        

                    name WAN_LOCAL                                             

                }                                                               

            }                                                                  

            mtu 1492                                                           

            name-server auto                                                   

            password NNNN                                               

            user-id NNNN                                

        }                                                                       

        speed auto                                                             

    }                                                                          

    ethernet eth1 {                                                             

        bridge-group {                                                         

            bridge br0                                                         

        }                                                                       

        description "Local Bridge"                                             

        duplex auto                                                            

        poe {                                                                   

            output off                                                         

        }                                                                      

        speed auto                                                             

    }                                                                          

    ethernet eth2 {                                                            

        description "Local Bridge"                                             

        duplex auto                                                            

        poe {                                                                  

            output off                                                          

        }                                                                      

        speed auto                                                             

    }                                                                           

    ethernet eth3 {                                                            

        description "Local Bridge"                                             

        duplex auto                                                             

        poe {                                                                  

            output off                                                         

        }                                                                       

        speed auto                                                             

    }                                                                          

    ethernet eth4 {                                                             

        description "Local Bridge"                                             

        duplex auto                                                            

        poe {                                                                  

            output off                                                         

        }                                                                      

        speed auto                                                             

    }                                                                          

    loopback lo {                                                              

    }                                                                          

    switch switch0 {                                                           

        bridge-group {                                                         

            bridge br0                                                         

        }                                                                       

        description "Local Bridge"                                             

        mtu 1500                                                               

        switch-port {                                                           

            interface eth2 {                                                   

            }                                                                  

            interface eth3 {                                                    

            }                                                                  

            interface eth4 {                                                   

            }                                                                   

            vlan-aware disable                                                 

        }                                                                      

    }                                                                           

}                                                                              

service {                                                                      

    dhcp-server {                                                              

        disabled false                                                         

        hostfile-update disable                                                

        shared-network-name LAN_BR {                                           

            authoritative enable                                               

            subnet 192.168.1.0/24 {                                            

                default-router 192.168.1.1                                     

                dns-server 192.168.1.1                                         

                dns-server 208.67.222.222                                      

                lease 86400                                                    

                start 192.168.1.38 {                                           

                    stop 192.168.1.243                                         

                }                                                              

            }                                                                   

        }                                                                      

        use-dnsmasq disable                                                    

    }                                                                           

    dns {                                                                      

        forwarding {                                                           

            cache-size 150                                                      

            listen-on br0                                                      

        }                                                                      

    }                                                                          

    gui {                                                                      

        http-port 80                                                           

        https-port 443                                                         

        older-ciphers enable                                                   

    }                                                                          

    nat {                                                                      

        rule 5010 {                                                            

            description "masquerade for WAN"                                   

            outbound-interface pppoe0                                          

            type masquerade                                                    

        }                                                                      

    }                                                                           

    ssh {                                                                      

        port 22                                                                

        protocol-version v2                                                     

    }                                                                          

}                                                                              

system {                                                                        

    host-name ubnt                                                             

    login {                                                                    

        user NNNN {                                                             

            authentication {                                                   

                encrypted-password NNNN            

            }                                                                  

            level admin                                                        

        }                                                                      

    }                                                                           

    ntp {                                                                      

        server 0.ubnt.pool.ntp.org {                                           

        }                                                                      

        server 1.ubnt.pool.ntp.org {                                           

        }                                                                      

        server 2.ubnt.pool.ntp.org {                                           

        }                                                                      

        server 3.ubnt.pool.ntp.org {                                           

        }                                                                       

    }                                                                          

    offload {                                                                  

        hwnat disable                                                           

        ipv4 {                                                                 

            forwarding enable                                                  

            pppoe enable     

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

Ah,

 

I have username@plusnetdsl.net.          

 

I'll try that            

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

Progress. Thank-you. Changing the username gave me a more valid IP address for pppoE: 

Which is consistent with the WAN IP address

 

But still no internet. Error message is DNS_PROBE_FINISHED_NO_INTERNET

Log is;;

killsta
Dabbler
Posts: 18
Thanks: 1
Registered: 11-01-2017

Re: Edgerouter POE unable to connect to internet

If you've got a valid WAN IP now then that's progress. Looks like your config is somehow preventing access.

Try the following:-

configure
delete interfaces

Paste the following commands, ensure to replace your user/pass in lines 8 and 9.

 

set interfaces ethernet eth0 description 'Internet (PPPoE)'
set interfaces ethernet eth0 duplex auto
set interfaces ethernet eth0 pppoe 0 default-route auto
set interfaces ethernet eth0 pppoe 0 firewall in name WAN_IN
set interfaces ethernet eth0 pppoe 0 firewall local name WAN_LOCAL
set interfaces ethernet eth0 pppoe 0 mtu 1492
set interfaces ethernet eth0 pppoe 0 name-server auto
set interfaces ethernet eth0 pppoe 0 password xxxxxxxx
set interfaces ethernet eth0 pppoe 0 user-id nnnnnnnn
set interfaces ethernet eth0 speed auto
set interfaces ethernet eth1 description Local
set interfaces ethernet eth1 duplex auto
set interfaces ethernet eth1 speed auto
set interfaces ethernet eth2 description Local
set interfaces ethernet eth2 duplex auto
set interfaces ethernet eth2 speed auto
set interfaces ethernet eth3 description Local
set interfaces ethernet eth3 duplex auto
set interfaces ethernet eth3 speed auto
set interfaces ethernet eth4 description Local
set interfaces ethernet eth4 duplex auto
set interfaces ethernet eth4 poe output pthru
set interfaces ethernet eth4 speed auto
set interfaces loopback lo
set interfaces switch switch0 address 192.168.4.1/24
set interfaces switch switch0 description Local
set interfaces switch switch0 mtu 1500
set interfaces switch switch0 switch-port interface eth1
set interfaces switch switch0 switch-port interface eth2
set interfaces switch switch0 switch-port interface eth3
set interfaces switch switch0 switch-port interface eth4
set interfaces switch switch0 switch-port vlan-aware disable

commit

 

 

Then try pinging google from the router Smiley

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

Just to check before I do this - (plus I will have to learn how to download, modify and reload config file).

I have reviewed the code you suggested in the config tree.

I have a bridge br0, with address 192.168.1.1/24. 

Your code doesn't appear to have a bridge - I am assuming this is replaced by the switch switch0.. I assume where your code has switch IP address 192.168.4.1/24 this reflects your individual needs, and I would need 192.168.1.1/24 - or am I incorrect? My bridge br0 has MTU 1500 and description local - as the proposed switch, but does not have any of the interfaces.

Is there a reason for doing a switch rather than a bridge? Would my bridge work if I added interfaces to it - assuming this is a sensible question?

All my other config code looks the same in the config tree

My brid

ukbikenerd
Dabbler
Posts: 11
Registered: 10-01-2017

Re: Edgerouter POE unable to connect to internet

One other point I just noticed - my eth0 address is shown as DHCP, whereas the proposed code has no address shown - is this significant?

killsta
Dabbler
Posts: 18
Thanks: 1
Registered: 11-01-2017

Re: Edgerouter POE unable to connect to internet

You are correct.

However my method was to get a simple, working configuration up and running (the one I posted is a basic PPPOE WAN on eth0 with eth1/eth2/eth3/eth0 configured as standard switching (switch0)).

Once it is working you can add your custom configuration to suit your needs, i.e. bridging, etc.

killsta
Dabbler
Posts: 18
Thanks: 1
Registered: 11-01-2017

Re: Edgerouter POE unable to connect to internet

My eth0 doesn't show as address DHCP:

 

interfaces {
ethernet eth0 {
description "Internet (PPPoE)"
duplex auto
pppoe 0 {
default-route auto
firewall {
in {
name WAN_IN
}
local {
name WAN_LOCAL
}
}
mtu 1492
name-server auto
password ****************
user-id xxxxxx@plusdsl.net
}
speed auto
}
ethernet eth1 {
description Local
duplex auto
speed auto
}
ethernet eth2 {
description Local
duplex auto
speed auto
}
ethernet eth3 {
description Local
duplex auto
speed auto
}
ethernet eth4 {
description Local
duplex auto
poe {
output pthru
}
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.4.1/24
description Local
mtu 1500
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}