cancel
Showing results for 
Search instead for 
Did you mean: 

ARP Request

griggzee
Newbie
Posts: 2
Registered: ‎22-06-2020

ARP Request

Hi Guys

I've had some issues with my Wifi ( disconnecting, not accepting passwords)

I've read through a post yesterday and it sounds like a firmware issue. I just wanted to see if anyone else is experienced issues with ARP request to the router?

When I join my network sometimes I don't get an IP Address. Its takes about 10 minutes and eventually I get one assigned. Sometimes I'll have an address ( I'm assuming I still have the lease) and I can't ping my router but can ping everything else on my network. Again after about 10 minutes, it comes back to life. I've been doing a bit of investigation and what I'm finding is that My PC is sending DHCP Discover messages but not getting a reply. eventually, I will get a response.

So, next, I used another device to serve as a DHCP server. I was getting an address much quicker but again couldn't browse the web for about 10 minutes. Long enough story short, It seems that my Plusnet router is not responding to ARP Requests. I've been using Wireshark and I can see requests are being sent by my Laptop but not being responded too. I've also set up another PC with Wireshark and can see the broadcast message. So, that to me says the router is unable to access its own Mac address or is unable to process frames ... not sure but just thought it was interesting ( well if your a geek like me 🙂 )

Not sure if anyone has experienced any of the above symptoms or if it's linked with the need for a firmware update?

Cheers

3 REPLIES 3
Strat
Moderator
Moderator
Posts: 30,219
Thanks: 3,230
Fixes: 495
Registered: ‎14-04-2007

Re: ARP Request

Moderators Note
This topic has been moved from ADSL Broadband to My Router.

Customer and Forum Moderator. Windows 10 Firefox 86.0 (64-bit)

VileReynard
Hero
Posts: 12,536
Thanks: 615
Fixes: 19
Registered: ‎01-09-2007

Re: ARP Request

If your wifi signal strength is weak, its quite possible for the router to fail to get a valid response to an ARP query, causing it to think your PC has died or something...

Have you checked your signal strength at the PC with a mobile app?

"In The Beginning Was The Word, And The Word Was Aardvark."

griggzee
Newbie
Posts: 2
Registered: ‎22-06-2020

Re: ARP Request

I did have this thought as well. I have experienced it about 6ft away from the router with a signal strength of about -30 to -40 dB.

I’ve also tried running with smart channels and Manual mode using a channel that doesn’t over lap with anyone else around me.

I’ve even tried using a different Access point and still get the same results.

Interesting one of my neighbours ( not attached to my house is running 5Ghz and his signal is stronger then my 2.4Ghz when I’m sat next to the router. Weird, being as 5Ghz should have a lot less penetration power as it’s a higher frequency. Plus being sat next to the router should make my signal the strongest ( provided my router is as powerful as next doors)