cancel
Showing results for 
Search instead for 
Did you mean: 

Strange behaviour when logging in to Member Centre

Pooh
Dabbler
Posts: 13
Thanks: 1
Registered: 26-10-2016

Strange behaviour when logging in to Member Centre

Hi,

Tried searching on the above title to see if it has already been solved, but nothing came up.

For a few weeks now, whenever I start a new session on my browser and log in to the PN Member Centre two issues have arisen:

The first is that Auto Login doesn't "stick", i.e. it seems to accept my enabling it, but next session it asks me to log in again.

Second, having logged-in, the next page to come up is always my payment details !  I did change bank recently but the direct debit is fully set-up and a payment has been successfully taken by PN so I know there is no issue with the DD.

I've tried all the usual stuff - deleted all PN cookies, cleared the browser cache - but it makes no difference.

Can anybody help ?

Thanks.

8 REPLIES
kjpetrie
Rising Star
Posts: 109
Thanks: 9
Fixes: 1
Registered: 19-12-2010

Re: Strange behaviour when logging in to Member Centre

Well, auto login can't stick if you clear cookies, since it will use at least one cookie to achieve it. Is your browser set to clear cookies on exit, perhaps (may be called Private Browsing Mode or some such thing)? The page to be displayed on log in might also be set by a cookie. (I don't know how PN implements it, but that is one way it's often done.) So the two symptoms both point to automatic deletion of cookies, probably as a result of a privacy setting in your browser.

 

Moderator
Moderator
Posts: 16,841
Thanks: 1,942
Fixes: 133
Registered: 06-04-2007

Re: Strange behaviour when logging in to Member Centre

@Pooh

Some years ago there was an anomolly with Auto-login where setting a period of greater than two years caused it to fail to work properly. Could this be part of the issues you are experiencing?

Forum Moderator and Customer
Courage is resistance to fear, mastery of fear, not absence of fear - Mark Twain
He who feared he would not succeed sat still

Pooh
Dabbler
Posts: 13
Thanks: 1
Registered: 26-10-2016

Re: Strange behaviour when logging in to Member Centre

Thanks kjpetrie, but I've checked "delete cookies on exit" settings and they're fine - in anycase, all other sites that use cookies are not affected.

I only deleted the cookies to check that when PN created new ones I still had the problem, and I do.

Pooh
Dabbler
Posts: 13
Thanks: 1
Registered: 26-10-2016

Re: Strange behaviour when logging in to Member Centre

Thanks Mav, I had also seen threads about using 2 years as the period.  Sadly, this doesnt make any difference.

Community Veteran
Posts: 4,987
Thanks: 1,154
Fixes: 29
Registered: 16-10-2014

Re: Strange behaviour when logging in to Member Centre

Hello @Pooh, can you tell us what browser and OS you are using please?

Pooh
Dabbler
Posts: 13
Thanks: 1
Registered: 26-10-2016

Re: Strange behaviour when logging in to Member Centre

Hi, I am using Firefox 53 on Windows 10.

Community Veteran
Posts: 4,987
Thanks: 1,154
Fixes: 29
Registered: 16-10-2014

Re: Strange behaviour when logging in to Member Centre

Thanks @Pooh, you might want to have a read of this link as regards your password management.

Pooh
Dabbler
Posts: 13
Thanks: 1
Registered: 26-10-2016

Re: Strange behaviour when logging in to Member Centre

Thanks for the response Mook, but I dont see what Passwords has to do with my issue.

The problem with seeing my Payment Details as the first page post log-in is, as post log-in would imply, after completing the password page.

Also, when Auto Login worked previously, you didnt need to enter your password which was pretty much the point of Auto Login.