cancel
Showing results for 
Search instead for 
Did you mean: 

Failed Billing

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Failed Billing

Why, after all this time, is there still an ongoing issue with the payment system on plusnet?  I can't even begin to explain how incredibly frustrating this is, from a customer point of view.

I don't need to go into too much detail as, I see, many others have already shared their experiences of this very issue, but just to confirm it would seem I am one of a small handful of customers who, no matter what, cannot process payment on their account.

Just like others have mentioned, the account restrictions kick in almost immediately after 'failed payment' where the 'splash page' is meant to appear, but doesn't.  Connections to Akamai sites, it would seem, are successful, but, and most importantly of all, any attempt to reach the plusnet website is blocked.  This then creates something of a security nightmare as it leaves only two options:

1. Log in via an alternative connection (mobile or otherwise) which isn't a particularly good idea when submitting personal details (or)

2. Contact customer services via telephone.

For those interested, I tried both methods, and both encountered issues along the way.

When logging in via an alternative internet connection, upon trying to process payments, I am greeted with: "Error Sorry, we are not able to complete this request at the moment, please try again later."

My previous experience of calling the contact centre (back in January) gave me the following issue - payment couldn't be processed over the phone as the system wouldn't allow payment to be processed at their end either.  To quote a ticket: "When trying to take this payment from yourself I was unable to do so but I have raised this due to it's an issue we are experiencing where we are faced with an empty assignment key when trying to take payment."

This, then, presents the customer with something of a headache - you can try to make a payment, but no matter how you try, payment cannot be processed.

For me, back in January, this meant I was hit with a bill for four months or so.  That's not great so soon after the festive period.  But I did have a connection for this period, and of course I expect to pay.  There's no problem there.  You provide a service, I pay as a customer.

When the contact centre aren't able to process payment, their advice is generally to call back again later to try again.  What's more, every time the contact centre are reached, they seemingly create a new ticket rather than tag this onto existing open tickets.  This all then leads to a frustrating experience for the end user, and generally slows down any response due to the number of open tickets.

To cut a long story short, after many months of goodwill gestures, and correspondence with the complaints team, once again this morning I was presented with account restrictions, the failed billing splash page issue where it failed to appear (including account restrictions being applied almost immediately after the failed billing) and the exact same issue when trying to process payment via alternative routes.

This isn't good enough.  It has been going on for far too long now, and this isn't the way I expect to be treated as a customer after being loyal for so many years.  You were a great company when I joined, and I would like to think that I will be with you for many more years to come, but I am by no means happy at the moment.  I think the biggest problem with this ongoing issue is the amount of frustration and time it takes, as a customer, to resolve it even though it's no fault of my own, as a customer.  You seem to put all of the emphasis back onto the customer to fix this by requesting multiple calls and contact in order to attempt to take a payment.  Where a service is provided, I'm happy to pay - so let me!

I have offered to work with the complaints team to try and troubleshoot this ongoing issue, and to feed my continued experiences in by means of attempting to try and improve the way this is handled in the future to avoid others from having to face the same frustrating experience.  Although this was acknowledged by a fantastic member in complaints (just the once), unfortunately any open dialogue with the complaints team is constantly closed automatically due to inactivity, which isn't great when you consider there is likely to be a gap of at least a month (the billing period) between communications - sometimes longer if a goodwill gesture credit is applied to the account.

I understand my issue was passed to the internal investigations in order to try and resolve, and I haven't been given any method of contacting that team directly, so I just wanted to let you know today that it would seem that, unfortunately, I'm now back to square one where all of the problems have returned.  I just want to know the way forward now.  I have been fair and reasonable throughout, but I am incredibly disappointed now.  The new systems, not just billing, but the lithium customer services platform, just aren't working it would seem - they are contributing to a bad customer experience.

 

 

 

 

36 REPLIES 36
Highlighted
Superuser
Superuser
Posts: 15,914
Thanks: 6,381
Fixes: 47
Registered: ‎22-08-2007

Re: Failed Billing

Out of background interest, why do you keep falling in to failed payments?  Is the system having an issue of processing your automatic payment method - Direct Debit or Payment Card (credit or debit)?

When you say connections to Plusnet are blocked EXACTLY what do you see?  A browser error with "Connection Refused"?

 

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

There was a change of details on file in order to keep payment details current and up to date, and the errors, it seems, began shortly after this.  To confirm, yes, the system is failing to automatically process payment.

 

EDITED TO ADD:  I seem to recall that it took several attempts to amend the details via the member portal as I was getting multiple errors on the days whilst trying to update the payment details.  So thinking back, there was even a problem with the system when trying to keep account details current and up to date.  Hope this additional information will be of some use.

 

Highlighted
Superuser
Superuser
Posts: 15,914
Thanks: 6,381
Fixes: 47
Registered: ‎22-08-2007

Re: Failed Billing

Sorry to re-ask the question to avoid ambiguity (the SUs have a number of on-going discussions taking place) but I need to be clearer about the details here.

1. Are you confirming that the authorised automatic payment method (DD or Card) on your account is failing due to a systems issue (not for other reasons outside of PlusNet's control)?

2. When you attempt to access http://failled.billing.plus.net or http://plus.net you DO NOT see the splash screen, but see some (apparently) network level error?

Whilst the end result might be the same there seems to be a number of differences in the details of experiences reported by users.  Such differences are likely to need different resolutions.

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

1. To confirm, yes, both customer services and ticket correspondence have confirmed that where my experience is concerned, this is an internal error on the plusnet automatic payment processing side of things.  Payment details held on file have been confirmed to be current and valid.

2. With regard to the failed billing splash screen, when this happened today I was effectively taken to the router log in page, but when the splash page failed to appear previously (in January) no web pages would load at all - The only reason I knew there was an issue was because the URL on the browser changed to failed.billing.plus.net/apps/payment/failed  - it was the same today.  Although the splash page rerouted to the router log in page, the url it was trying to reach was always failed.billing.plus.net/apps/payment/failed via 212.159.8.18

 

Just to add, I don't know if there is a trend with this error, but it's worth noting that I believe PlusNet SafeGuard is enabled on my connection, so it is entirely possible that SafeGuard could be responsible for preventing the splash screen from appearing following a failed payment.

Highlighted
Superuser
Superuser
Posts: 15,914
Thanks: 6,381
Fixes: 47
Registered: ‎22-08-2007

Re: Failed Billing

Cheers, you have answered my next question.

I was starting to wonder if what you are seeing (router log in screen) is consequential to this https://community.plus.net/t5/My-Account-Billing/Payment-Reminder/m-p/1646654#M41593 - but with SG enabled and / or an option on the Plusnet routers (which eludes me at the moment) means that you see the router log on page instead?

Which router are you using?

Superuser citation

This topic has been cited by one of the Superusers; the purpose of which is to provide a note for information which might help to focus continued discussion (but might not result in a staff response).


 

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

TG582n as supplied by plusnet as a replacement to a router, of the same model, which was supplied upon signing up with plusnet.  The replacement came about because the original router developed a loud whistle.  I don't believe this router was plug and play, so to speak, as account details had to be added manually.  Whereas the original was a heavily plusnet branded router, the newer one uses the original technicolor themes with no plusnet branding.

Highlighted
Superuser
Superuser
Posts: 15,914
Thanks: 6,381
Fixes: 47
Registered: ‎22-08-2007

Re: Failed Billing

I'm still kicking the tyres on this - do you have a static IP address per chance?

If not can you please share A.B.x.x of your IP address please?

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

It's a dynamic IP, currently 146.90.x.x

Highlighted
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 1,915
Fixes: 75
Registered: ‎11-01-2018

Re: Failed Billing

Hi @luk

 

Thanks for getting back in touch. I'm sorry to hear that your payment issues are ongoing.

 

I've reopened your complaint ticket here and asked your case handler to get in touch accordingly.

 

Best wishes

 

Dave

Highlighted
Aspiring Pro
Posts: 223
Thanks: 82
Fixes: 1
Registered: ‎23-09-2018

Re: Failed Billing

On a previous post an Agent told a Customer,,,, " What he did say, which I find incredible but honest, was that he could not guarantee that the exact same issue wouldn't happen on my account next month or the next etc. "

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

Once again, failed payment, no splash screen appearing and restrictions have, again, been applied to the account immediately and all methods of being able to pay are either broken with an error message or two (via alternative connection) or inaccessible via my plusnet connection.  If someone at plusnet can be kind enough to at least remove the restrictions on the account, that would be a good start.  I will then pick up again on the open ticket and take things from there.

Highlighted
Superuser
Superuser
Posts: 15,914
Thanks: 6,381
Fixes: 47
Registered: ‎22-08-2007

Re: Failed Billing

Highlighted
Plusnet Alumni (retired)
Plusnet Alumni (retired)
Posts: 442
Fixes: 19
Registered: ‎25-09-2018

Re: Failed Billing

Hi there @luk

 

I have removed the restrictions for you. Please accept my apologies for any inconvenience caused.

You should now be able to access the open ticket and reply at your leasure.

Highlighted
Grafter
Posts: 34
Thanks: 18
Registered: ‎18-04-2013

Re: Failed Billing

Townman, plus.net could not be reached at all during the restrictions.  Initially all attempts to access the website, including the failed billing splash page, were diverted to dsldevice.lan which in turn brought up a locally hosted webpage to say unable to connect.

I had a feeling diversions to dsldevice.lan were a result of 'Web Browsing Interception' being enabled on the gateway device, so I deactivated this and tried again.  That prevented the locally hosted webpage from being displayed, and stopped the diversion to dsldevice.lan however any attempts to reach plus.net or the payment page after this tweak was applied simply didn't work.  The server and web page could not be reached.

Further to my first post on Sunday, during my restrictions earlier today, I tried to connect to the failed billing splash page, and also the plus.net website via the main plusnet name servers rather than the SafeGuard name servers.  It made no difference.

Once again, just like on Sunday, during the restrictions I logged in via an alternative connection (mobile) and tried to process a payment.  Two attempts were made.  The first brought back the following error:

Sorry, an error occurred.
Error
The error has been recorded and our website team will investigate.
Please try again later.

The second attempt stated:

There's currently a problem with our system, please try again. If you continue to have problems, please contact our support team on 0800 432 0200.

After the restrictions were lifted, the first thing I did was log in via my plusnet connection in order to try and process a payment, and once again the same two errors came back.  Following that, as promised I added additional details to my open ticket with complaints, and I await their response and hopefully a prompt resolution.