cancel
Showing results for 
Search instead for 
Did you mean: 

High Ping / latency

pezzdr
Newbie
Posts: 2
Registered: ‎03-12-2018

High Ping / latency

Recently I "upgraded" my Speed with PlusNet offered a better deal more speed, was told I would be sent a new router, which was later only sent due to me asking where is it, I finish a conversation online with a PlusNet representative asking where my new router was then after revived a email saying the order had just been completed . The new router turned up (Hub One) replacing the 582n router and BT Open reach routers I had been given when I 1st joined PlusNet, Since then my Ping has gone from stable usually around 10-40ms to 200-500ms along with multiple disconnections.

I raised this as a fault and issue with PlusNet and the following day tried to to again to someone online from PlusNet only to be told this fault can 3-5 days for a response, while I am left with unplayable games.

I am also considering replacing the router provided with a tp link router in the hopes that this is just a poor build quality of the PlusNet Router.

Tags (3)
3 REPLIES 3
Plusnet Help Team
Plusnet Help Team
Posts: 12,968
Thanks: 4,025
Fixes: 643
Registered: ‎21-04-2017

Re: High Ping / latency

Sorry to hear you're having issues with your latency.

Are you able to plug your Openreach modem and Technicolor router back in to see if the issue goes away?

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team
pezzdr
Newbie
Posts: 2
Registered: ‎03-12-2018

Re: High Ping / latency

I have changed the router back to the older one, ping has vastly improved back to what it was, in the range of 20-40ms. However I did speed test with the Hub One router and received 50-60mb on various dates and time both on and off peak. The ISP always came up as BT Americas, now I am using the older router it now has returned back PlusNet as my current ISP and my current speeds are 30-40mb. 

Plusnet Help Team
Plusnet Help Team
Posts: 12,968
Thanks: 4,025
Fixes: 643
Registered: ‎21-04-2017

Re: High Ping / latency

Thanks for getting back to us.

Were you connecting over WiFi or via ethernet when you did the tests? This may explain the issues you're having with the speed on your older router, as well as latency on your new router.

There's no reason why your Technicolor router can't handle the full speed. 

The fact that the ISP shows BT Americas is just a red herring, it wouldn't have any affect on your service. It'll be due to the geolocation database of the IP address your router is assigned that the website is drawing from being out of date.

If this post resolved your issue please click the 'This fixed my problem' button
 Anoush Mortazavi
 Plusnet Help Team