cancel
Showing results for 
Search instead for 
Did you mean: 

Problem connecting Chromecast to Plusnet Hub Two

FIXED
Shaun68
Newbie
Posts: 2
Registered: Sunday

Problem connecting Chromecast to Plusnet Hub Two

I have read, and followed the suggestions offered by, a couple of previous posts regards a similar problem others have had regarding Chromecast, however my problem remains. I have factory reset the Chromecast as well as the hub a couple of times, there doesn’t appear to be any AP isolation that can be disabled in the router wireless settings and I have tried two Chromecast devices, both of which have previously worked okay with other BT routers.

The Chromecast device connects to my Android phone courtesy of Google Home, but then reports a problem when trying to connect to Wi-Fi - ‘Connection problem during setup - Could not communicate with your Chromecast’. There is nothing wrong with the strength of the Wi-Fi signal.

Is anyone able to offer a solution to this problem?

3 REPLIES 3
the_groundsman
Rising Star
Posts: 455
Thanks: 14
Fixes: 2
Registered: ‎12-08-2007

Re: Problem connecting Chromecast to Plusnet Hub Two

Fix

Strangely I had similar problems in the past with Chromecast and chromecast audio devices. I found the issue was with the android device I was using to do the set up on the Home App. It temporarily disconnects from your wifi to the signal from the Chromecast device. In the end I found restarting the phone and disconnecting it from my router solved the issue. Intuitively I thought it must be a chromecast / router issue but it was actually an issue with my phone. I had a Moto phone at the time but it might be something of nothing to do with the phone model or the version of Android.

You're probably on an Apple phone Smiley 

Anyway hope that works for you.

Shaun68
Newbie
Posts: 2
Registered: Sunday

Re: Problem connecting Chromecast to Plusnet Hub Two

Well I'll be damned!

I was just about to reply having tried this earlier and it not worked, when I thought I'd give it one last shot and now after I don't know how many total attempts it has now finally connected.

Not sure what I did differently. Must have been something you said.

Cheers.

the_groundsman
Rising Star
Posts: 455
Thanks: 14
Fixes: 2
Registered: ‎12-08-2007

Re: Problem connecting Chromecast to Plusnet Hub Two

Who cares. So long as it's working 🙂