cancel
Showing results for 
Search instead for 
Did you mean: 

relay.plus.net Internal server error

Monsoft
Grafter
Posts: 33
Thanks: 6
Registered: ‎29-09-2019

relay.plus.net Internal server error

I'm hosting SMTP server for years in my home network and there was no issues until now.

I see in Postfix logs that each attempt to relay outgoing email via SMTP relay relay.plus.net is unsuccessful with error  "451 4.3.2 Internal server error":

Oct  3 09:12:39 mail postfix/smtp[64211]: E60361F6F7: to=<[email protected]>, relay=relay.plus.net[91.204.208.26]:25, delay=0.68, delays=0.07/0.36/0.16/0.08, dsn=4.3.2, status=deferred (host relay.plus.net[91.204.208.26] said: 451 4.3.2 Internal server error (in reply to RCPT TO command))

 

Here test using Swaks:

$ swaks -f [email protected] -t [email protected] -s relay.plus.net --header "Subject: Mail test"
=== Trying relay.plus.net:25...
=== Connected to relay.plus.net.
<- 220 mail.enmail.co ESMTP ready
-> EHLO leon
<- 250-mail.enmail.co
<- 250-AUTH PLAIN LOGIN
<- 250 STARTTLS
-> MAIL FROM:<[email protected]>
<- 250 2.0.0 OK
-> RCPT TO:<[email protected]>
<** 451 4.3.2 Internal server error
-> QUIT
*** Remote host closed connection unexpectedl

 

For me this looks like issue with configuration of SMTP service on relay.plus.net.

Does anybody see this errors as well ?

 

I can bypass Plusnet mail relay but I bet that 50% of my outgoing emails will be rejected by destination SMTP servers as my IP address even if it is static is market globally as dynamic and emails from it are marked as spam.

 

9 REPLIES 9
MisterW
Superuser
Superuser
Posts: 20,140
Thanks: 9,050
Fixes: 580
Registered: ‎30-07-2007

Re: relay.plus.net Internal server error

@Monsoft 

relay.plus.net has been switched to the Greenby proxy as part of the email migration project. Its sending policy is now 'hardened' in as much as it will only allow sending from an address that was hosted by Plusnet (and now Greenby).

Bottom line is that relaying email for your own domain (which is what you seem to be doing) will no longer work. You will either need to host your domain with a hosting service or use another smtp service. There's some suggestions on here that smtp2go may work. 

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

Monsoft
Grafter
Posts: 33
Thanks: 6
Registered: ‎29-09-2019

Re: relay.plus.net Internal server error

@MisterW Thanks for letting me know.


In my 30y job as linux sysadmin I will not call this move 'hardening'  but ... 

I guess this is all about money as whole mail service has been moved to 3rd party provider.

Its probably time to find mail-relay service or move my server to AWS or GCP

 

MisterW
Superuser
Superuser
Posts: 20,140
Thanks: 9,050
Fixes: 580
Registered: ‎30-07-2007

Re: relay.plus.net Internal server error

I guess this is all about money as whole mail service has been moved to 3rd party provider.

Not just about money, but also the problem of having the expertise to support the legacy email system in an organisation which is now effectively a broadband only supplier. 

There were two options, one drop the email facility completely (which is what many other ISPs have done!) or offload to a specialist provider. Fortunately the 2nd option was chosen which means most people will still have their email facility. Unfortunately some 'edge case' use of the smtp server such as using it to relay from a non-hosted domain no longer work.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

adflyer
Grafter
Posts: 37
Thanks: 26
Fixes: 1
Registered: ‎27-02-2019

Re: relay.plus.net Internal server error

@Monsoft TIL about swaks! +1 from me for that (indirect) pointer 🙂

Monsoft
Grafter
Posts: 33
Thanks: 6
Registered: ‎29-09-2019

Re: relay.plus.net Internal server error

"(host gmail-smtp-in.l.google.com[192.178.223.26] said: 550-5.7.1 [80.229.2.44] The IP you're using to send mail is not authorized to 550-5.7.1 send email directly to our servers. Please use the SMTP relay at your 550-5.7.1 service provider instead. For more information, go to 550 5.7.1  https://support.google.com/mail/?p=NotAuthorizedError ffacd0b85a97d-48b5b426b7fsi8253101f8f.282 - gsmtp (in reply to end of DATA command))

 

This is what I was thinking 

" Some ISPs may provide a way to get an IP that is authorized, either by upgrading to business class service or static IP service. "

 

Would be nice to have option to get my  IP that authorised as it's static for I guess 6 or even longer.

Meanwhile I will have a look to Cloudflare or  smtp2go. My outgoing email volume is like a 3-5 daily max so I should be able to get some free/basic tier from them.

starfry
Aspiring Pro
Posts: 326
Thanks: 27
Fixes: 3
Registered: ‎14-09-2007

Re: relay.plus.net Internal server error


@MisterW wrote:

@Monsoft 

There's some suggestions on here that smtp2go may work. 


Just to say that I was doing exactly the same thing (postfix -> plusnet relay) but I moved mine to smtp2go on the free plan and it works really well. You have to put 3 DNS records on any domains that you want to send from but it is a fantastic service and it's brilliant that you can go onto a portal and confirm the delivery of mail (it shows you the server the message was handed off to which is fantastic for troubleshooting delivery problems). Also you get dkim etc effectively for free.

I have some clients configured to send mail directly to the plusnet relay and they also stopped working, I think, last Thursday.

Monsoft
Grafter
Posts: 33
Thanks: 6
Registered: ‎29-09-2019

Re: relay.plus.net Internal server error

Thanks for info @starfry

Now I know what I'm going to do tonight 😉

mwwagain
Pro
Posts: 316
Thanks: 125
Fixes: 4
Registered: ‎03-12-2024

Re: relay.plus.net Internal server error

They do not need the whole 'legacy email system' though do they ?

 

Just an SMTP server that accepts traffic coming over PlusNet connections authorised by PlusNet IP+username+password sets.

 

I guess PlusNet will now avoid telling Greenby who is a legitimate user ?

Monsoft
Grafter
Posts: 33
Thanks: 6
Registered: ‎29-09-2019

Re: relay.plus.net Internal server error

That is true. For years I'm running cluster of smtp relay servers in organisation where I'm working to allow our projects to send emails. From experience I know that this is not much complicated and when is setup it doesn't need much babysitting when all monitoring and patching is in the place (my relays relay around 200K messages per day).

 

When I looked to logs of my home smtp server and I seen response error "Internal server error" from  relay.plus.net I though it had some issue or is miss-configured. I think that this error is massively misleading and it should really point to some website where it is explained what happened.

 

But anyway, I setup account on smtp2go and reconfigure my Postfix to use their mail relay servers and all works.

Thanks for pointing me in the right direction.