cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP Relay not working

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

SMTP Relay not working

I have a problem with my plusnet broadband, I raised a call on 9 Feb 2022. This is supposed to be a company with great service. I have raised it as a complaint, no response. Why has this company gone so bad? #PlusnetSupport

15 REPLIES 15
Townman
Superuser
Superuser
Posts: 23,256
Thanks: 9,761
Fixes: 162
Registered: ‎22-08-2007

Re: SMTP Relay not working

Not working in what manner?

What exactly are you trying to do which what technology?

What error message do you get?

Has this ever worked for you?

Are you connected to the Plusnet network or are you with some other ISP or using a mobile network?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

Essentially my plusnet IP address is blacklisted by local policy on relay.net.

Numerous calls to support and a complaint has failed to resolve the issue.

I am hoping this post and a few others will get plusnet to resolve it.

It was working until their system blacklisted the address.

 

 

Townman
Superuser
Superuser
Posts: 23,256
Thanks: 9,761
Fixes: 162
Registered: ‎22-08-2007

Re: SMTP Relay not working

Again can you please expand on the issue?

Black Listing is complex and is often misapplied by third party mail services.

Are your using your own mail server?

Is your connection to the relay.plus.net SMTP server authenticated?

Are you using a VPN?

Plusnet need a clearly articulated problem to attempt a fix - do you see the problem at the point of attempting to send the email or as a non-deliver rejection by a remote mail service?  If the latter, does that happen with all email services or just one?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

I gave them loads of info to resolve the fault including screen shots.

Fundamentally I am connecting to relay.plus.net on a server with its default gateway set to the plusnet broadbands router. The system has been in working for about 12 years.

I test it with a manual telnet session and their SMP server states "blacklisted by local policy".

Initially they blamed Spamhaus blacklist but that is clear.

It really is very straightforward but the Net Ops team just ignore the call and posting on here and elsewhere seemed to be the only way to get them to respond.

Just plain poor customer service.

 

 

 

Townman
Superuser
Superuser
Posts: 23,256
Thanks: 9,761
Fixes: 162
Registered: ‎22-08-2007

Re: SMTP Relay not working

Do you have a static or dynamic external IP address?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

Static

Townman
Superuser
Superuser
Posts: 23,256
Thanks: 9,761
Fixes: 162
Registered: ‎22-08-2007

Re: SMTP Relay not working

And you've had this static IP address since whenever?

In which case the change in behaviour here is quite odd.  I had thought that static IP addresses were excluded from the PBL ... so I checked mine first.  Sure enough of 91 blacklists checked, it only appears on Spamhaus' lists! Here is what they say...

Blacklist Check - HetrixTools

Outbound Email policy of Plusnet Plc for this IP range

It is the policy of Plusnet Plc that unauthenticated email sent from this IP address should be sent out only via the designated outbound mail server allocated to Plusnet Plc customers. To find the hostname of the correct mail server to use, customers should consult the original signup documentation or contact Plusnet Plc Technical Support.

Removal procedure

If you are not using normal email software but instead are running a mail server and you are the owner of a Static IP address in the range 84.92.0.0/16 and you have a legitimate reason for operating a mail server on this IP, you can automatically remove (suppress) your static IP address from the PBL database.

About The PBL

The Spamhaus Policy Block List (PBL) is an international anti-spam system maintained by The Spamhaus Project in conjunction with Internet Service Providers and is used by Internet networks to enforce inbound email policies. The PBL database lists end-user IP address ranges which should not be delivering unauthenticated email to any mail server except those provided for specifically for that customer's use. The PBL lists only IP addresses (not domains or email addresses).

 

So some further questions...

  • Is the SMTP server configuration set to use AUTHENTICATION?
  • Are you using port 587?
  • Are you using "normal email software" to SUBMIT email messages?
  • --- or
  • Are you running a mail server to SEND inter-MX messages?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

Mook
Seasoned Champion
Posts: 1,266
Thanks: 872
Fixes: 9
Registered: ‎27-12-2019

Re: SMTP Relay not working

Moderators Note : This topic has been moved from ADSL to Email
KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

I have checked and double checked every.

 

The IP address I have had for 10yrs maybe 15yrs.

 

The address is no listed in Spamhaus

 

The error is "Blaklisted by local policy" which screams a policy on relay.plus.net

  • Is the SMTP server configuration set to use AUTHENTICATION?
  • No authentication
  • Are you using port 587?
  • No 25
  • Are you using "normal email software" to SUBMIT email messages?
  • I am using a telnet session to identify the fault but I normally used php mail but since the fault is identified via telnet is irrelevant

 

This really is a straightforward problem on relay.plus.net but no one seems to engage with the problem.

 

We are over six weeks in, it is hopeless.

 

  • --- or
  • Are you running a mail server to SEND inter-MX messages?

 

 

 

 

adamwalker
Plusnet Help Team
Plusnet Help Team
Posts: 16,891
Thanks: 885
Fixes: 221
Registered: ‎27-04-2007

Re: SMTP Relay not working

Cheers for taking my call just now Kevin, as agreed I'm going to pick this back up on Monday when I'm in the office so I can go and speak with our net ops guys face to face and get more information on this so we know what to do next. 

If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
bobpullen
Community Gaffer
Community Gaffer
Posts: 16,904
Thanks: 5,012
Fixes: 316
Registered: ‎04-04-2007

Re: SMTP Relay not working

@KevinJones - can you post the output from a telnet transaction here (from your Plusnet IP address)?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

See Attachment

bobpullen
Community Gaffer
Community Gaffer
Posts: 16,904
Thanks: 5,012
Fixes: 316
Registered: ‎04-04-2007

Re: SMTP Relay not working

Thanks, that's pretty conclusive.

@adamwalker - NetOps shouldn't need any info beyond this screenshot (and @KevinJones IP address). Feel free to point them my way if they believe otherwise Wink

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

KevinJones
Newbie
Posts: 7
Thanks: 7
Registered: ‎10-06-2013

Re: SMTP Relay not working

Just to update everyone, the fault has been resolved with Bob's help.

Call was raised on Feb 9th, it was sorted on March 31st but I am delighted to see it working again even if it was a huge struggle to get plus net netops team to accept if was a problem on their server.