cancel
Showing results for 
Search instead for 
Did you mean: 

Mail client says problem with security certificate when connecting to plusnet imap

FIXED
cjags
Aspiring Pro
Posts: 498
Thanks: 22
Fixes: 4
Registered: ‎31-08-2007

Mail client says problem with security certificate when connecting to plusnet imap

The mail client on my tablet has stopped connecting to plusnet IMAP server.

It says

"There is a problem with the servers security certificate (it is self-signed, expired or has a hostname mismatch)."

Even if I say to trust it anyway, the client still cannot connect.

 

I can still log in via webmail so that is working OK.

 

3 REPLIES 3
Baldrick1
Moderator
Moderator
Posts: 11,155
Thanks: 4,925
Fixes: 401
Registered: ‎30-06-2016

Re: Mail client says problem with security certificate when connecting to plusnet imap

Fix

@cjags 

Are you using these settings, they have changed over the years. https://www.plus.net/help/email-guides/how-to-set-up-plusnet-email/?

Moderator and Customer
If this helped - select the Thumb
If it fixed it,  help others - select 'This Fixed My Problem'

cjags
Aspiring Pro
Posts: 498
Thanks: 22
Fixes: 4
Registered: ‎31-08-2007

Re: Mail client says problem with security certificate when connecting to plusnet imap

I was using those settings but I changed the outgoing server port to the other one and it started working.

I vaguely remember having that issues years ago (flipping the outgoing port cleared the problem).

Thanks for the suggestion.

Townman
Superuser
Superuser
Posts: 22,354
Thanks: 9,218
Fixes: 148
Registered: ‎22-08-2007

Re: Mail client says problem with security certificate when connecting to plusnet imap

The usual issue here is using an alias for the server name, mail.plus.net for imap.plus.ne or smtp.plus.net for smtp.plus.net. 

The alias essentially work but they are not in the certificate server identities.  "Flipping the port number" is more than likely not a "fix" but an avoidance of the issue by disabling encryption which the certificates facilitate.

 

For example, if it is the IMAP server changing the port from 933 to 143 turns encryption OFF!!!

Server configuration should be:

IMAP: imap.plus.net Port 993 encryption SSL/TLS

SMTP: relay.plus.net Port 587 encryption STARTTLS

The Plusnet published settings are flawed as they imply STARTTLS should be used for the IMAP server.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.