cancel
Showing results for 
Search instead for 
Did you mean: 

WebGL1 &2 disabled or unavailable

Community Veteran
Posts: 18,773
Thanks: 2,017
Fixes: 24
Registered: ‎06-11-2007

WebGL1 &2 disabled or unavailable

As my previous thread about PREY seemed to disintegrate, with no answers from my beloved followers/helpers....

nor any response from PREY themselves... (most disappointing) ..(unless they don`t work over the weekend  ? ? ?  Maybe an answer tomorrow)  

 

 

Anyway... on small 10 inch Hannspree laptop... (which has the same OS and progs as the DELL 15 inch laptop. ) I get a message saying the map cannot be displayed because (map displays ok on the Dell 15 inch) ...

 

 

WebGL 1 and WebGL2 are disabled or unavailable.

Sometimes this is the result of older video drivers being rejected by the browser. try updating your video drivers if possible

Also check out Get WebGL, or try installing the latest version of Chrome, or Firefox

 

Firefox is "up to date".. latest version installed. 

 

Going into Firefox Preferences page..

under the section ... Performance,

It shows Use recommended Performance Settings.. ( tick in the box)

but nothing about the hardware acceleration ,

until I remove the tick in the box... then it says

Use hardware acceleration when available.

content process limit      8 (default)

Either way... (Tick in first box or not ticked) the map does not show..  ...##

 

The little sticker on the laptop says "Intel Atom" inside !... so I looked for INTEL Video driver update, but drew a blank on that.

 

I have run "sudo apt update" and it does not report any updates needed.. ( recent downloaded updates also installed ).

 

Going to "Driver Manager" ( as superuser)   it shows a blank panel, and the words  "No proprietary drivers are in use" .. which is as helpful as a chocolate fire guard...

 

Going to the Firefox section on Troubleshoot ... for the Graphics section, it says  ( under the FEATURES

 

 

Compositing Basic

WebGL1 Driver Rendererer           WebGL creation failed:

*Refused to create native OpenGL content because of blacklist entry :

FEATURE_FAILURE_OPENGL_1

*Exhausted GL driver options.

 

WebGL2 Driver Renderer  WebGLcreation failed.. ( as above )

 

GPU#1

Active                   Yes

Description           Intel Open Source Technology Centre - Mesa DRI Intel(R)Pineview M

Driver ID              Mesa DRI Intel(R) Pineview M

Driver Version      1.4 Mesa 19.0.2

 

Decision Log

HW_COMPOSITING                blocked by default : Acceleration blocked by platform

OPENGL_COMPOSITING       unavailable by default:  Hardware compositing is disabled

WEBRENDER                          opt-in by default:  WebRender is an opt-in feature

                                                 unavailable by runtime: Hardware compositing is disabled

 

WEBRENDER_QUALIFIED     blocked by env: no qualified hardware

 

Haven`t a clue what all that means individually or collectively... 

 

However, it seems that since the machine was originally sold with Windows 7 starter installed... and now it has LINUX MINT 19.1 on it.. there is some difficulty updating drivers.

( same on the DELL 15 inch..  going to the Dell site and entering the Service number  to access the updated drivers results in a "no show"  due to the change of O.S.)

 

So, once again... I am in a quandry and don`t know the way forward to solve the problem.... any help,.... much appreciated ... as always.

Thanks

 

 

7 REPLIES 7
RPMozley
Aspiring Pro
Posts: 1,142
Thanks: 33
Fixes: 6
Registered: ‎04-11-2011

Re: WebGL1 &2 disabled or unavailable

What about this article? https://www.binarytides.com/enable-webgl-firefox-ubuntu/
That's RPM to you!!
Community Veteran
Posts: 18,773
Thanks: 2,017
Fixes: 24
Registered: ‎06-11-2007

Re: WebGL1 &2 disabled or unavailable

@RPMozley 

 

I read through that... did some terminal work...the first bit.... it said.. it was already installed.

couldnt find it  in "about:config" list..

skipped the last bit before this...

Test it

Now open the following url
http://get.webgl.org/

 

Clicked on the link and got the revolving cube  saying that the browser DOES support webgl.. 

 

CRAZY or what... !    still none the wiser... Crazy3

RPMozley
Aspiring Pro
Posts: 1,142
Thanks: 33
Fixes: 6
Registered: ‎04-11-2011

Re: WebGL1 &2 disabled or unavailable

It’s installed on the system, that’s a good start. Next is trying to locate where it is, not always easy to do. Is there a file search program installed in Mint? For Xubuntu the program is called “Catfish Search”.

That option within Firefox may not be there by default so you will have to add it manually. I think it can be added within Firefox on the config page, right click probably.
That's RPM to you!!
RPMozley
Aspiring Pro
Posts: 1,142
Thanks: 33
Fixes: 6
Registered: ‎04-11-2011

Re: WebGL1 &2 disabled or unavailable

Scratch that, maybe it is just the particular site you’re using that’s at fault, if it’s working fine on other pages.
That's RPM to you!!
mikelahey
Pro
Posts: 235
Thanks: 88
Fixes: 11
Registered: ‎24-11-2015

Re: WebGL1 &2 disabled or unavailable

It's probably because Linux is using a generic driver to drive the Intel display adaptor, therefore there is no 3D hardware acceleration for OpenGL support as these require hardware specific drivers.

mikelahey
Pro
Posts: 235
Thanks: 88
Fixes: 11
Registered: ‎24-11-2015

Re: WebGL1 &2 disabled or unavailable

A bit of detective work on the Intel website and  I reckon your GPU is probably an Intel GMA 3150,

https://www.intel.co.uk/content/www/uk/en/support/articles/000005526/graphics-drivers.html

You could try this package:

apt-get install cedarview-drm libva-cedarview-vaapi-driver cedarview-graphics-drivers

See: https://www.linuxquestions.org/questions/linux-general-1/intel-graphics-media-accelerator-3150-a-944...

 

Community Veteran
Posts: 18,773
Thanks: 2,017
Fixes: 24
Registered: ‎06-11-2007

Re: WebGL1 &2 disabled or unavailable

@mikelahey  Thanks for your input... and investigations... I will have a look and see what those links say, and see if I can do something with them

Wink