cancel
Showing results for 
Search instead for 
Did you mean: 

Virtual box ip address for minecraft server

zpeterk
Grafter
Posts: 377
Registered: ‎14-04-2007

Virtual box ip address for minecraft server

We are trying to run a Linux Mint virtual box on a win7 machine to run minecraft  server (as is doesn't work in win7) and it is all good including java etc but we are stumped by which ip to use, the host machine is 192.168.1.48 and the Linux vb is 192.168.56.1.
The server won't bind to port on either address, and the tunneling has got me confused, which is the correct way to give access from the local lan (192.168.1.xx) to the vb server?
4 REPLIES
Community Veteran
Posts: 3,424
Thanks: 17
Registered: ‎18-01-2013

Re: Virtual box ip address for minecraft server

I set my Linux server up to 192.168.1.200, subsequent Virtualbox sessions are set up on 192.168.1.201,  192.168.1.202 etc
I set the network card for bridge mode.
Never had a problem and I host a couple of live servers (WAN accessible) this way.
Not sure if that's any help to you but it always works for me. I just port forward to the above IP addresses and off I go.
zpeterk
Grafter
Posts: 377
Registered: ‎14-04-2007

Re: Virtual box ip address for minecraft server

OK tried setting static ip in the same subnet following hosts address but does not work. I there a setting in vb for bridged mode instead of a virtual tunnel?
Community Veteran
Posts: 3,424
Thanks: 17
Registered: ‎18-01-2013

Re: Virtual box ip address for minecraft server

Here is how one of mine is set up.
I run a DHCP server (ironically on a VM) but the majority of my network is assigned Static IP.
The Virtual machines are all assigned static IP addresses in the same subnet and the network adapter is set to bridged mode.
It all just seems to "work" and I've always done it like this unless I've needed to isolate a VM from my main network for testing purposes.
zpeterk
Grafter
Posts: 377
Registered: ‎14-04-2007

Re: Virtual box ip address for minecraft server

I think I've got it, the default mode is NAT you need to change it to bridged mode to run a server. Thanks for your help.