cancel
Showing results for 
Search instead for 
Did you mean: 

OpenWRT Help....

FIXED
Highlighted
IceColdRum
Dabbler
Posts: 22
Thanks: 1
Registered: ‎13-08-2013

OpenWRT Help....

So I've set-up my OpenWRT TP-Link router using the below settings:

Configuration via Web Interface LUCI

Of course you can achieve this with using the web interface:
Once you have configured your wireless network with LUCI you can start configuring your dumb AP.

  1. Disconnect the (soon-to-be) Dumb AP from your network, and connect your computer to it with an Ethernet cable. 
  2. Use the web interface to go to Network → Interfaces and select the LAN interface.
  3. Enter an IP address “next to” your main router on the field “IPv4 address”. (If your main router has IP 192.168.1.1, enter 192.168.1.2). Set DNS and gateway to point into your main router to enable internet access for the dumb AP itself 
  4. Then scroll down and select the checkbox “Ignore interface: Disable DHCP for this interface.”
  5. Click “IPv6 Settings” tab and set everything to “disabled”.
  6. In the top menu go to System → Startup, and disable firewall, dnsmasq and odhcpd in the list of startup scripts.
  7. Click the Save and Apply button. Hard-Restart your router if you're not able to connect anymore.
  8. Go to http://192.168.1.2 (or whatever address you specified) and check if the settings for the LAN interface are the same.
  9. Use an Ethernet to connect one of the LAN ports on your main router to one of the LAN/switch ports of your “new” dumb AP. (There's no need to connect the WAN port of the Dumb AP.)
  10. You are done.

Soure: https://openwrt.org/docs/guide-user/network/wifi/dumbap

 

and I've changed the IP address range of my Plusnet Hub 1 to that of 172.16.0.64 - 172.16.255.254 so it's different to OpenWRT's 192.168.1.1 however now It's connected to the Lan of my Hub 1 I can't access LUCI through the web browser or through SSH... it just times out! I'm close to pulling my hair out it's so frustrating :/ I can access the Plusnet router settings and the internet whilst connected via Ethernet to the OpenWRT router...

Does anyone know what I have done wrong? If I reset the OpenWRT routers settings back to default I can access LUCI again so it's clearly something I am changing

 

4 REPLIES 4
IceColdRum
Dabbler
Posts: 22
Thanks: 1
Registered: ‎13-08-2013

Re: OpenWRT Help....

I've just discovered that if I try to connect to the OpenWRT router without the hub 1 being connected then my computer won't connect to it at all Crazy3 

IceColdRum
Dabbler
Posts: 22
Thanks: 1
Registered: ‎13-08-2013

Re: OpenWRT Help....

I've got a Huawei HG612 modem arriving tomorrow anyway I think I'll just wait for that I'm still none the wiser I just can't connect to my OpenWRT router once the settings have changed...

 

I tried resetting the Hub 1 and setting the IP address of the OpenWRT router to 192.168.1.255 as suggested by the instructions above and even when I'm connected to the Hub 1 via Ethernet and the OpenWRT router is connected to the Hub 1 as well it just says 192.168.1.255 unavailable and 192.168.1.1 just continually loads :/

Superuser
Superuser
Posts: 7,609
Thanks: 1,406
Fixes: 89
Registered: ‎30-07-2007

Re: OpenWRT Help....

Fix

Ok, leave the Hub one addresses at the default.

Follow the instructions you posted in the first post, using the following at Step 3

enter 192.168.1.2 as the Ip address for Openwrt . enter 192.168.1.254 as DNS and Gateway

That should work. the Openwrt box should be accessible at http://192.168.1.2

 

NB 192.168.1.255 is not a valid address which is why your attempt didn't work. The openwrt box needs to be given an ip address in the Hub one sbnet BUT outside its DHCP range. Anything between 192.168.1.1 & and 192.168.1.63 should work

 

IceColdRum
Dabbler
Posts: 22
Thanks: 1
Registered: ‎13-08-2013

Re: OpenWRT Help....

Genius, I knew I was doing something obviously stupid Roll eyes

 

Thank you Smiley