cancel
Showing results for 
Search instead for 
Did you mean: 

Not Impressed

niche99
Newbie
Posts: 1
Registered: 12-03-2013

Not Impressed

Just had Fibre installed. Speedtest 70mbps down 15Mbps Up.
Trying to download a 133MB file over http at 60kbs!
Why are my downloads so slow? I got better download speeds with my old provider BE on an 8Mbps line.
Would appreciate a response.
It still hasn't finished downloading arrrghhhhh!
Now testing LibreOffice http download of 184MB speed 56Kbs 38 minutres remaining! Come on stop traffic shaping my http downloads!
Can't port forward using plusnet router. Predefined rules will assign to my registered device, but my custom rule will not assign to my registered device. The custom rule will appear in the dropdown and is selectable but will not assign when I click Add, what do you have to do to get custom port forwarding to work?
2 REPLIES
Community Gaffer
Community Gaffer
Posts: 5,101
Thanks: 425
Fixes: 5
Registered: 04-04-2007

Re: Not Impressed

Hi, Niche99.
Please disconnect and reconnect your router and see if that improves your performance?
Kelly Dorset
Broadband Service Manager
Plusnet Help Team
Plusnet Help Team
Posts: 13,089
Thanks: 153
Fixes: 55
Registered: 27-04-2007

Re: Not Impressed

Just to add, I would definitely expect a lot better having seen the estimate for your line.
I'd give Kelly's suggestion a go if you haven't already and let us know how you get on, we're happy to help you.
Adam
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team