cancel
Showing results for 
Search instead for 
Did you mean: 

Port forwarding via range extender

pir8ped
Grafter
Posts: 37
Thanks: 4
Registered: ‎19-05-2018

Port forwarding via range extender

Hi,

I recently switched to FTTC from copper. I have a Raspberry Pi in my greenhouse that controls an irrigation system. The GUI is web based - the pi runs a server. With my previous router, I could use port forwarding to direct all http requests to the pi and I was able to check the logs and control the system from anywhere.

The pi can't see the new router, Plusnet Hub One. I guess the wifi signal is weaker. So I bought a range extender (TPLink, TL-WA850RE) and connected the pi to that. I can use the ip address for the pi on the internal network to access my irrigation system. But looking at the Hub One management pages, I can't see the raspberry pi - only the extender. So I can't click on device (rasp pi ) and assign port forwarding to it. I've looked at using port forward to pass http requests on to the extender, but I can't see anywhere on the extender management pages to use port forwarding there.

 

I'd really like to once more access my irrigation system from anywhere.

 

Any suggestions?

 

Thanks,

 

John

19 REPLIES 19
MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

But looking at the Hub One management pages, I can't see the raspberry pi - only the extender. So I can't click on device (rasp pi ) and assign port forwarding to it.

@pir8ped It doesn't matter that the Pi doesn't show in the devices. As long as you know the IP address of the Pi(and its been assigned by the Hub one via DHCP) then use the 'user defined IP address' in the device dropdown on the Port forwarding screen, and enter the IP address.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

pir8ped
Grafter
Posts: 37
Thanks: 4
Registered: ‎19-05-2018

Re: Port forwarding via range extender

Hi,

 

I hadn't seen that user defined IP address option. Thanks.

So I added the irrigation system as a user defined application, and set the IP address to 192.168.1.203. If I put that IP address in my browser, I can see the pi serving its pages.

 

Looking in port forwarding again, I see this:

Game or Application Device MAC Address IP Address
Irrigation User Defined ... 00:00:00:00:00:00 192.168.1.203
 
Delete

 

Empty MAC address? I can't see how that can be, as if the router hasn't found the pi, and yet putting that ip address in the browser address bar, I can see the pi fine, so the router must be directing my query correctly in that case.

Sorry, confused!

 

John

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

It could just be a bug in the router display of MAC. Does the port forward actually work ?

I can see the pi fine, so the router must be directing my query correctly in that case.

The router doesnt need to route any local network traffic. Each device uses ARP to find where to send traffic for a local IP address.

edit: just noticed the IP address of .203 , that's quite high for a DHCP allocated address. Is the Pi getting its IP address via DHCP or have you allocated a static IP to it ?

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

pir8ped
Grafter
Posts: 37
Thanks: 4
Registered: ‎19-05-2018

Re: Port forwarding via range extender

Sorted. I'm afraid I'm not sure what fixed it. Changing port ranges I think (the pi listens on :8090)

 

Thanks for your help.

 

John

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

No problem

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

pir8ped
Grafter
Posts: 37
Thanks: 4
Registered: ‎19-05-2018

Re: Port forwarding via range extender

Hi,

 

I haven't allocated a static ip address to the pi. .203 is what was allocated dynamically.

 

I think there must be a bug somewhere!

 

I've got this on the port forwarding page:

 

Game or Application Device MAC Address IP Address
Irrigation User Defined ... 00:00:00:00:00:00 192.168.1.203
 
Delete

 

but I've also got this:

 

http://johnirrigation.hopto.org/ working fine - you'll only see the login page, but this no-ip name is set up with the router and it's working correctly. One day when the router reboots, I'm not sure if the port forwarding is going to be forwarding to the pi's MAC address (which isn't displayed) or that IP address which has been allocated to the pi, and which may no longer point there.

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

Set the router to fix ( always allocate the same ip)  the ip address allocated to the  Pi. Thatbway the port forwarding will always work

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

pir8ped
Grafter
Posts: 37
Thanks: 4
Registered: ‎19-05-2018

Re: Port forwarding via range extender

I can't see the pi from the router management pages. I can see the pi only in the extender list of connected devices. The ip of the raspberry pi is displayed there, and I used that ip address for port forwarding with the router. So I expect that if I turn the extender or router off, the DHCP might well give the pi another ip address and my setup will stop working.

I guess I'm back to my original question. How can I set up port forwarding to the pi in the router if I can't see the pi there in the list of connected devices?

Maybe there's a way to set up a static ip address from the client side, from the pi. I'll look into that.

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

So does the extender have a DHCP  server active ? As far as I can see it doesn't?  If it does, then disable it

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

Dan_the_Van
Pro
Posts: 499
Thanks: 51
Fixes: 6
Registered: ‎25-06-2007

Re: Port forwarding via range extender

Hi @pir8ped 

Ignore the fact the extender has an IP address it needs that to work, the extender operates like a bridge device, the Hub One DHCP is not very flexible and it prevents the user from defining fixed IP Addresses to a MAC address simply.

You are not seeing the IP address of the pi on the network map because the Hub One DHCP server has not issued an IP address for it, unlike the extender which has been allocated an IP address, I would suggest your follow these steps which I have used many times.

1) Turn fixed IP off on the pi, make DHCP and reboot.

2) After reboot check pi IP address, hopefully it has now been allocated an IP

3) On the Hub One check network for pi, hopefully it is now showing

4) Hub One navigate to Advanced Settings >Home Network >DHCP Table

5) Click on the pi hostname

There should be an option to make the selected IP permanent by clicking on Always use this IP address: Yes, once selected you can make the IP address to 192.168.1.203

6) Reboot the pi and check IP address is your choice.

Hopefully you can set your port forward rule

Hope this helps

Dan.

 

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

@Dan_the_Van  1) Turn fixed IP off on the pi, make DHCP and reboot.

The OP said earlier...

I haven't allocated a static ip address to the pi. .203 is what was allocated dynamically.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

Dan_the_Van
Pro
Posts: 499
Thanks: 51
Fixes: 6
Registered: ‎25-06-2007

Re: Port forwarding via range extender

Hi @MisterW 

Maybe there's a way to set up a static ip address from the client side, from the pi. I'll look into that.

I was responding to this; an alternative to fixing the IP address on the pi. But how on earth DHCP allocated .203 is a mystery to me unless the pi is still using the last modem/router DCHP servers allocated IP address, which I have seen when I swapped out modem/router makes 

Dan.

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

@Dan_the_Van But how on earth DHCP allocated .203 is a mystery to me

That's confusing me as well!. AFAIK the Hub one allocates DHCP addresses sequentially, starting from .64 by default, so unless there's 140 odd devices it won't have allocated .203.

I'm unsure whether the extender has its own DHCP server, the manual isn't very clear!. However it does have a default LAN IP in the 192.168.0.x subnet and the manual shows examples of connected devices with .1.x addresses. That tends to indicate that it does have a DHCP server and that it has router functionality but there's nowhere in the manual where you can change the DHCP pool.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

MisterW
Superuser
Superuser
Posts: 9,678
Thanks: 2,537
Fixes: 187
Registered: ‎30-07-2007

Re: Port forwarding via range extender

From this https://www.tp-link.com/us/support/faq/691/

It looks like the TL-WA850RE does have a DHCP server.

@pir8ped Id suggest disabling the DHCP server, allocating the W850 a static IP of 192.168.1.63 ( in the Hub one subnet but out of its DHCP range ) and see how that goes ...

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.