cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet Hub 2 v Hub 1 a personal Review

Chilternphil
Dabbler
Posts: 18
Thanks: 10
Registered: ‎09-04-2016

Plusnet Hub 2 v Hub 1 a personal Review

Renewed my PlusNet FTTC BB two weeks ago after four years using Hub 1 and upgraded to Hub 2. Having read some other forum threads I thought that some general feedback may be of interest. I had already set up a second hand BT smart hub 2 as a successful experiment last year.

My experience of Hub 2 is that both up and down speeds increased (about 6%) to 65/15 which may be serendipity or just a better S/N performance.  Wi-Fi performance is significantly better (which is a reasonable expectation as it has more aerials and presumably better circuits/software). Before and after the upgrade I measured signal strength/throughput around the house which showed Hub 2 is better but a real example is the TV will now play BBC iPlayer without stuttering whereas previously had to use mains-Ethernet to watch programs.  [That is 2.4 GHz through two external and one internal walls.]  A computer in upstairs bedroom now has a bi-direction link speed of 470 Mbps. Tablets and phones connect with stronger signal and seem to switch seamlessly between 2.4 and 5 GHz bands as one moves about.

In summary, a straight forward upgrade which has significantly improved performance. My one wish would be for a Guest User facility - but hey, I can always buy an expensive personal router if that becomes a problem.

12 REPLIES 12
andy7400
Newbie
Posts: 1
Thanks: 1
Registered: ‎29-11-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

Very helpful, Chilternphil, thank you.

Norrette
Grafter
Posts: 37
Thanks: 1
Fixes: 1
Registered: ‎29-07-2016

Re: Plusnet Hub 2 v Hub 1 a personal Review

Thanks for this, just about to plug in my Hub 2.  I take it that the 5g vs 2.4 clash issue has now gone away?

AJ27
Newbie
Posts: 5
Thanks: 3
Registered: ‎06-12-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

I tried plugging in my Hub 2, upgraded from the original.  Whilst many things connected easily I still had several devices that couldn’t pick up the Wi-Fi even with 5Ghz switched off.  Plus net support said it must be an issue with my devices, despite the only thing having changed being the router.  I have gone back to the original router and everything works fine.  Would love to get the hub 2 working but don’t know how to resolve the issues and plusnet customer service couldn’t help either. 

jab1
Legend
Posts: 17,009
Thanks: 5,446
Fixes: 253
Registered: ‎24-02-2012

Re: Plusnet Hub 2 v Hub 1 a personal Review

Which devices couldn't connect?

John
AJ27
Newbie
Posts: 5
Thanks: 3
Registered: ‎06-12-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

HP printer, Ring chime (ring doorbell connected ok), smart sockets.

Smart bulb only connected when I turned off 5GHz so I had high hopes that the others would too, but unfortunately not. 

jab1
Legend
Posts: 17,009
Thanks: 5,446
Fixes: 253
Registered: ‎24-02-2012

Re: Plusnet Hub 2 v Hub 1 a personal Review

Try resetting the offending devices to factory default and then retry, while keeping the 5GHz switched off. The printer especially will need this procedure, and I suspect the other items will.

John
AJ27
Newbie
Posts: 5
Thanks: 3
Registered: ‎06-12-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

Ok thanks. I thought I had done but I’ll give it another try.

bobpullen
Community Gaffer
Community Gaffer
Posts: 16,887
Thanks: 4,979
Fixes: 316
Registered: ‎04-04-2007

Re: Plusnet Hub 2 v Hub 1 a personal Review

Another thing you can try is selecting Mode 2 or 3 under the Advanced Wi-Fi settings in the Hub Manager (2 first, and if that doesn't work, try 3).

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

AJ27
Newbie
Posts: 5
Thanks: 3
Registered: ‎06-12-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

Thank you.  I will give these suggestions a go when I have a few minutes.  👍

AJ27
Newbie
Posts: 5
Thanks: 3
Registered: ‎06-12-2022

Re: Plusnet Hub 2 v Hub 1 a personal Review

Hi.  Just got round to trying it again and success! I did a full factory reset on the printer and then the others seemed to connect ok too.  Thanks both for your help.

7up
Community Veteran
Posts: 15,828
Thanks: 1,583
Fixes: 17
Registered: ‎01-08-2007

Re: Plusnet Hub 2 v Hub 1 a personal Review

Quick note regarding the firmware..

Hub1 has a list of common applications that can be quickly used to open a port to a selected device. On the Hub2 you have to do it all manually.

The network stuff (listing all connecting devices etc) is a lot superior though.

I need a new signature... i'm bored of the old one!
Greggorio
Hooked
Posts: 8
Registered: ‎16-02-2019

Re: Plusnet Hub 2 v Hub 1 a personal Review

It has for me. I had to split them with my old plusnet router. So far I haven't needed to