cancel
Showing results for 
Search instead for 
Did you mean: 

New customer - Broadband still to go live

FIXED
7JI
Newbie
Posts: 4
Registered: ‎25-10-2018

New customer - Broadband still to go live

Far from impressed with Plusnet. My broadband was due to go live at my new house on Monday. The Openreach engineer texted me at 06:30 asking me to plug my router in, then again at 10:00 to tell me the job was complete and my line should be up and running. Multiple texts and photos later we established that I had set up the router correctly and that I should wait - as I had originally intended to - for Plusnet to confirm my line was live which could be at any point up to midnight Monday.

Midnight Monday came and went, a phone call later I was told Plusnet were waiting for Openreach to mark the job as done on their side but rest assured as soon as that was done Plusnet would let me know that my broadband was live which could be up to midnight on Tuesday.

Midnight Tuesday came and went, another phone call on Wednesday morning, same story - give it to midnight Wednesday.

Midnight Wednesday came and went, it's now Thursday and you've guessed it - I've been told it's still waiting for Openreach to do something on their system but rest assured it will be sorted by midnight tonight.

It's now 50 minutes to midnight Thursday. Anyone holding out any hope that anything is going to happen between now and then? I'm certainly not and am rapidly tiring of how this is dragging and having to hotspot off my personal mobile to be able to do my work.
3 REPLIES 3
7JI
Newbie
Posts: 4
Registered: ‎25-10-2018

Re: New customer - Broadband still to go live

Friday morning and still nothing!
7JI
Newbie
Posts: 4
Registered: ‎25-10-2018

Re: New customer - Broadband still to go live

Friday afternoon and no further communication from Plusnet on the status of my provisioning...
dvorak
Moderator
Moderator
Posts: 25,313
Thanks: 4,670
Fixes: 1,183
Registered: ‎11-01-2008

Re: New customer - Broadband still to go live

Fix

Moderators Note


This topic has been moved from ADSL Broadband to My Order

Customer / Moderator
If it helped click the thumb
If it fixed it click 'This fixed my problem'