cancel
Showing results for 
Search instead for 
Did you mean: 

Xbox one strict NAT

mnUser
Hooked
Posts: 8
Registered: 26-11-2012

Xbox one strict NAT

Hello everyone!

 

My gaming life has been all well for months until yesterday when, for some reason, my NAT type changed to Strict. Testing Multiplayer Connection on the console returns "Cannot get a Teredo IP address", isn't that a IPv6 thing?

 

I have a TP-Link TD-W9980. I also reverted back to the modem BT give me when I switched to fibre. The Sagecom? The one that comes with the modem and router separated, two pieces of hardware. And got the same result.

 

Has anything changed recently on the ISP side? Or what do you think happened to my hardware and if I can fix it?

 

Thanks!

11 REPLIES
legume
Rising Star
Posts: 165
Thanks: 10
Registered: 21-07-2013

Re: Xbox one strict NAT

Though Teredo is associated with IPv6  it's also what you see in upnp/igd logs when an xbox one uses it.

 

IME it will ask for the external ip address and open udp port 3074, so it could be that that is failing.

 

Do you normally use upnp? I am wondering if you had a port forwarding/dmz set up previously then maybe it would always have said that, even though games got open nat.

 

mnUser
Hooked
Posts: 8
Registered: 26-11-2012

Re: Xbox one strict NAT

Yes, I have uPnP enabled. Never used DMZ (apparently it has significant implications for the modem security?)

 

I manually port-forwarded 3074 and 3544 (XBox said "make sure UDP port 3544 is not blockued on your router". I assume by adding it to the port forward list would be enough... yet still it gets a strict NAT Sad

Lurch
Rising Star
Posts: 81
Thanks: 19
Registered: 24-06-2016

Re: Xbox one strict NAT


mnUser wrote:

Yes, I have uPnP enabled. Never used DMZ (apparently it has significant implications for the modem security?)


Well, the modem is completely transparent to anything secure so it would be the router you are referring to, and no. What the DMZ does is effectively bypasses all security on the router for that single device in the DMZ so it would be your Xbox that was unsecure, not the router.


mnUser wrote:

 

I manually port-forwarded 3074 and 3544 (XBox said "make sure UDP port 3544 is not blockued on your router". I assume by adding it to the port forward list would be enough... yet still it gets a strict NAT Sad


Have you definitely forwarded the UDP and not just TCP?

legume
Rising Star
Posts: 165
Thanks: 10
Registered: 21-07-2013

Re: Xbox one strict NAT

I don't know whether your router upnp works with xbox one or not - in theory you shouldn't port forward and use upnp.

 

There's a step by step trouble shooter here -

http://support.xbox.com/en-GB/xbox-one/networking/multiplayer-connection-error-solution

Which may or may not help - some good advice about trying to clear router upnp etc.

 

The original message is a bit strange - it's almost like there was a fail on some remote server - does it still give the same message?

3544 probably only needs not to be blocked outgoing as the point of Teredo is to work through firewall/nat without user intervention.

On your web plusnet account there is the option to enable a firewall - maybe check that that is off.

Did you have the port forward plus upnp setup when all was OK, or did you change it after getting the error?

 

mnUser
Hooked
Posts: 8
Registered: 26-11-2012

Re: Xbox one strict NAT

mnUser wrote:

 

I manually port-forwarded 3074 and 3544 (XBox said "make sure UDP port 3544 is not blockued on your router". I assume by adding it to the port forward list would be enough... yet still it gets a strict NAT Sad


Have you definitely forwarded the UDP and not just TCP?


Yes, I forwarded both. I did just in case even though the message mentioned UDP. Since that failed, I also tried UDP only. But nothing has worked so far

mnUser
Hooked
Posts: 8
Registered: 26-11-2012

Re: Xbox one strict NAT


legume wrote:

 

 

The original message is a bit strange - it's almost like there was a fail on some remote server - does it still give the same message?

3544 probably only needs not to be blocked outgoing as the point of Teredo is to work through firewall/nat without user intervention.

On your web plusnet account there is the option to enable a firewall - maybe check that that is off.

Did you have the port forward plus upnp setup when all was OK, or did you change it after getting the error?

 


Yes, it still gives the same Teredo related message. I tried turning off the firewall but nothing changed.

On the Sagemcom 2704n I had uPnP enabled (both tick boxes) and port forward with the Bungie.net option. I've been playing Destiny and this router has it. So never had to input ports manually. It worked all this time. Until now, that I randomly got the NAT strict issue. I input the port manually via expert_user.html page on my Sagemcom router.

 

Thanks for the link. I will follow the steps and see what happens

mnUser
Hooked
Posts: 8
Registered: 26-11-2012

Re: Xbox one strict NAT

Right so I followed that link's steps but didn't solve the problem. I however kept on resetting the router a few more times.

 

 

I tried factory reset my Sagemcom. However, I'm not sure it is a true factory reset because the hardware kept my account details when it booted up. I tried the Factory Reset button on the admin web page as well as press down the hardware button on the back with a pin (for 10 seconds). Both cases, the router kept my details... is this expected?

 

Eventually though, my xbox one finally showed NAT Open! But I only managed to connect to a couple of matches before the game consistently kicked me out and asking me to check my connection. NAT was still open, but running a connection test on the console showed it has a 100% packet loss. It is intermittent though. But never again managed to join a game match.

 

I re-started the router and it went back with a Strict NAT. I reset it several times and got it open again. But the 100% packet loss was always happening. I wonder if it is a wire at fault. Actually, I saw a BT engineer sorting out the new neighbours' Internet five days ago. Hopefully they didn't mess my connection up. Ha! I just don't know what the problem is at this point.

 

I also factory reset my xbox one but didn't solve anything. And took it to a friend's and test it there and I was able to connect and play. So something with my routers? Both of them? I will try to borrow a third one.

 

Sorry for the long post. Not sure what else I can try. Thanks!

davvy76
Grafter
Posts: 71
Thanks: 3
Registered: 20-11-2013

Re: Xbox one strict NAT

Same problem here mate, I contacted plusnet support and they confirmed a fault at their end, see attachment. It would be helpful if there was something on the status page about it!

Tallikz
Newbie
Posts: 2
Registered: 28-06-2016

Re: Xbox one strict NAT

i had this problem a few weeks ago and after hours of troubleshooting i just got a new router sent out and it worked fine until today. same problem

kitch84
Newbie
Posts: 1
Registered: 10-07-2016

Re: Xbox one strict NAT

Exactly the same problem for me since yesterday. Tried numerous combinations of opening ports, DMZ, upnp and resets of both console and router and same results :Strict NAT and  the message 'cant get a Teredo IP address'. Everything was working totally fine until Saturday when it just went t*ts up and hasn't worked since! Its driving me up the wall!

legume
Rising Star
Posts: 165
Thanks: 10
Registered: 21-07-2013

Re: Xbox one strict NAT


mnUser wrote:

I tried factory reset my Sagemcom. However, I'm not sure it is a true factory reset because the hardware kept my account details when it booted up. I tried the Factory Reset button on the admin web page as well as press down the hardware button on the back with a pin (for 10 seconds). Both cases, the router kept my details... is this expected?


Sorry for the long post. Not sure what else I can try. Thanks!


Plusnet have now confirmed there is a problem.

 

On the factory reset question, there's something called IIRC TR069 so the reset cleared the settings, but then the router will pull in your details over the connection.