cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet Two hub connection

FIXED
tommyebo
Newbie
Posts: 2
Thanks: 1
Registered: Thursday

Plusnet Two hub connection

Hi all,

I received a new Plusnet Two hub yesterday and plugged it in as usual. It loaded up and settled on two blue lights and I entered the password as normal. My phone connects to the wifi with signal but on connecting takes me to a plusnet hub two manager login page. I switched back to the old hub and the internet works as normal. Any ideas with why the new hub might be doing this or if there’s anything else I need to do?

Many thanks,
Tommy
3 REPLIES 3
Baldrick1
Seasoned Hero
Posts: 7,633
Thanks: 3,408
Fixes: 235
Registered: ‎30-06-2016

Re: Plusnet Two hub connection

Fix

@tommyebo  Welcome to the forum.

It sounds like your hub has not been registered properly in the Plusnet database.

Log in to your hub by entering 192.168.1.254 in the address field of your Internet browser. Select Advanced settings. The admin password is on the hub pull out tab. Select Broadband.
If the username is showing as setup@plusdsl.net then this is your problem.
Change the username to youraccountusername@plusdsl.net  and change the password to your account password. Select Save (if requested) then Connect

bobpullen
Community Gaffer
Community Gaffer
Posts: 15,431
Thanks: 3,134
Fixes: 194
Registered: ‎04-04-2007

Re: Plusnet Two hub connection

It's due to the problem I've alluded to here.

The last couple of days of dispatches have not yet been registered on the management platform.

I'm hopeful the backlog will be cleared tomorrow.

In the meantime, the advice from @Baldrick1 should get you online.

Apologies for the hassle. Not the best of first impressions Sad

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

tommyebo
Newbie
Posts: 2
Thanks: 1
Registered: Thursday

Re: Plusnet Two hub connection

Thank you kindly @bobpullen and @Baldrick1 for the help. That did indeed do the trick.

Much appreciated.

Tommy