cancel
Showing results for 
Search instead for 
Did you mean: 

Domain pointing to Plusnet IP addresses and DNS settings in Portal being ignored

zalan001
Newbie
Posts: 2
Registered: ‎20-10-2014

Domain pointing to Plusnet IP addresses and DNS settings in Portal being ignored

Hi,
I called Plusnet to try and get the DNS for my domain name www.independent-technologies.co.uk to point to my dedicated server on IP 31.132.4.195.  Currently, however, the DNS records show that the domain is pointing to the following:-
a:www.independent-technologies.co.uk
Type Domain Name IP Address TTL
A homepages.plus.net 212.159.8.91 24 hrs
A homepages.plus.net 212.159.9.91 24 hrs
Why is this when this is not what is reflected on the DNS page in the plusnet portal, which is:-
Left field                                         Type          Right field
independent-technologies.co.uk.     A          31.132.4.195
www.                                                A          31.132.4.195
www.                                            CNAME   31.132.4.195
After speaking with Plusnet on the phone they changed the DNS on Friday to point all www traffic to 31.132.4.195, so there has been ample time for propagation.
Why are the IP details for the domain different to those in the portal?  
3 REPLIES 3
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,955
Thanks: 2,573
Fixes: 169
Registered: ‎04-04-2007

Re: Domain pointing to Plusnet IP addresses and DNS settings in Portal being ignored

independent-technologies.co.uk is pointing to 31.132.4.195:
~$ host independent-technologies.co.uk
independent-technologies.co.uk has address 31.132.4.195

The www subdomain isn't though:
~$ host www.independent-technologies.co.uk
www.independent-technologies.co.uk is an alias for homepages.plus.net.
homepages.plus.net has address 212.159.9.91
homepages.plus.net has address 212.159.8.91

That's because of the following records:
Quote from: zalan001
www.                                                A          31.132.4.195
www.                                            CNAME   31.132.4.195

There shouldn't be a qualifying dot at the end of those left-hand-side records. With the dot in place you have:
www --> 31.134.4.195

Instead of:
www.independent-technologies.co.uk --> 31.134.4.195

Of course 'www' isn't a valid hostname which is why things aren't working. In addition to this you have a CNAME pointing to an IP address. CNAME records should always point to another domain, never to an IP address.
I've corrected the records, however you're going to need to wait another 24 hours or so for DNS to catch up.
PS: Browsing to http://independent-technologies.co.uk returns a database connectivity error so I suspect there's a problem with your Wordpress config too .

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

zalan001
Newbie
Posts: 2
Registered: ‎20-10-2014

Re: Domain pointing to Plusnet IP addresses and DNS settings in Portal being ignored

Thank you for your help - however I am confused as someone at Plusnet changed these details for me on Friday.  Anyway, glad it is resolved, thank you.
bobpullen
Community Gaffer
Community Gaffer
Posts: 14,955
Thanks: 2,573
Fixes: 169
Registered: ‎04-04-2007

Re: Domain pointing to Plusnet IP addresses and DNS settings in Portal being ignored

Whilst I'm sure whoever you spoke to on Friday altered your records in good faith, they unfortunately made some mistakes. I'll catch up with them to make sure they're familiar with what needs to be done in future.

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵