cancel
Showing results for 
Search instead for 
Did you mean: 

SMTP server settings for Gmail

martin10
Interested
Posts: 2
Registered: ‎12-04-2017

SMTP server settings for Gmail

Evening,

I use Gmail to "Send email as", i.e. send email from another third party email account from Gmail. I originally set this up using a Sky SMTP server when they were my provider. Having changed to PlusNet last year, I have only now realised that I didn't change SMTP servers and Sky have obviously only now caught up, as the SMTP server is only now not working!

In Gmail settings I have changed the SMTP server, username and password details to:

- SMTP server: relay.plus.net

- Username: username@plusdsl.net (i.e. my plusnet broadband account username)

- Password: plusnet account password (i.e. my plusnet broadband account password)

I receive the following error message when doing the above:

Authentication failed. Please check your username/password.
Server returned an error: "Unspecified Error (SENT_EHLO): Unable to send AUTH command over non ssl connection code(0) "

 

Does anyone know how I can resolve this? Do I have a separate plusnet email password to my plusnet account password?

 

Thanks

 

 

 

5 REPLIES 5
Browni
Aspiring Hero
Posts: 2,580
Thanks: 978
Fixes: 53
Registered: ‎02-03-2016

Re: SMTP server settings for Gmail

Plusnet email doesn't support SSL so you may struggle convincing Google to connect to it!
martin10
Interested
Posts: 2
Registered: ‎12-04-2017

Re: SMTP server settings for Gmail

Thanks Browni. Can you suggest a work around to this? Reading Gmail's help I got the below suggestion. If I take this approach does that mean my emails are more prone to hacking/spam? Again any help would be appreciated.

 

If your other mail service doesn't support these secured connections, you can choose port 25, then select the Unsecured connection option that appears.

If you do this, your information won't be encrypted for your protection.

Browni
Aspiring Hero
Posts: 2,580
Thanks: 978
Fixes: 53
Registered: ‎02-03-2016

Re: SMTP server settings for Gmail

There isn't really a work around as such as the server won't accept a secured connection. You could use Plusnet's Webmail (yikes!) for those emails that need to be sent from your Plusnet email address?
pjmarsh
Superuser
Superuser
Posts: 3,583
Thanks: 1,253
Fixes: 12
Registered: ‎06-04-2007

Re: SMTP server settings for Gmail

You should still be able to send through the Plusnet SMTP server though.  Your username on there is just the username bit, ie without the @plusdsl.net part.

 

If you are only going to use it on the Plusnet network then you could do it without any authentication.

Equally you could use the the Gmail SMTP server with the address smtp.gmail.com, using port 465 and SSL.  That would need your gmail username (email address) and password.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.

Townman
Superuser
Superuser
Posts: 19,696
Thanks: 8,034
Fixes: 94
Registered: ‎22-08-2007

Re: SMTP server settings for Gmail


@martin10 wrote:

 

If your other mail service doesn't support these secured connections, you can choose port 25, then select the Unsecured connection option that appears.

 


Only Google could get this so wrong!  Port 25 is often blocked over some networks as that port is allocated for SMTP to SMTP server transfers.  The correct port is 587 for authenticated SMTP connections without SSL/TLS for SUBMITTING emails for relay.

See: https://en.wikipedia.org/wiki/Simple_Mail_Transfer_Protocol

SMTP communication between mail servers uses TCP port 25. Mail clients on the other hand, often submit the outgoing emails to a mail server on port 587. Despite being deprecated, mail providers sometimes still permit the use of nonstandard port 465 for this purpose.

Superusers are not staff, but they do have a direct line of communication into the business in order to raise issues, concerns and feedback from the community.