cancel
Showing results for 
Search instead for 
Did you mean: 

Receiving a MIME format email

gbhall
Grafter
Posts: 29
Registered: 06-04-2008

Receiving a MIME format email

I just received emails from a European delivery service which start as shown below in red.
This layout might be an attempt to send emails to customers in all parts of the continent and expect all to be able to read it, but as is obvious below, I cannot see this in an easily understood way, not to mention I suspect there may be clickable links for responses in there somewhere.
I am unable to find any setting in plusnet webmail which changes these emails to make them more readable. Any ideas, anyone ?
This is a multi-part message in MIME format.
--------------090303020209010600070908
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta name="viewport" content="width=device-width">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<title>Email Notification</title>
</head>

and so forth...........
7 REPLIES
kmilburn
Grafter
Posts: 902
Thanks: 2
Registered: 30-07-2007

Re: Receiving a MIME format email

How these messages display depend on how they've been sent and how webmail is setup.
In Webmail,  go to 'Personal Settings', 'Displaying Messages' and tick the 'Display HTML' option,  save the change and see if that helps.
If not, the mail is probably missing the header that identifies the mail as Multipart MIME and the boundary text.
You can check the headers by clicking oin the small arrow beneath the Date field in the preview.
You're looking for something like this:

MIME-Version: 1.0
Content-Type: multipart/alternative;
    boundary="--------------090303020209010600070908"

If you want to see the full email source,  click on the Cog above the message list and select 'Show source'  (or right click on the message, more actions, show source)..
gbhall
Grafter
Posts: 29
Registered: 06-04-2008

Re: Receiving a MIME format email

Thank you. 'Display HTML' option was already set. I examined the headers as you defined I could, and the two lines you quoted are there, except it says
multipart/related;  instead of multipart/alternative;
I noticed that the content-type is different (as you can see in the beginning of the email which I copied in my post) It says
charset=ISO-8859-15 whereas in my personal settings email is defined to have ISO-8859-1 (Western Europe) character set.
I cant see that that would make any difference though?
Community Veteran
Posts: 6,313
Thanks: 86
Fixes: 3
Registered: 08-01-2008

Re: Receiving a MIME format email

I've recently had a similar email (from DPD courier), same display problems in webmail but displays fine once downloaded to Microsoft Office Outlook (though the display issues persist if I forward the message from webmail to my work email (also using MS Outlook - though an older version if that makes any difference).
I could not find any way to get it to display correctly in Webmail and have had the same issue previously with the same sender.
Links (maybe not clickable but can be copied and pasted) can be found by searching the email for 'http://' if that helps at all.
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
kmilburn
Grafter
Posts: 902
Thanks: 2
Registered: 30-07-2007

Re: Receiving a MIME format email

Quote from: gbhall
Thank you. 'Display HTML' option was already set. I examined the headers as you defined I could, and the two lines you quoted are there, except it says
multipart/related;  instead of multipart/alternative;

The multipart parameter might be the cause of the problem going from the description on wikipedia.
Also, from a quick check, PlusNet are currently on Roundcube 0.7.4, so this bug may be relevant.
Quote
I noticed that the content-type is different (as you can see in the beginning of the email which I copied in my post) It says
charset=ISO-8859-15 whereas in my personal settings email is defined to have ISO-8859-1 (Western Europe) character set.
I cant see that that would make any difference though?

You're right there,  the only difference between those is how certain characters codes are interpreted.
PeeGee
Aspiring Pro
Posts: 1,088
Thanks: 47
Fixes: 3
Registered: 05-04-2009

Re: Receiving a MIME format email

Quote from: gbhall
This is a multi-part message in MIME format.
--------------090303020209010600070908
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 7bit
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>

The problem is that the originating software has converted the HTML so it will display correctly as text within a HTML document  Roll eyes  Shocked
&lt; and &gt; are the HTML encodings for displaying  < and >  which are the characters used for delimiting HTML tags to define, for example, [color=red]DOCTYPE, the start of html and the page header.
If you extract the converted HTML and replace all the & ; sequences by the relevant character, the page should display in a browser  Roll eyes
Plusnet Fibre (Sep 2014), Essentials (Feb 2013); ADSL (Apr 2009); Customer since Jan 2004 (on 28kb dial-up)
Using a TP-Link TD-W9980 modem-router.
kmilburn
Grafter
Posts: 902
Thanks: 2
Registered: 30-07-2007

Re: Receiving a MIME format email

While the character escaping will certainly not produce the desired result, I would still not expect the first part (the block header) to show.
It's also possible the additional escaping is because of the usage of multipart/related, and if correctly processed, may display the intended result.
Ultimately, it appears Roundcube does not like the mesage format.
gbhall
Grafter
Posts: 29
Registered: 06-04-2008

Re: Receiving a MIME format email

Quote from: kmilburn
While the character escaping will certainly not produce the desired result, I would still not expect the first part (the block header) to show.
It's also possible the additional escaping is because of the usage of multipart/related, and if correctly processed, may display the intended result.
Ultimately, it appears Roundcube does not like the mesage format.

Thank you for your valuable insight.  You appear to have hit the nail on the head, as I had the idea of viewing the original emails (completely unchanged) in another email program - specifically Mozilla Thunderbird. As you probably guessed, they appear as they should, including embedded images, clickable links and even clickable buttons.
So will plusnet up their game on webmail any time soon ?
As you see from member W23 in post#3 above, this problem is not confined to one delivery agent. It might be common to many who deliver continent-wide.