cancel
Showing results for 
Search instead for 
Did you mean: 

Unread posts not working correctly

Community Veteran
Posts: 38,244
Thanks: 933
Fixes: 54
Registered: 15-06-2007

Unread posts not working correctly

This morning before coming on the forum I received an automated email about a comment on a Library Article.
I clicked on the link to go to it.
I then moved to the forum via an unread posts shortcut and there weren't any.
However in many of the boards there were unread posts.
The question is whether it was the effect of going to the library glitched it or was it just an oddity
9 REPLIES
Moderator
Moderator
Posts: 25,756
Thanks: 1,120
Fixes: 47
Registered: 14-04-2007

Re: Unread posts not working correctly

In the last few weeks I've been working through 2 or 3 pages of unread posts and suddenly lost a chunk of them.
It doesn't happen very often.
Customer and Forum Moderator.
Product of the Tyrell Corporation
Community Veteran
Posts: 3,181
Thanks: 19
Fixes: 2
Registered: 31-07-2007

Re: Unread posts not working correctly

That has been a  feature for a while, noticed it as far back as last august.  I can see new post icons when I click my normal forum link  http://community.plus.net/forum/index.php then click unread and good few of them aren't there, I always do mark all read on leaving the forum so shouldn't be a cookie issue
Opera 11.64
Unvalued customer since 2001 funding cheap internet for others / DSL/Fibre house move 24 month regrade from 8th May 2017
Community Gaffer
Community Gaffer
Posts: 12,852
Thanks: 672
Fixes: 65
Registered: 04-04-2007

Re: Unread posts not working correctly

Mine seem to be OK but I'm not around these parts as often as you folk I guess.

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

prichardson
Grafter
Posts: 1,503
Registered: 05-04-2007

Re: Unread posts not working correctly

This is most certainly an issue. In short form it can be replicated by making your first visit to the community site, any page unrelated to the "/forum/" directory.
This is most certainly going to be PHP session related and something about the way SMF does not like sessions that are created by Wordpress.
Wordpress may or may not like sessions created by SMF, however there is no "unread" functionality in WP, so may seem to the casual user that all is OK.
IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Unread posts not working correctly

Heck, I'm due to start a site and had Wordpress/SMF in mind.
I'd be extremely interested to hear any updates on this. Don't like the sound of glitches like that -- I'm doing the whole thing myself...
Is this common with Wordpress + some other PHP application?Huh
Community Veteran
Posts: 38,244
Thanks: 933
Fixes: 54
Registered: 15-06-2007

Re: Unread posts not working correctly

I suspect it won't be relevant as the forum software is well out of date
Community Veteran
Posts: 26,372
Thanks: 629
Fixes: 8
Registered: 10-04-2007

Re: Unread posts not working correctly

Have you looked at Joomla, JFusion (to bridge) and SMF?
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Unread posts not working correctly

jelv - who me?
Yes, did look at some options. Not keen on Joomla.
JFusion, no. Don't know it - I'll check that out, thanks!
I was just wondering tho about this issue with WP php being glitchy with other apps. But as Oldjim says, the SMF version in question here has lost its newness! But it pulled me up a bit to read that.
Reason I was looking at SMF is it seems less bloated than apps like phpBB which I've got running elsewhere, and is a pain when upgrading with mods, styles and whatnot... wish I was smart enough to write my own stuff!  Grin
zedingrove
Grafter
Posts: 293
Registered: 18-06-2012

Re: Unread posts not working correctly

Quote from: P
This is most certainly an issue. In short form it can be replicated by making your first visit to the community site, any page unrelated to the "/forum/" directory.
This is most certainly going to be PHP session related and something about the way SMF does not like sessions that are created by Wordpress.
Wordpress may or may not like sessions created by SMF, however there is no "unread" functionality in WP, so may seem to the casual user that all is OK.

Have you tried bridging SMF + TinyPortal + WP?