cancel
Showing results for 
Search instead for 
Did you mean: 

Trouble with 212.159.8.110?

Community Veteran
Posts: 4,920
Thanks: 343
Fixes: 16
Registered: 10-06-2010

Trouble with 212.159.8.110?

I was getting a lot of timeouts trying to load these forums just now. community.plus.net was set to 212.159.8.110 in the /etc/hosts file. Changing it to 212.159.9.110 solved the problem. This is not the usual the forums are slow / I got one timeout loading 20 tabs complaint, I couldn't access the forums at all.
Some of the traceroutes are going a bit weird, e.g.:
[tt]traceroute -q 1 -N 1 -T -p 80 212.159.8.110
traceroute to 212.159.8.110 (212.159.8.110), 30 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  79.503 ms
2  lo0.10.Central10.ptn-bng02.plus.net (195.166.130.190)  89.081 ms
3  irb.10.PTW-CR01.plus.net (84.93.249.1)  60.228 ms
4  te9-4.ptn-gw01.plus.net (195.166.129.33)  74.621 ms
5  gi5-1.peh-cr02.plus.net (84.93.232.61)  98.496 ms
6  po5.peh-cr01.plus.net (84.93.232.16)  96.565 ms
7  vlan2657.peh-elb01.plus.net (84.93.232.44)  53.121 ms
8  vlan2657.peh-elb01.plus.net (84.93.232.44)  85.209 ms
9  community.plus.net (212.159.8.110)  124.437 ms
10  *
11  *
12  *
13  *
14  *
15  *
16  *
17  *
18  *
19  *
20  vl2657.peh-cr01.plus.net (84.93.232.41)  108.576 ms
21  vlan2657.peh-elb01.plus.net (84.93.232.44)  98.331 ms
22  vlan2657.peh-elb01.plus.net (84.93.232.44)  85.526 ms
23  vl2657.peh-cr01.plus.net (84.93.232.41)  71.760 ms
24  vlan2657.peh-elb01.plus.net (84.93.232.44)  145.218 ms
25  vlan2657.peh-elb01.plus.net (84.93.232.44)  95.476 ms
26  vl2657.peh-cr01.plus.net (84.93.232.41)  91.824 ms
27  vlan2657.peh-elb01.plus.net (84.93.232.44)  68.795 ms
28  vlan2657.peh-elb01.plus.net (84.93.232.44)  51.918 ms
29  vlan2657.peh-elb01.plus.net (84.93.232.44)  90.513 ms
30  vlan2657.peh-elb01.plus.net (84.93.232.44)  64.040 ms
[/tt]
Perhaps some routing is messed up, or there are some routing changes that haven't fully propagated to all bits of network kit yet?
Edit: Whatever the problem was, it seems to have cleared now and it's working again.
12 REPLIES
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

On the subject of weird (or just odd) traceroutes -
Tracing route to community.plus.net [212.159.8.110]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2   100 ms    71 ms    33 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    32 ms    33 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    33 ms    35 ms    32 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    51 ms    32 ms    32 ms  ae1.ptw-cr01.plus.net [195.166.129.0]
  6    33 ms    32 ms    33 ms  te9-4.ptn-gw01.plus.net [195.166.129.33]
  7    53 ms    41 ms    43 ms  gi5-1.peh-cr02.plus.net [84.93.232.61]
  8    45 ms    42 ms    43 ms  po5.peh-cr01.plus.net [84.93.232.16]
  9    57 ms    44 ms    41 ms  vlan2657.peh-elb01.plus.net [84.93.232.44]
10    42 ms    46 ms    43 ms  community.plus.net [212.159.8.110]
Trace complete.
Tracing route to community.plus.net [212.159.9.110]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2    32 ms    32 ms    38 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    33 ms    32 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    32 ms    34 ms    32 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    33 ms    33 ms    32 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  6    39 ms    38 ms    39 ms  gi5-8.ptp-cr01.plus.net [84.93.224.48]
  7    40 ms    39 ms    39 ms  vlan2657.ptp-elb01.plus.net [84.93.224.36]
  8    39 ms    39 ms    39 ms  community.plus.net [212.159.9.110]
Trace complete.
Community Veteran
Posts: 4,920
Thanks: 343
Fixes: 16
Registered: 10-06-2010

Re: Trouble with 212.159.8.110?

Those traceroutes look pretty usual. I have mentioned before that one of the IP addresses for community.plus.net has a shorter route if you are connected to a PCL gateway and the other has a shorter route if you are on a Telehouse gateway.
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

Well I'm afraid I can't remember every post you've made, thanks for mentioning it though. The problem is they should not be different which is why I would not call them "usual" - they may be usual to Plusnet, but I wonder whether part of the issues I see are related to them being different.
Whilst one may connect to either of the IP addresses on different occasions that one connects to the forum, which I've noted when I occasionally check, on re-reading your post today I was minded to check the traceroutes with the above results.
I further checked the consistency of those traceroutes with which ever IP I was actually connected to on the Forum. But because I was monitoring the Forum IP more closely I then observe that despite always having at least one tab open, the IP address had changed after either I posted or refreshed a tab, so I now need to monitor more closely to see exactly when it does change.
However before I do that, I'm going to set the IP address in Hosts to see if I get problems with one IP address and not the other.
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

Well, when I'm connected to 212.159.9.110 things seem reasonable, if not slow, not noticed any stalls as such yet.
Things are much more troublesome of 212.159.8.110 but still testing.
Community Veteran
Posts: 26,379
Thanks: 634
Fixes: 8
Registered: 10-04-2007

Re: Trouble with 212.159.8.110?

Quote from: Anotherone
The problem is they should not be different which is why I would not call them "usual"

The gateways are in buildings in different parts of London and there's routing from each back to Sheffield with a link between the two London buildings - of course there's a high chance that the routing may be different!
Edit: Too add to that the targets are in different datacentres, one is in peh and one in ptp.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

Eh, forum servers are in different data centres?
And actually I didn't mean why are they different in that sense, why the different number of hops?
Community Veteran
Posts: 26,379
Thanks: 634
Fixes: 8
Registered: 10-04-2007

Re: Trouble with 212.159.8.110?

Everything should be replicated in different datacentres so that if anything drastic happens at one it all keeps running (albeit with probably reduced performance).
Looking at the trace routes the first goes pcl -> ptw -> ptn -> peh.
The second goes pcl -> ptp so of course it has fewer hops.
I'm on a ptw gateway and you can see the routing for me goes the other way:
C:\Users\John>tracert 212.159.8.110
Tracing route to community.plus.net [212.159.8.110]
over a maximum of 30 hops:
  1    1 ms    <1 ms    <1 ms  tg582 [192.168.1.254]
  2    21 ms    20 ms    21 ms  lo0-central10.ptw-ag02.plus.net [195.166.128.196]
  3    21 ms    21 ms    21 ms  link-a-central10.ptw-gw01.plus.net [212.159.2.148]
  4    21 ms    20 ms    20 ms  xe-0-2-0.ptw-cr01.plus.net [212.159.0.248]
  5    28 ms    27 ms    22 ms  te9-4.ptn-gw01.plus.net [195.166.129.33]
  6    39 ms    31 ms    30 ms  gi5-1.peh-cr02.plus.net [84.93.232.61]
  7    38 ms    33 ms    33 ms  po5.peh-cr01.plus.net [84.93.232.16]
  8    39 ms    29 ms    30 ms  vlan2657.peh-elb01.plus.net [84.93.232.44]
  9    30 ms    54 ms    32 ms  community.plus.net [212.159.8.110]
Trace complete.
C:\Users\John>tracert 212.159.9.110
Tracing route to community.plus.net [212.159.9.110]
over a maximum of 30 hops:
  1    <1 ms    2 ms    1 ms  tg582 [192.168.1.254]
  2    23 ms    21 ms    23 ms  lo0-central10.ptw-ag02.plus.net [195.166.128.196]
  3    21 ms    20 ms    21 ms  link-a-central10.ptw-gw01.plus.net [212.159.2.148]
  4    20 ms    21 ms    24 ms  xe-0-2-0.ptw-cr01.plus.net [212.159.0.248]
  5    27 ms    21 ms    21 ms  ae1.pcl-cr01.plus.net [195.166.129.1]
  6    21 ms    21 ms    21 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  7    28 ms    29 ms    27 ms  gi5-8.ptp-cr01.plus.net [84.93.224.48]
  8    29 ms    28 ms    27 ms  vlan2657.ptp-elb01.plus.net [84.93.224.36]
  9    28 ms    28 ms    30 ms  community.plus.net [212.159.9.110]

If you gateway hop on to a ptn gateway you'd see something different again.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

I realised that after I posted the rather daft comment. I suppose I should untangle my brain and get a cup of coffee - caffeine deficiency has set in Roll eyes
Having said that, I'm not convinced that this doesn't have a bearing on some of the issues being seen - if you follow all the negatives!
I can do traceroutes to each of the ntp servers and they are all the same number of hops. They are in different data centres. How does that come about?
Community Veteran
Posts: 26,379
Thanks: 634
Fixes: 8
Registered: 10-04-2007

Re: Trouble with 212.159.8.110?

Because each of the data centres with gateways has it's own set of DNS servers with the same set of IP addresses.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

I thought the ntp servers were only in two of the data centres, but perhaps I misunderstood something back down the line.
Community Veteran
Posts: 26,379
Thanks: 634
Fixes: 8
Registered: 10-04-2007

Re: Trouble with 212.159.8.110?

You may be right - ptn and ptw might share in which case the routing from ptn and ptw gateways would show a difference.
All four IPs are definitely present in both ptw and pcl - you'll see the traceroute doesn't leave ptn/ptw or pcl depending upon where you are connected.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Trouble with 212.159.8.110?

Tracing route to cdns01.plus.net [212.159.13.49]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2    34 ms    40 ms    35 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    33 ms    31 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    34 ms    32 ms    32 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    32 ms    31 ms    32 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  6    32 ms    31 ms    32 ms  cdns01.plus.net [212.159.13.49]
Trace complete.
Tracing route to cdns02.plus.net [212.159.13.50]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2    32 ms    32 ms    32 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    32 ms    33 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    32 ms    65 ms    31 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    33 ms    32 ms    32 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  6    32 ms    32 ms    32 ms  cdns02.plus.net [212.159.13.50]
Trace complete.
Tracing route to cdns01.plus.net [212.159.6.9]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2    34 ms    32 ms    32 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    32 ms    32 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    32 ms    34 ms    32 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    32 ms    32 ms    31 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  6    33 ms    32 ms    32 ms  cdns01.plus.net [212.159.6.9]
Trace complete.
Tracing route to cdns02.plus.net [212.159.6.10]
over a maximum of 30 hops:
  1    <1 ms    <1 ms    <1 ms  dsldevice.lan [192.168.1.254]
  2    32 ms    32 ms    32 ms  lo0-central10.pcl-ag03.plus.net [195.166.128.184]
  3    33 ms    32 ms    32 ms  link-a-central10.pcl-gw01.plus.net [212.159.2.168]
  4    32 ms    31 ms    52 ms  xe-10-2-0.pcl-cr01.plus.net [212.159.0.200]
  5    33 ms    32 ms    32 ms  po2.pcl-gw01.plus.net [195.166.129.41]
  6    31 ms    31 ms    32 ms  cdns02.plus.net [212.159.6.10]
Trace complete.
That would seem to trace to only the pcl ones. I guess on a ptn or ptw it will be different then. I'll have to try hopping and check it out again - a while since I have. But on pcl-ag03 it's working well so reluctant to hop atm.
In terms of problems - this "Connection Problems. Sorry SMF was unable to connect to the database.........."
has come up several times now whilst on 212.159.8.110 but I didn't get it once whilst on 212.159.9.110.