cancel
Showing results for 
Search instead for 
Did you mean: 

Oops, profile pic disappeared and can't upload it again

IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Oops, profile pic disappeared and can't upload it again

Shows as uploading but nothing arrives.

Tried on Mac and PC.

 

edit --

ok, it worked when I went to 'load avatar' under settings, but can't load images under 'my images' on profile.

18 REPLIES
Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

Avatar images are seperate to your 'my images' folder and need to be uplaoded seperately into that folder. Did you manage to upload a new image in the end? I am seeing your original avatar still.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Superuser
Superuser
Posts: 10,023
Thanks: 1,562
Fixes: 19
Registered: 22-08-2007

Re: Oops, profile pic disappeared and can't upload it again


IanSn wrote:
but can't load images under 'my images' on profile.

Ian,

Exactly what did you do and what happened (exactly)?

I just tried to do this on an iPad.  Went through all the motions of selecting upload, choosing a picture, watched the progress bar progressing and was then prompted to select an album (I selected the private one).  So all in all it looked like the process was complete ... But there is no uploaded image in the album.

@jaread83 are we supposed to be able to upload images in this manner?

Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

I uploaded a new avatar and the images were placed in my 'profile' or 'hidden' folder depending what route I went to add the image. You can also upload an image to your public folder and 'edit' the image and in the options drop down you can click 'use image as avatar'.

I can't seem to make the avatar upload or selection break no matter what I do.

If I knew the exact process they went through for it to not work I might be able to get a better idea of what's going wrong and raise a support ticket if there is a bug I can identify and replicate.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Oops, profile pic disappeared and can't upload it again

I did manage to upload the avatar by going to 'settings' and it works as described above.
However, initially I went via 'profile' and 'my images' - as townman has described - and after apparently uploading the image file there seems to be no image in the folder. Tried many times on two different platforms.
This involved clicking 'add image' and 'browse', selecting file from my computer.
Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

odd. I looked at your profile and I can only see one uploaded image which is the one you are currently using as an avatar.

I will see if I can replicate this using the method you described.

Can I ask what browser & operating system you are using?

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Oops, profile pic disappeared and can't upload it again

Two different issues here getting confused.
Yep, I uploaded the avatar easily via settings. That's done.
But going via 'profile' (on menu) and 'my images', 'add image', browse' does not appear to work.
Tried on Mac using latest Firefox and Win7 also Firefox. Thoroughly checked firewalls, etc., etc., on both. But seems @townman has discovered same issue?
Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

Okay so I think I can see what the issue is here. When you go to the albums and click to add an image, did you select an album first? You can't upload images outside of the albums. When I tried it, it said to select an album. When I selected an album I had to upload again. Once I was in the album it got uploaded just fine.

I should probably do away with the 'add image' button on the first screen until you are in an album to avoid confusion..

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Superuser
Superuser
Posts: 10,023
Thanks: 1,562
Fixes: 19
Registered: 22-08-2007

Re: Oops, profile pic disappeared and can't upload it again

@jaread83,

If that's the way it is supposed to work, it would help! Grin

The way it functions - goes fully through the motions of selection and upload and AFTERWARDS asks for the album, its not obvious that the upload was ignored.  Would it be possible for the upload button to display the select album message if one has not been selected before offering the upload dialogue?

Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

I just wanted to say thanks for bringing this to my attention. I inspected the code and my previous comment is correct, you can only upload to an album BUT if you upload an image outside of an album you should be able to select an album and then carry on from there. I did a bit of digging and found the container is getting a class for 'hiding' the content which is not how it should be, the container with the preview should not be hidden!! Ticked off

Here is what you should see with that hidden class removed:

Screen Shot 2016-04-25 at 15.24.21.png

I will get @LouisaMartin to file a support ticket as I can't change this and Lithium will need to implement a change. Can't beleive none of us noticed this before so thank you for bringing this to my attention. I will get this sorted asap.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Superuser
Superuser
Posts: 10,023
Thanks: 1,562
Fixes: 19
Registered: 22-08-2007

Re: Oops, profile pic disappeared and can't upload it again

@jaread83,

Well when there are so many fires to quell...!!

I was just going to add that the way the screen presents, the browse files is present first, then you get the select folder option and it appears to imply that one clicks on the folder icons below.  I guess your finding indicates that some key bit of functionality is not actually displayed?

Community Gaffer
Community Gaffer
Posts: 2,859
Thanks: 1,534
Fixes: 62
Registered: 22-02-2016

Re: Oops, profile pic disappeared and can't upload it again

You are correct @townman. When you upload a file in the root directory of your images you may notice a big area of whitespace. This is becuase the form for album selection is set to 'visibility:hidden;' in the CSS which actually keeps the layout of the thing that is being hidden but doesn't display it (I use display:none; in these cases as it stops the whitespace). I suspect what is happening is that the album selection is being set to hidden and waiting for an image to be uploaded. When the image is uploaded that hidden flag should have been removed to show you the album selection form. I don't think it would be too difficult  to resolve by Lithium as its just the javascript waiting on something to happen before removing the class from the form element. I have got this on my list and will be speaking to Louisa to raise this as a product bug.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Oops, profile pic disappeared and can't upload it again

The big whitespace did look a bit odd, but I do recall trying to choose an album first, after it failed to work first time, but still ended up going round in circles. Can't remember exactly what I did tho, might've been due to me going round in circles with it.
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Oops, profile pic disappeared and can't upload it again

This issue was mentioned  during testing IIRC Cry

IanSn
Grafter
Posts: 492
Thanks: 5
Registered: 25-09-2011

Re: Oops, profile pic disappeared and can't upload it again

Btw, just tried to upload another pic via 'profile', 'my images' on windows phone. Same thing happened. Where is the option to choose an album?
(In transit at mo so can't try on desktop till later.)