cancel
Showing results for 
Search instead for 
Did you mean: 

New forum - "Unresponsive Script" WARNING when posting a reply

FIXED
Community Veteran
Posts: 5,459
Thanks: 274
Fixes: 4
Registered: 11-08-2007

New forum - "Unresponsive Script" WARNING when posting a reply

 

Why does the new forum lock-up so often ?

Just typing text in the "Rich Text" tab, then for no apparent reason the CPU usage hits 100% for something like a minute, then a warning -

 

Warning:Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Allowing the script to continue just repeats the error and the CPU running at 100%.

 

Stopping the script leaves the page in a unusable condition which requires the browser to be closed.

 

I thought Lithium was chosen as the forum provider because they were supposed to know what they are doing, so why are there so many problems with such basic functionality ?

22 REPLIES
Superuser
Superuser
Posts: 2,585
Thanks: 974
Fixes: 8
Registered: 10-04-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

Was this problem cured by the more general Javascript 'fix' a week or so back?

 

M

Community Gaffer
Community Gaffer
Posts: 2,849
Thanks: 1,527
Fixes: 62
Registered: 22-02-2016

Re: New forum - "Unresponsive Script" WARNING when posting a reply

What browser and OS are you using? Did you try clearing your browser cache and trying again? You might have a cached version of the files required for the editor.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Community Veteran
Posts: 38,246
Thanks: 934
Fixes: 56
Registered: 15-06-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

could this be related - just got it when going to first unread post in a thread

2016-04-12_093629.jpg

Superuser
Superuser
Posts: 2,585
Thanks: 974
Fixes: 8
Registered: 10-04-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

I don't have the problem.  My query was posted to help migrate the post from the 'Unanswered Topic' list into (hopefully?)  the 'Fixed' category for the information of new readers.

M

Superuser
Superuser
Posts: 2,585
Thanks: 974
Fixes: 8
Registered: 10-04-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

@Oldjim  See that response quite often.  I've just got used to expecting it.

Community Gaffer
Community Gaffer
Posts: 2,849
Thanks: 1,527
Fixes: 62
Registered: 22-02-2016

Re: New forum - "Unresponsive Script" WARNING when posting a reply

The authentication errors that have been cropping up for some users is a cause for concern for me so I need to raise a support ticket to get this investigated.

As for the unresponsive script warning, I am not entirely sure why this would happen. I can only suggest trying to clear your browser cache and seeing if that makes any difference.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

Superuser
Superuser
Posts: 9,997
Thanks: 1,533
Fixes: 19
Registered: 22-08-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

Is there any possibility that this error and the authentification error are related to communication problems between client JS and the server?

This morning I have seen sluggish responses on pressing the post button and two or three communication with the server errors.

Superuser
Superuser
Posts: 2,585
Thanks: 974
Fixes: 8
Registered: 10-04-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

I've noted the sluggish responses but not the server errors.  Also getting

Thanks error.JPG

When trying to click on 'Thanks'

 

NOTE:  Just updated to FF46.0

M

Community Gaffer
Community Gaffer
Posts: 2,849
Thanks: 1,527
Fixes: 62
Registered: 22-02-2016

Re: New forum - "Unresponsive Script" WARNING when posting a reply

I have linked to this post on my authentication error thread to collect data about this.

https://community.plus.net/t5/Community-Site-Feedback/Authentication-error-on-community-are-you-affe...

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

rongtw
Seasoned Hero
Posts: 6,325
Thanks: 1,154
Fixes: 11
Registered: 01-12-2010

Re: New forum - "Unresponsive Script" WARNING when posting a reply

for some reason lithium does not like FF46 Embarrassed

this is 3rd attempt at posting due to Embarrassed

 

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Community Gaffer
Community Gaffer
Posts: 2,849
Thanks: 1,527
Fixes: 62
Registered: 22-02-2016

Re: New forum - "Unresponsive Script" WARNING when posting a reply

@rongtw, can you grab me a screenshot of your entire browser (with the URL in the screenshot) as well as any info as to how you get the errors and post on my authentication error page so I can gather as many instances as possible about this?

We are in the process of raising a support ticket to look into whats going on in the system to cuase these errors and it will help to gather as much information as we can about it.

In the meantime I am looking out for any posts (after the fix we did to remedy the initial javascript error) to link to within that thread as well.

Frontend Web Developer | www.plus.net

If you have an idea to improve the community, create a new topic on our Community Feedback board to start a discussion about your idea.

rongtw
Seasoned Hero
Posts: 6,325
Thanks: 1,154
Fixes: 11
Registered: 01-12-2010

Re: New forum - "Unresponsive Script" WARNING when posting a reply

Jaread83 this is what i get

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

@jaread83 beware any red herrings. This OP was when we had all the javascript issues due to the GA problem as @MauriceC suggested in message #2.

As @Nibiru has not been back since, maybe the thread should be marked as fixed. All the issues raised since message #4 are now covered by your other thread on Authentication errors etc. are they not?

Community Veteran
Posts: 5,459
Thanks: 274
Fixes: 4
Registered: 11-08-2007

Re: New forum - "Unresponsive Script" WARNING when posting a reply

I'm back !  Roll eyes

 

I've just looked at a few threads and replied to three topics, and haven't seen any repeat of the "Unresponsive Script" WARNING, and not seen any 100% CPU issues.

 

I will keep a lookout for any occurrences of this, but it does appear much better then when I last visited three weeks ago !.