cancel
Showing results for 
Search instead for 
Did you mean: 

Major Speed problems this past week

LeedsUnited1995
Newbie
Posts: 7
Registered: 16-07-2012

Major Speed problems this past week

Hi All,
            Ive been experiencing weird speed loss this past week my whole internet across the house be it on gaming platforms or multiple computers seem to be stumpted on connection speed. The speed I am receiving from plus net is expected "14mb/s" however it is slow even browsing the internet.
Has anyone else been experiencing this problem or help me fix it?
Thanks
Matt
4 REPLIES
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: Major Speed problems this past week

Hi LeedsUnited1995,
Do you get the same problems whilst connected into your Test Socket? If so, with an alternative microfilter?
It's worth checking to see if it's any different as the internal wiring or faulty microfilter could be causing the problem.
Chris Pettitt
Cloud Environments Engineer
LeedsUnited1995
Newbie
Posts: 7
Registered: 16-07-2012

Re: Major Speed problems this past week

Changed to 3 different routers both brand new. Changed Micro filters aswell
LeedsUnited1995
Newbie
Posts: 7
Registered: 16-07-2012

Re: Major Speed problems this past week

Also the test socket is encountering the same problems
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

Re: Major Speed problems this past week

If that's the case you should now have enough information to finish off the questions on the faults wizard (I can see you've started filling this in). Once you've done that it'll raise a ticket through to our faults team who'll get things fixed for you.