cancel
Showing results for 
Search instead for 
Did you mean: 

Set up Phone App to communicate with PC

fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Set up Phone App to communicate with PC

I have obtained an app for my Android phone that enables me to control software installed on my PC from my phone. Unfortunately it doesn't seem to be able to communicate with the PC. It just sits there indefinitely "searching"
I thought it was probably the firewall on my PC blocking access but turning it off doesn't solve the problem so I thought it might be the firewall in my router (Thomson TG585v7). This says its firewall is "on" in "standard" mode. However, according to Plusnet support this doesn't mean anything and the firewall is actually controlled in "my account" where it is set to off.
The app's help says I need to allow access to port 2305
Does anybody have any ideas? The application on the PC is called "Mixcraft" (it's audio recording software) if it's of any help
15 REPLIES
bradw
Grafter
Posts: 105
Registered: ‎21-05-2013

Re: Set up Phone App to communicate with PC

Are you connecting to your home wifi on your phone when you try to connect to PC? If you're doing over cell network, you'll have a lot more issues to resolve.
Is there an option to manually specify the connect options? If there is, find out your computer's IP address and use that.
This may help to find your internal IP address: http://www.bobborst.com/tools/whatsmyip/ (note you want to look for something beginning with usually 192.168.0. or 192.168.1.
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

Yes, I'm trying to connect via my home network.
I've tried entering the IP address but get the same result. IE the app just sits there waiting to connect
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: Set up Phone App to communicate with PC

Quote
I thought it was probably the firewall on my PC blocking access but turning it off doesn't solve the problem so I thought it might be the firewall in my router (Thomson TG585v7). This says its firewall is "on" in "standard" mode. However, according to Plusnet support this doesn't mean anything and the firewall is actually controlled in "my account" where it is set to off.
Neither the PlusNet firewall in your account or the router firewall should have any effect on connections within your home network, they purely affect connections from the internet.
I've just downloaded the Mixcraft remote help from here http://acoustica.com/files/Mixcraft6-RemoteAppHelpAndroid.pdf and from what I can see the only thing likely to cause problems is a local firewall on the PC running Mixcraft. I know you said you'd disabled the windows firewall, did you try just enabling Mixcraft as described in that help ? do you have any other internet security/firewall software on the PC that may be causing problems ?
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

I actually usually use Zonealarm and initially I thought that might be the problem so I disabled it and tried Windows' firewall instead. I got the same result. So, I then disabled Windows' firewall. Still the same result. At no stage with either firewall did I receive message asking to enable access. The app just sits there waiting. The only other security software I have is Windows Defender. I'm not really sure what it does in detail but again I've not seen any message from it, which presumably I would if it was taking some sort of action
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

In case this helps..................................
Someone suggested I try a tracer app. When I put in my IP address and hit "trace" it comes back with :
                                          87.112.43.215; 3.54, 3.02, 3.54; AS6871
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: Set up Phone App to communicate with PC

Its nothing to do with your external IP and tracing. As I understand it, both your PC running Mixcraft and your Android phone are connected to your local network. Both should have an IP address in the 192.168.1.x range . Can you check that ? 
You have enabled the remote App facility in Mixcraft I assume ? when you did that the firewall should have prompted you to enable that port.
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

Funny. Yesterday when I checked my IP address was indeed in the 192.168.1.x range. Today, having checked 3 different sources it's being reported as 87.112.43.215. But on re-checking via "Network Connections" it gives me a 192.168.1.x. address. Having run the tracer on that I get :
              3.05, 3.05, 2.71 AS10223
The remote app. facility is enabled in Mixcraft. When I enabled it my firewall didn't make any response. I assume that's because Mixcraft was already "approved" as an application before I enable the remote app. facility. Anyway, as I've said already even with no firewall at all running the app still can't find Mixcraft on the PC.
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: Set up Phone App to communicate with PC

Those sources are giving you your external(global) IP, that's of no interest here. Your phone and PC are(should be) on the local network.
You need to check that the phone has an IP address in the correct subnet as well http://www.techpaparazzi.com/how-to-find-ip-address-of-android-smartphone/ .
Just a thought, the phone isn't trying to use its 3g network to communicate is it ?
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

Thanks for your patience.
Interestingly my phone reports my IP address as a 192.168.1.x address, but different to the one Windows Network Connections gave me, but the websites referred  to in the article show the IP address as 87.112.43.215, which is the same as I was getting from other sources.
Is that of any help?
By the way, the phone isn't trying to use 3G
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: Set up Phone App to communicate with PC

Quote
but different to the one Windows Network Connections gave me
That's to be expected, all devices should have different internal network addresses.
Quote
but the websites you referred me to show the IP address as 87.112.43.215.
Yes, thats fine it's the external address. I only wanted to check the internal one.
It looks like everything is ok, I'm beginning to run of of ideas.
It would be useful to see if the phone and PC can 'see' each other , let me just check something on my Android Nexus 7...
Ok, can you open a cmd window on the PC and see if you can ping the phone see here for example how to do it http://www.wikihow.com/Ping-in-Windows-XP
In your case the address you need will be the 192.168.1.x address that the phone reported it had.
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: Set up Phone App to communicate with PC

You have ticked 'Enable Mixcraft Rempte App' under File|Preferences|Interfaces?
I'm sure you have but you haven't said so...
Try turning off mobile data just to make sure the app is communicating via wifi?
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

@pwatson - Yes, I have ticked 'Enable Mixcraft Remote App' under File|Preferences|Interfaces. Mobile data is off
@MisterW - The PC can ping the phone  (packets : Sent = 4, Received = 4, Lost = 0)
Superuser
Superuser
Posts: 6,969
Thanks: 999
Fixes: 60
Registered: ‎30-07-2007

Re: Set up Phone App to communicate with PC

Well that proves that the phone and pc can talk to each other. Ideally one would try pinging the PC from the phone but pinging from android isn't simple without downloading an app and I'm not sure it would prove much. It still looks like either a firewall proble on the PC or a problem with the Mixcraft app itself.
I'm confused by the fact that neither Zonealarm or Windows firewall alerted you to the Mixcraft app when you enabled its remote app facility. Can you try disabling the remote app and enabling it again ( restarting mixcraft again each time ). I'd try that with both Zonealarm and the WIndows firewall ( but not both at the same time ).
Reading the whole thread again, I notice that at one point you tried entering an IP address into the app on the phone, was that the local IP address that the PC shows in its network connections ( i.e the 192.168.1.x ) or the public IP, If that's still configured in the phone then it needs to be the local 192.168.1.x address.
fatwarry
Newbie
Posts: 8
Registered: ‎07-08-2013

Re: Set up Phone App to communicate with PC

I even tried uninstalling/reinstalling the app but to no avail. Since the reinstall I tried to connect to the PC using the local IP address. Still nothing. I guess it's time to give up. Many thanks for your time and trouble.