cancel
Showing results for 
Search instead for 
Did you mean: 

try connecting mobile phone to modem

Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

try connecting mobile phone to modem

Hi I am trying to connect my mobile phone - tmobile vivacity - to my D-link DSL 2640B modem so I can use the internet on my phone with its wifi instead of 3G. The phone 'sees' my modems SSID but will not connect because it says the modem is Disabled protected with WPA/WPA2 PSK. Don't know if this is relevant but I use ethernet homeplugs for my computer. I asked Tmobile and they don't know why I can't connect either. My phone doesn't ask for a password to connect to the modem either.  Sad
14 REPLIES
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: try connecting mobile phone to modem

Check the router settings - it sounds as though it is set up to block any new wireless connections
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

I have checked around by logging in to my modem and can't see anything obvious but I'm no expert.
Ok I've checked again under 'Wireless Lan' and it says 'Wireless Radio ON'
don't know if that is it.
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: try connecting mobile phone to modem

Have a look under Advanced Wireless Settings
There should be an option for MAC filtering - the options are Disabled, Allow, Deny - it should be set to "Disabled" (This option may not be there as it applies to only some of the firmwares)
Another thing to try is to change the WPA password to one only 8 characters long
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

Firmware version:  3.06
Current Firmware Date:  June 2  2007
I can't see anything for MAC filtering, there are inbound and outbound filters but no options set for them.
My WPA password is already 8 characters long. My PSK though is 63 characters long, I hope that's not the problem.
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: try connecting mobile phone to modem

According to my router the WPA-PSK Security Encryption key is the one I am talking about so I don't know why you have two keys
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

I must be using the wrong words. When I log in to my router with my browser the first page that comes up asks me to login, you know, the one that says Admin and Admin when it's new - the defaults to connect with the router, of course I changed the password. That password is now 8 characters long. The PSK is 63 characters, yes I know silly but I read it was more secure somewhere. I have that pass written down. The thing is my mobile phone does not ask me for a password.
Community Veteran
Posts: 38,460
Thanks: 1,030
Fixes: 62
Registered: 15-06-2007

Re: try connecting mobile phone to modem

Superuser
Superuser
Posts: 6,774
Thanks: 854
Fixes: 55
Registered: 30-07-2007

Re: try connecting mobile phone to modem

I suspect that at some point you may have entered an incorrect PSK into the phone for your wireless network. It has now stored that connection information and will use the stored password each time and fail to connect. You need to use the wireless settings function on your phone to delete the stored wireless connection identified by your SSID. It will then rescan, find your network again, and allow you to enter the correct PSK. Although I agree with Jim, I would change the PSK on the router first to something smaller...
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

Thanks Mr W, I have never keyed a pass for my router into the phone, it has never accessed my router, I have always only been able to connect to the web with 3G, luckily I got six months internet free when I bought the phone.
Thanks Oldjim, I will now go and read the thread you quoted  Smiley
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

Quote from: MisterW
I suspect that at some point you may have entered an incorrect PSK into the phone for your wireless network. It has now stored that connection information and will use the stored password each time and fail to connect. You need to use the wireless settings function on your phone to delete the stored wireless connection identified by your SSID. It will then rescan, find your network again, and allow you to enter the correct PSK. Although I agree with Jim, I would change the PSK on the router first to something smaller...


I removed the SSID for my router, the key is now 8 characters. It worked!  Cheesy
Now one final question please, how do I choose to use my modem to connect to the internet and not 3G?
Thanks for the help  Smiley
jojopillo
Grafter
Posts: 9,786
Registered: 16-06-2010

Re: try connecting mobile phone to modem

If you're connected to wireless it should use wireless by default. Only when you're not on wi-fi should it go back to 3G Smiley
Superuser
Superuser
Posts: 6,774
Thanks: 854
Fixes: 55
Registered: 30-07-2007

Re: try connecting mobile phone to modem

JoJo is probably right. I just tried looking at the manual and can't see a setting to set the default connection for data.
What you can do is to enable/disable data connection over 3G and thus force any connection to be via Wifi.
Quote
The GPRS/EDGE/3G connection can be switched on or off manually. Just select  > Settings > Wireless & networks > Mobile networks from the home screen and tick or clear the Data enabled check box.
Fenster
Rising Star
Posts: 132
Fixes: 1
Registered: 30-07-2007

Re: try connecting mobile phone to modem

Wonderful, thank you all, this has been an intractable problem for me, isn't it nice when problems get solved.  Smiley