cancel
Showing results for 
Search instead for 
Did you mean: 

re: Why are my applications not the latest possible version?

Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

re: Why are my applications not the latest possible version?

Just noticed this on the Mint forums, as it has been discussed here I thought it may be useful to some people. Wink
Read it <a href="http://forums.linuxmint.com/viewtopic.php?f=47&t=31954">HERE</a>
Quote
Frequently users new to linux cannot understand why the newer versions of their favourite program are available from the program's website, but the update never comes. If you are one of those people, this post is for you.

dick:green Quote tag fixed.
3 REPLIES
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: re: Why are my applications not the latest possible version?

there's a long, involved and complicated explanation for the non-inclusion of cutting edge in a distro.  short answer is that each distro is built around a specific kernel and not all new stuff will work without considerable modificaton of said kernel.
the optimum is to have as many apps as possible work with the current kernel and work towards including the updated versions of apps in the next distro build.
as an example, pclinuxos 2009 could no longer include the updated firefox as it needed the newer gcc compiler.  this then extended to more and more newer versions of applications until the time came when it made sense to completely rebuild the os using the newer gcc compiler and kde4.
as always, some people loved it and jumped right in the deep end and some people fretted at the loss of their beloved kde3.  no doubt a similar brouhaha will ensue at the introduction to kde5.
VileReynard
Seasoned Pro
Posts: 10,826
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: re: Why are my applications not the latest possible version?

Just checked; Ubuntu has gcc 4.3 and gcc 4.4 installed on my machine...
(versions 4.1 & 4.2 are still available) Cheesy

Waldo
Grafter
Posts: 473
Registered: 01-08-2007

Re: re: Why are my applications not the latest possible version?

My FreeBSD 8.0 box is still using gcc 4.2.1; no problem compiling Firefox 3.6.3 with it.