cancel
Showing results for 
Search instead for 
Did you mean: 

constant change of local IP.. stop!?

marc2
Dabbler
Posts: 23
Registered: 31-01-2013

constant change of local IP.. stop!?

seems a bit pointless to have a static IP set if my internal keeps changing and the plex server then cannot direct connect.  will connect but indirect so slower

 

I have asked Plusnet support but got no where.

every few days i have to enter the router and reset game sharing for my plex server, edit ip and chose my pc hostname.  it then works fine until the local IP changes again.

 

anyway i can stop this?

 

 

ty

 

 

 

 

67 REPLIES
Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: constant change of local IP.. stop!?

Give the PC a static IP address?
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

i have a static external but is no use when the internal changes so often and i have to reset the new internal to associate with my pc

 

i dont want the internal to change or at least auto reset itself to my pc hostname

 

 

DaveyH
Seasoned Pro
Posts: 1,423
Thanks: 246
Fixes: 9
Registered: 15-11-2012

Re: constant change of local IP.. stop!?

What @Browni is saying is you need to assign your Plex server an static internal/local IP address.

marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

yeah thats part of my question

if i set a fixed ip i get no connection

 

how can i set plex to stay to a certain ip all the time and thus route through?

 

Community Gaffer
Community Gaffer
Posts: 13,224
Thanks: 966
Fixes: 81
Registered: 04-04-2007

Re: constant change of local IP.. stop!?

What router are you using?

Bob Pullen
Plusnet Product Team
If I've been helpful then please give thanks ⤵

marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

technicolour 582

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: constant change of local IP.. stop!?


marc2 wrote:

 

anyway i can stop this? 


Two ways:

1) Assign your device a static IP in its own TCP/IP settings (you *might* be able to do this in your router config but not all offer that feature)

2) Run your own DHCP server and configure it to give that device the same IP each time it renews the lease on that ip address. You'd need to turn off your existing dhcp server in your router for this option.

I need a new signature... i'm bored of the old one!
marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

thanks, good answer

 

but this is basic stuff as per port forwarding, the system should know

no point in port forwarding if keeps changing

 

 

Browni
Aspiring Hero
Posts: 2,178
Thanks: 746
Fixes: 45
Registered: 02-03-2016

Re: constant change of local IP.. stop!?

If you assign a static IP to the PC as I said in the first reply in this thread it won't change. That is basic stuff.
I must have been really bad in a previous life as this was my 3rd ISP in a row that used lithium.
Now you're stuck with me because my new ISP doesn't run a forum Cheesy
RPMozley
Aspiring Pro
Posts: 1,117
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: constant change of local IP.. stop!?

If you're using the tg582n then login to it, go to Devices in the Home Network section. From there select your PC running the plex server, click configure top right of screen. Then check the box "Always use the same IP address" in the addressing section. Save and done.
That's RPM to you!!
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: constant change of local IP.. stop!?


marc2 wrote:

thanks, good answer

 

but this is basic stuff as per port forwarding, the system should know

no point in port forwarding if keeps changing

 

 


I've already explained to you how to get around the ip addresses being changed. Either go static or use a different dhcp server on your network. I've no idea if your router supports static IP addressing but thats the best place to look.

I need a new signature... i'm bored of the old one!
RPMozley
Aspiring Pro
Posts: 1,117
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: constant change of local IP.. stop!?

See post 7 @7up the "technicolor 582" and as you may know port forwarding only works with DHCP client on auto not a static device set IP address with this router.
That's RPM to you!!
marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

this may have resolved

 

need further testing

marc2
Dabbler
Posts: 23
Registered: 31-01-2013

Re: constant change of local IP.. stop!?

great that plusnet dont offer any technical support what so ever