cancel
Showing results for 
Search instead for 
Did you mean: 

Wireless (non) connection

timroe
Newbie
Posts: 2
Registered: ‎21-12-2009

Wireless (non) connection

I'm new to Plusnet and am having difficulty connecting wirelessly via the Thomson TG585v7 router supplied by Plusnet. The laptop that's having problems is an elderly, (but still perfectly seviceable), G3 PowerBook known as a  Pismo running OSX 10.4.11 (Tiger). When the machine is turned on the airport icon in the top strip is greyed out, though the Plusnet network shows up when the icon is clicked on. If I then select the Plusnet network to try to connect to the internet there is a brief pause and an error message appears stating that " An error occured trying to connect to the PlusnetWireless network" . I'm given an option of "Try again" or "OK". If I try again then the same error message appears and clicking "OK" means giving up on the whole exercise.
Interestingly I can "fool" the Pismo into connecting wirelessly by switching the router off then on and waiting for the Plusnet network to appear under the airport icon and then selecting that network. However when the airport is turned off or the Pismo shut down exactly the same scenario repeats as outlined above.
Previously my ISP was Orange and there was no problem connecting via the Seimens wireless router supplied by them.
Any thoughts/suggestions?
2 REPLIES
MacOS10
Grafter
Posts: 172
Thanks: 1
Registered: ‎30-07-2007

Re: Wireless (non) connection

If the Pismo has an Airport Card, this will be the original Airport Card (54b) and not the later Airport Extreme Card (54g). Therefore, make sure your router allows 54b connections - some modern routers are set to exclude the older, slower speed wireless cards. Or does the Pismo use a wireless network PCI card in the PCI slot on the side of the Mac? If so, check for updated drivers for that PCI card.
If you log-in to the router, there should be a section that shows the wireless speeds settings - make sure it's set to "b, g and n" - or if you have no "N" speed computers just stick to "b and g" speeds.
Also, if that doesn't work, try a new password on the wireless network and possibly a different encryption strength (WPA or even WEP, rather than WPA2 which might be be compatible with older Airport Cards.)
Last year, I bought a Belkin Wireless "N" speed router, despite it saying on the box that it was backward compatible with 54b and 54g, my Powerbook G4 could connect fine (with it's newer, faster Airport Extreme Card) but my older G4 iMac couldn't connect (with its older Original Airport Card), giving me the same error message as yours. In the end, the Belkin router went back and I got a refund, and I went back to my Netgear DG834GT which works with both Macs using the same wireless settings, encryption strength and passwords. So, all is not equal when it comes to routers it seems.
timroe
Newbie
Posts: 2
Registered: ‎21-12-2009

Re: Wireless (non) connection

Hi
Thanks for your input. The support team at Plusnet came up with the suggestion to try changing encryption to WEP rather than WPA and that did the trick. Its really nice to know that there are people out there willing to give their time trying to help total strangers with this sort of problem. Thank you and Happy Christmas.