cancel
Showing results for 
Search instead for 
Did you mean: 

Windows XP Keyboard problem

penneck
Rising Star
Posts: 730
Thanks: 25
Registered: 03-08-2007

Windows XP Keyboard problem

I recently rebuilt a Dell 775 pc by fitting a new hard derive then re-installing the software from operating system upwards. I know that XP asks for the nationality of the keyboard, and I'm sure I said it was UK. However, my son who now has this pc, tells me that the "@" key produces an "!", and vice-versa. The keyboard is a USB keyboard, and it is what I used when I was re-installing the software.
Doing tests on my pc, which also uses XP and a USB keyboard, I am unable to find anywhere that I can check what keyboard nationality my pc  thinks it has, and my keyboard types what the keys indicate, so I don't have the same problem.
Wouldanyone who knows what to do, please let me know
Thanks
10 REPLIES
CX
Grafter
Posts: 745
Thanks: 2
Registered: 16-09-2010

Re: Windows XP Keyboard problem

You can set the appropriate keyboard layout in the "Regional and Language Options" control panel.
Make sure that you click the button to change the system defaults too, if it is incorrect, otherwise any new user accounts will have the same problem.
Community Veteran
Posts: 3,380
Thanks: 4
Registered: 18-01-2013

Re: Windows XP Keyboard problem

As above - your keyboard is probably set to US layout when you need to set UK layout.
penneck
Rising Star
Posts: 730
Thanks: 25
Registered: 03-08-2007

Re: Windows XP Keyboard problem

Thankyou.
Community Veteran
Posts: 4,847
Thanks: 121
Fixes: 24
Registered: 14-07-2009

Re: Windows XP Keyboard problem

Quote from: penneck
. I know that XP asks for the nationality of the keyboard, and I'm sure I said it was UK.

It asks for language and locale and keyboard setting.  All three of these default to US and need to be reset to UK.  It's easy to miss the keyboard settings option but all can be reset later as CX indicated..
penneck
Rising Star
Posts: 730
Thanks: 25
Registered: 03-08-2007

Re: Windows XP Keyboard problem

I have just visited my son so am trying to fix his computer now (I am typing this message on his pc).
I have tried what CX suggested. I have gone into Control Panel to Regional Settings, and found three places where it listed US English or just US, I changed them to UK English or UK, clicked Apply and OK and rebooted, but it hasn't solved the problem. Didn't find anything that seemed to be about keyboard layout.
Device Manager/Keyboard talks about HID Keyboard. I don't know what the HID stands for, nor whether it should be saying something else, so I don't know if this is a clue.
Could it be a driver problem (remember this is a USB keyboard)?
Any other suggestions would be gratefully received
TIA
Community Veteran
Posts: 6,735
Thanks: 12
Registered: 02-02-2008

Re: Windows XP Keyboard problem

Quote from: penneck
HID

It does tell you.  Wink But in case you missed it, Human Interface Device.
CX
Grafter
Posts: 745
Thanks: 2
Registered: 16-09-2010

Re: Windows XP Keyboard problem

This should do it:
1) Go to Regional and Language Options control panel.
2) Click on the Languages tab and then the Details button
3) Under Installed services, click Add and selected English (United Kingdom) and click Apply.
4) Under Default input language, select English (United Kingdom) and click Apply.
5) Now, under Installed services again, highlight US and then click Remove.
Community Veteran
Posts: 17,485
Thanks: 1,482
Fixes: 17
Registered: 06-11-2007

Re: Windows XP Keyboard problem

add to the above...
6.  you may be told that the change will only become effective when you re-boot.
7. on reboot you may have a small E icon bottom right  click on this to "remove" the US language
penneck
Rising Star
Posts: 730
Thanks: 25
Registered: 03-08-2007

Re: Windows XP Keyboard problem

That's it! Brilliant! Well done lads. Thanks for everything
Community Veteran
Posts: 17,485
Thanks: 1,482
Fixes: 17
Registered: 06-11-2007

Re: Windows XP Keyboard problem

Glad to help........
"Gud `ere innit?" 
comes to mind  Wink