cancel
Showing results for 
Search instead for 
Did you mean: 

Windows 8.1 won't see network USB drive on my TG582n

David123
Newbie
Posts: 3
Registered: 01-01-2014

Windows 8.1 won't see network USB drive on my TG582n

Hi,
I have recently upgraded to fibre and am using the Technicolor TG582n router that I was sent.
I saw that it had a USB port and thought - great, I can attach my Buffalo 1TB USB hard drive and use it as a network drive.
Chance would be a fine thing. It was formatted to NTFS and despite the instructions for the TG582n saying that this file system might be supported (the manual uses the word "optional"), it would not recognise the drive. So I re-formatted to exFAT - but it seems that was not supported either.
So I ditched that idea and decided (rightly or wrongly) that the router would only support memory sticks up to 32Gb rather than a large hard drive.
So I plugged in a 32Gb memory stick formatted to FAT32 - which was easily recognised by my old laptop running windows 7 - and I mapped it without a problem - wireless.
My issue is that my new laptop running Windows 8.1 Home won't see the USB drive on the network at all - I am connected wirelessly. It will ping it, but not see it on the network.
I am running McAfee Livesafe and have tried disabling the firewall, but to no avail. The network is set up as private, which I understand should relax the windows security settings for my home network - but Windows 8.1 will still not see the USB network drive.
Any ideas?
Thanks, David
1 REPLY
nanotm
Pro
Posts: 5,712
Thanks: 120
Fixes: 2
Registered: 11-02-2013

Re: Windows 8.1 won't see network USB drive on my TG582n

network name .....
open the file explorer left click the my computer icon(often called This PC) in the side bar then right click and select properties (or if your my computer icon is on the desktop then just right click that and select properties) in the properties page click any of the 4 side bar icons and select computer name tab in the new window
check the workgroup matches the name of the router workgroup (network name)
for instance my router is set up with the network name of myplace and the computers all default to "workgroup" so have to be manually changed to a different group in order to share files etc through network places list
if its not that it then have you checked that your advanced sharing options in network and sharing centre ?  I seem to recall having to manually adjust those settings to allow automatic setup of connected devices enable file and printer sharing and allow windows to manage homegroup connections.
these are just general ideas to help since I only have w8.1 pro systems and a totally different router so they might be a wild goose chase or be a lucky guess /
just because your paranoid doesn't mean they aren't out to get you