cancel
Showing results for 
Search instead for 
Did you mean: 

Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Steve
Seasoned Pro
Posts: 6,700
Thanks: 252
Registered: 13-07-2009

Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Caught me and borked my system, Have to resort to windows once again, Ready to give up on Linux soon.
Quote
If you have an NVidia card older than and including the G80 GPU, including the 6, 7, and 8800 series cards, DO NOT UPDATE TO Ubuntu 12.04 Precise yet! The latest NVidia driver installed with 12.04, 295.40, will not work with Compiz and 3D Unity. Precise will run in Unity 2D mode, but not 3D.
If life gives you lemons, make lemonade.
14 REPLIES
Community Veteran
Posts: 1,850
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

try switching to pclinuxos.
http://www.pclinuxos.com/
download here:
http://www.pclinuxos.com/?page_id=180
near the bottom of the page.
i've been using it for years and it's the most rock-solid, stable, usable distribution i know.  the developers keep to texstar's philosophy of a reliable os for day to day work.  cutting edge it is not.  workhorse it is.  could well solve your nvidia issue.  i have a 5200 nvidia card, so it can handle old kit. 
Community Veteran
Posts: 5,472
Thanks: 288
Fixes: 4
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

[quote=the same forum post that "Steve M" quoted]Until a fix is released, you can run Precise in Ubuntu 2D mode as is, then uninstall the 295.40 driver and install the 295.33 driver which can be downloaded here. Be sure to follow the instructions in the readme located in the 295.33 download directory.
I'm successfully running Precise in 3D mode with the 295.33 driver, getting ~8000 fps on my 8800 GTS card. I troubleshot 12.04 for about 7 hours before discovering the nVidia driver issue. nVidia is actively working a fix.
Community Veteran
Posts: 4,949
Thanks: 359
Fixes: 16
Registered: 10-06-2010

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

It's not related to any particular distribution, just the 295.40 nvidia driver. (The 295.40 driver was released to fix a security vulnerability, so perhaps it was rushed out with not enough testing.)
http://www.phoronix.com/scan.php?page=news_item&px=MTA4ODc
Community Veteran
Posts: 5,472
Thanks: 288
Fixes: 4
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

So Nvidia have known about this problem for at least two weeks, but still have not managed to fix it !
http://www.nvidia.com/object/unix.html
Steve
Seasoned Pro
Posts: 6,700
Thanks: 252
Registered: 13-07-2009

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Yeah there Is workarounds but did not want to confuse the issue for first timers, Going to Install 12.04 again this evening and either use no nVidia driver or try the nouveau driver.
If life gives you lemons, make lemonade.
Community Veteran
Posts: 4,949
Thanks: 359
Fixes: 16
Registered: 10-06-2010

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Well nvidia have now released 295.49 which claims to fix it.
Community Veteran
Posts: 5,472
Thanks: 288
Fixes: 4
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

That looks like progress at last  Smiley
Is it worth trying v295.49 ?, when Nvidia released the final BETA of v302.07 the day before - as that has a big list of fixes and long term improvements which is obviously the version to have when it is formally released in the near future.
Steve
Seasoned Pro
Posts: 6,700
Thanks: 252
Registered: 13-07-2009

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Quote from: ejs
Well nvidia have now released 295.49 which claims to fix it.
Sounds good, How do I go about Installing that driver?
The update doesn't support my  GE Force 7050/ n force 610i.
If life gives you lemons, make lemonade.
Community Veteran
Posts: 6,340
Thanks: 481
Fixes: 44
Registered: 30-07-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Is that just a typo in the release notes ( 7050 / nForce 620i ) OR does it really not support your card ?
It still seems to support other GeForce 7 and even 6 series.
Edit :- if you search for a driver for the 7050 / 610i it gives both 295.49 and the beta 302.07 as being compatible.
NB the search dropdown box doesn't even have 7050/ 620i as an option so I suspect the release notes could well be a typo.
Community Veteran
Posts: 1,122
Thanks: 6
Registered: 28-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

I have now installed 12.04 on to 2 set ups and looking at doing a possible third. Graphics drivers are something I have never really looked too far into, on my system at home which is on on 10.04lts there was a option for installing drivers on there which doesn't seem to be an option in 12.04. I have just went with whatever has been built in. Are there any benefits to installing drivers from the card manufacturer? I notice at times on my laptop which has a 9700 radeon mobile card in that at times my my screen will dim as if going into screensaver mode and then come back for no reason. Not sure if it's graphic driver related.
On my desktop at home which I intend to upgrade to 12.04 at the weekend I have a 6800gt Nvidia card, would I benefit at all from installing drivers from nvidia on that?
Community Veteran
Posts: 5,472
Thanks: 288
Fixes: 4
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Installing the Nvidia drivers makes a huge difference in performance, and in my opinion is essential for a desktop or laptop machine with the Nvidia chipset.
When I was playing with 12.04 BETA, the additional Nvidia drivers didn't appear until I had installed the 320+ updates  Shocked
If you have done the updates, then look for the "System" settings and look for "Additional Drivers"
Unfortunately I don't currently have a machine with 12.04 installed, but intend to revisit installing the proper release over the next couple of weeks - probably when the Nvidia v302.07 driver is officially released.
Community Veteran
Posts: 1,122
Thanks: 6
Registered: 28-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Thanks Purleigh, just did a search on my work pc which has a v old nvidia card and seems no other drivers available and its been updated. I never tried on the other machines after updating so will give it another shot tonight.
Community Veteran
Posts: 5,472
Thanks: 288
Fixes: 4
Registered: 11-08-2007

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

Interesting you should say that, as recently I was repairing a PC for someone and installed Ubuntu 12.04 to check all the hardware worked (before reloading Windows XP and returning it), and that had an Nvidia MX460 card which was a very fast card in it's day, but Ubuntu 12.04-BETA wouldn't detect that as requiring the Nvidia driver, but when I swapped the card for a later GeForce6200 then I was prompted to install the relevant driver.
Community Veteran
Posts: 4,949
Thanks: 359
Fixes: 16
Registered: 10-06-2010

Re: Warning about Ubuntu 12.04 LTS Precise and NVidia cards

The nvidia legacy drivers haven't been updated to be compatible with the version of the xorg x11 server in Ubuntu 12.04. So you can't use the nvidia legacy drivers in Ubuntu 12.04 nor Fedora 16 and 17 until nvidia update them.
Here's a thread on the nvidia forums of people complaining about that.