cancel
Showing results for 
Search instead for 
Did you mean: 

VM keeps loosing internet connection via network...

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

VM keeps loosing internet connection via network...

Hi guys
I've got a XP Pro SP2 setup in VMWare. I'm having some trouble with it tonight.
We've got a storm which might account for the internet being a bit upset this evening on my main PC. Eventually it comes back to life BUT my VMWare still can not connect to anything on the internet except DNS servers.
Initially I thought it must be a OS problem or network fault BUT if so, it wouldn't be able to look up IP address via DNS (Yes I flushed the DNS to make sure).
There was one other thing... I have a small program called clockwise which I use to synchronise the OS time (VMs don't always seem to readjust for some reason). Anyway I had to manually trigger it to adjust this evening and not long after that the internet on the VM died and I can't even pull up google or connect to borlands newsgroup server.
Any ideas?
It isn't the internet connection as my main physical PC can connect (though it has been dropping in and out all evening). I can't see though why a VM would just suddenly stop working! I did have similar problems a while back with 1 physical machine which had 3 default gateways set in the TCP/IP properties... like this VM...
I need a new signature... i'm bored of the old one!
10 REPLIES
Community Veteran
Posts: 1,574
Thanks: 3
Registered: 13-04-2007

Re: VM keeps loosing internet connection via network...

3 default gateways is a no no unless you are on a very large network. reduce it to one and check the dns is set correct.
you could do a tracert 194.119.131.66 and see were its going
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

hi
Yea I know what you mean but because I've actually got 3 types of different gateway on my network I found it easier to have all 3 setup in every systems TCP/IP (with 4 physical pcs and multiple VMs it gets rather time consuming and annoying having to change all the TCP/IP settings manually).
Anyway, its a random fault that continues to occur. Strangely after logging off, closing the vmware player (thus saving the OS in a running state), opening and logging back on the internet was again working!
Very weird though!
Are there any parts of the Windows networking system that might be falling asleep and forgetting to do what they're meant to do?
There must be something in the OS somewhere which is misbehaving - Any ideas as to what though?
I need a new signature... i'm bored of the old one!
VileReynard
Seasoned Pro
Posts: 10,826
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: VM keeps loosing internet connection via network...

So it's a bug in Vmware then?
Or alternatively what is your default, default gateway - the one used when you don't specify a complete route?

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

No I don't think it is a bug in VMware.
It also used to happen on my main PC when I had 3 gateways setup. It still happens now sometimes too even with just one.
It seems like Windows ability to connect to any server other than DNS just falls asleep! It really is so annoying...
One thing I am wondering about is perhaps it being a TCP related issue? IF I understand correctly, DNS is a broadcast via UDP?
So... would it make sense that perhaps somewhere on my network - probably the router, that the TCP packets might be getting interfered with somehow? - I dunno, perhaps it forgets mac addresses or something?
I need a new signature... i'm bored of the old one!
VileReynard
Seasoned Pro
Posts: 10,826
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: VM keeps loosing internet connection via network...

Hmmmm...
DNS uses UDP
NTP (Network Time Protocol) uses UDP
DO you have some bad firewall settings in your router/elsewhere?

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

Not that I'm aware of!
Its weird how its always intermittend and other systems on the network can still use the web while one machine drops out temporarily.
Its also very annoying!
Incidentally, I've still not actually shut down or rebooted that VM - I just suspend it by closing the VM player and then log back in next time I run it. Internet on it has today been faultless. Its so odd!
I need a new signature... i'm bored of the old one!
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

Quote from: axisofevil
DNS uses UDP
NTP (Network Time Protocol) uses UDP

Forgot to comment on this...
DNS always finds the IP addy of the site even after a dns flush.
Clockwise doesn't work when the internet is dead - it grumbles that it can't get connected so that might actually rule out the UDP theory (I didn't realise NTP was UDP based).
Does that narrow it down any further?
I need a new signature... i'm bored of the old one!
Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

Anyone?
I need a new signature... i'm bored of the old one!
VileReynard
Seasoned Pro
Posts: 10,826
Thanks: 250
Fixes: 10
Registered: 01-09-2007

Re: VM keeps loosing internet connection via network...

Is your host OS Windows or Linux?

Community Veteran
Posts: 14,345
Thanks: 685
Fixes: 10
Registered: 01-08-2007

Re: VM keeps loosing internet connection via network...

Winblows but the host isn't always affected (sometimes it is but not as much as the VM) yet at the same time the VM can access a http server elsewhere on my network.
I need a new signature... i'm bored of the old one!