cancel
Showing results for 
Search instead for 
Did you mean: 

Ubuntu screw-up Window controls...

VileReynard
All Star
Posts: 11,186
Thanks: 305
Fixes: 11
Registered: ‎01-09-2007

Ubuntu screw-up Window controls...

The new Ubuntu 10.04 has Window close,minimize,maximize at the top left of each and every Window. Cry
Luckily, it's easily fixed (for each user) by the following procedure:-
(See http://www.tuxradar.com/content/discover-new-features-ubuntu-1004-lucid-lynx)
Press Alt+F2 and in the Run Application dialog box, type gconf-editor. Click on Apps > Metacity > General on the left sidebar and change the button_layout property from
Quote
close,minimize,maximize:
to
Quote
:minimize,maximize,close

Click Close Window
And it's fixed - btw those colons are essential.

12 REPLIES
Steve
Seasoned Pro
Posts: 6,818
Thanks: 315
Registered: ‎13-07-2009

Re: Ubuntu screw-up Window controls...

Thankyou very much, That was doing my head in and i would of had no idea where to start to fix it, Thanks Smiley
If life gives you lemons, make lemonade.
Community Veteran
Posts: 6,773
Thanks: 258
Fixes: 21
Registered: ‎16-02-2009

Re: Ubuntu screw-up Window controls...

Hehehe staying the same in Mint 9  Cheesy
alanf
Aspiring Pro
Posts: 1,931
Thanks: 78
Fixes: 1
Registered: ‎17-10-2007

Re: Ubuntu screw-up Window controls...

The buttons on the left option is mereley the new default. No need to resort to dodges if this is not to your liking.
Simply select System / Preferences / Theme and choose another theme such as Clearlooks.
VileReynard
All Star
Posts: 11,186
Thanks: 305
Fixes: 11
Registered: ‎01-09-2007

Re: Ubuntu screw-up Window controls...

Quite like the default theme (after fixing). Cheesy

Steve
Seasoned Pro
Posts: 6,818
Thanks: 315
Registered: ‎13-07-2009

Re: Ubuntu screw-up Window controls...

Yeah its much better when you can fix that yourself, I think clearlooks is pant's Wink
If life gives you lemons, make lemonade.
Waldo
Grafter
Posts: 473
Registered: ‎01-08-2007

Re: Ubuntu screw-up Window controls...

Quote from: A
The new Ubuntu 10.04 has Window close,minimize,maximize at the top left of each and every Window. Cry
Luckily, it's easily fixed (for each user) by the following procedure:-
(See http://www.tuxradar.com/content/discover-new-features-ubuntu-1004-lucid-lynx)

For KDE and Xfce it's drag 'n drop from the window manager config. screens.
Waldo
Grafter
Posts: 473
Registered: ‎01-08-2007

Re: Ubuntu screw-up Window controls...

I was using Clearlooks before dist-upgrading to 10.04; after a reboot I had Clearlooks with the window control buttons on the left...
I don't suppose it matters how you move them back to the right.
Steve
Seasoned Pro
Posts: 6,818
Thanks: 315
Registered: ‎13-07-2009

Re: Ubuntu screw-up Window controls...

@ A Fox Is Evil ive just read that seemingly that fix in your first post is not a good way to go about it as its been done for a reason, Something else is going to the right in the next release.
If life gives you lemons, make lemonade.
VileReynard
All Star
Posts: 11,186
Thanks: 305
Fixes: 11
Registered: ‎01-09-2007

Re: Ubuntu screw-up Window controls...

Sounds very mysterious!

Steve
Seasoned Pro
Posts: 6,818
Thanks: 315
Registered: ‎13-07-2009

Re: Ubuntu screw-up Window controls...

Indeed, This taken from a sticky over in the ubuntu forums....
Minimize, Maximize and Close button placement.
A decision has been taken to move the placement to the left. Mark Shuttleworth explained that this was because "something" is going to be placed in the right hand area in the next release. Moving the buttons now would help enable this change.
[[Update ]http://www.markshuttleworth.com/archives/333
The buttons are in the old location on all default themes apart from Ambiance,Radiance and Dust, If you still want the Ambiance ,Radiance or Dust theme but with buttons on the right, choose one of those other themes and use the Customize button to achieve what you want. e.g.
1. System > Preferences > Appearance
2. Select the theme icon "New Wave"
3. Click the button "Customize.."
4. Select tab "Controls" and select "Ambiance"
5. Select tab "Window border" and select "Ambiance"
6. Select tab "Icons" and scroll down and select "Ubuntu-mono-dark"
7. Select "Save Theme" to your choice.
Using gconf-editor is not the right approach as this could bork future themes. This change makes it easier for themes to do interesting things with window borders. Unfortunately, if the wrong approach spreads, they won't be able to do that.
If life gives you lemons, make lemonade.
VileReynard
All Star
Posts: 11,186
Thanks: 305
Fixes: 11
Registered: ‎01-09-2007

Re: Ubuntu screw-up Window controls...

Good - they should leave the Window Manager to draw Window decorations and then the apps don't have to do it.
I don't want windicators! (at least on the right)
It was crazy to half-institute this change in a Lomg Term Support version.
I hope Mr Shuttleworth finds himself well and truly borked. Cheesy

Steve
Seasoned Pro
Posts: 6,818
Thanks: 315
Registered: ‎13-07-2009

Re: Ubuntu screw-up Window controls...

Yeah i could not agree with you more. Crazy
If life gives you lemons, make lemonade.