Showing results for 
Search instead for 
Do you mean 

Thomson TG585 v7

Highlighted
Newbie
Posts: 3
Registered: ‎09-05-2009

Thomson TG585 v7

Hi
I'm trying to get VPN working and I'm struggling.
I'm using the Thomson TG585v7 router.
I've got port 1723 (PPTP) forwarding to the only computer connected. This has been verified via some online port scanner. I've also turned off the firewall on the router.
The problem lies in the fact that I still cant get connected.
I've had this working before in my old house with a different ISP and a different router so I know the VPN settings on my computer work. I've checked them to make sure that they haven't changed.
Is forwarding that port the only thing I need to get the router to do? Is there some way I can check that protocol 47 is also being correctly forwarded?
Stu
5 REPLIES
Community Veteran
Posts: 5,455
Thanks: 31
Fixes: 1
Registered: ‎30-07-2007

Re: Thomson TG585 v7

Quote
I'm trying to get VPN working

Are you just trying to use a VPN client to connect to a remote VPN server ? If so then you shouldn't need any port forwarding, thats only needed if you are trying to run a VPN server locally.
One possible difference from your old configuration my be the subnet of the TG585 router. I think the 585 uses 192.168.1.x , is your remote site behind a NAT router with the same 192.168.1.x subnet by any chance ? If so you need to change the subnet of the 585.
Newbie
Posts: 3
Registered: ‎09-05-2009

Re: Thomson TG585 v7

Quote
Are you just trying to use a VPN client to connect to a remote VPN server ?

Yea, I didnt think I needed port forwarding but I couldnt think of anything else to do :p I'll turn them off.
Quote
is your remote site behind a NAT router with the same 192.168.1.x subnet by any chance ?

Here are the details (copy and pasted):
Protocol: PPTP (ports 1723 and protocol 47)
Authentication protocol: MSCHAPv2
Data Encryption: 128bit
Maximum throughput: 1Gb
IP addresses range: 10.56.X.X
DNS range: x.vpn.local
Does that help?
Community Veteran
Posts: 5,455
Thanks: 31
Fixes: 1
Registered: ‎30-07-2007

Re: Thomson TG585 v7

I'm not sure I understand those settings , what's the VPN client ?
Quote
IP addresses range:    10.56.X.X

I'm guessing that this is the remote IP range , if so it shouldnt be a problem.
Quote
I've had this working before in my old house with a different ISP

Aha!! What's the setting on your PlusNet firewall ? https://portal.plus.net/my.html?action=firewall
Needs to be LOW or OFF

Newbie
Posts: 3
Registered: ‎09-05-2009

Re: Thomson TG585 v7

Quote from: MisterW
Needs to be LOW or OFF

It's off.

I've been trying to connect through Ubuntu and I've just remember that VPN is a bit of a pain in the ass. So I rebooted into Windows and tried out my VPN connection there and it worked fine. Sigh, so it's something in Ubuntu that's the problem.
Thanks for your help.
Community Veteran
Posts: 5,455
Thanks: 31
Fixes: 1
Registered: ‎30-07-2007

Re: Thomson TG585 v7

Hi,
I think I lost my brain back there for a while. Anyway glad you got it working , with Windows at least.
Funnily enough I use Ubuntu and don't have a problem with VPN to my office with either that or Windows.
However I dont use the default configuration for routing ( see attached screen dump ). Rather than route all traffic through the VPN tunnel
I set it to ONLY route traffic for the remote private subnet.