cancel
Showing results for 
Search instead for 
Did you mean: 

System clock running slow using Mint 10 - Fixed

custos
Aspiring Pro
Posts: 315
Thanks: 47
Fixes: 2
Registered: 28-06-2007

System clock running slow using Mint 10 - Fixed

A while back I had a problem with the clock running slow on my Fujitsu/Siemens Amilo Li 1705 Laptop when running Xubuntu. With help from people on this forum I cured the problem by adding clocksource=tsc to the grub boot menu. However I am now running Mint 10 and have the same problem. However it seems that tsc is not available as an alternative clocksource to the one currently in use which is acpi_pm. Can anone help please?
21 REPLIES
VileReynard
Seasoned Pro
Posts: 10,980
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: System clock running slow using Mint 10

In Ubuntu the package "ntp" causes modestly frequent connections to be made to internet time servers (depending on the stability of your clock).

Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: System clock running slow using Mint 10

I always set my pc's up to use an ntp server (e.g. ntp.plus.net) usually you just need to right click on the clock, references and set time using using server then add the server at the end.
custos
Aspiring Pro
Posts: 315
Thanks: 47
Fixes: 2
Registered: 28-06-2007

Re: System clock running slow using Mint 10

I have ntp installed and set for ntp.plus.net. As far as I can tell it only updates the clock at boot as it is always correct immediately after boot. However it then starts losing a few seconds every minute and continues to do so until shut-down. If I run Windows on the same machine the clock stays accurate. This is exactly the same problem as I had with Xubuntu and the only way to cure it was to change the clocksource. However that option does not seem to be available on Mint 10.
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: System clock running slow using Mint 10

Try installing chrony
From Synaptic:-
Quote
It consists of a pair of programs :
`chronyd'.  This is a daemon which runs in background on the system.  It
obtains measurements (e.g. via the network) of the system's offset
relative to other systems, and adjusts the system time accordingly.  For
isolated systems, the user can periodically enter the correct time by hand
(using `chronyc').  In either case, `chronyd' determines the rate at which
the computer gains or loses time, and compensates for this.  Chronyd
implements the NTP protocol and can act as either a client or a server.
`chronyc'.  This is a command-line driven control and monitoring program.
An administrator can use this to fine-tune various parameters within the
daemon, add or delete servers etc whilst the daemon is running.
custos
Aspiring Pro
Posts: 315
Thanks: 47
Fixes: 2
Registered: 28-06-2007

Re: System clock running slow using Mint 10

OK, so I have installed Chrony but I have no idea what to do next!
VileReynard
Seasoned Pro
Posts: 10,980
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: System clock running slow using Mint 10

Well, ntp normally starts the ntpd daemon at boot time...
see
man ntpd

Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: System clock running slow using Mint 10

I think you just need to start the deamon.
sudo chrond& in a terminal.
Then see if your clock still drifts.
If all that fails try the Mint forums  Wink
Community Veteran
Posts: 5,167
Thanks: 478
Fixes: 20
Registered: 10-06-2010

Re: System clock running slow using Mint 10

There should be a GUI program in the Administration menu for configuring services to start at boot, and for starting and stopping them.
A more old fashioned way to start the service would be "sudo /etc/init.d/chrony start".
custos
Aspiring Pro
Posts: 315
Thanks: 47
Fixes: 2
Registered: 28-06-2007

Re: System clock running slow using Mint 10

I think I have to get back to my original problem in that with my hardware I need to use an alternative clocksource. The hardware clock normally keeps good time, it is only when running Linux I have a problem. What puzzles me is why I can't use the same fix as I did before - why is tsc no longer available as it was with the older version (9 I think) of Xububtu?
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: System clock running slow using Mint 10

It is probably that it has been "depreciated" as a kernel driver so is no longer supplied.
I find it weird that it is only Linux that has this issue on your h/w.
As I said earlier probably better posting in the Mint Forum for a definite answer.
Community Veteran
Posts: 5,472
Thanks: 292
Fixes: 4
Registered: 11-08-2007

Re: System clock running slow using Mint 10

From http://www.cyberciti.biz/faq/set-date-time-network-time-protocol-ntp/
Quote
I had the exact same problem. A Fujitsu Siemens Amilo Li 1705 that simply could not keep the time synced! It lagged about 1 second/minute… I set up a crontab that ran ntpdate every other hour or so. (NO! To any of you naysayers, the ntp daemon will not do it’s job under those circumstances…)
After having the missus spilling coffee and milk on the keyboard of the laptop, rendering the keyboard useless, I instead started using it as a server. Then, of course, syncing every 2 hours simply would not cut it as the lag buildup could amount to 2 minutes.
The solution was to use another server, well-behaved and well-synced (a trusty NSLU2 running Debian), as a local ntp server running ntpd. Then the misbehaving former-laptop-now-server could sync to that server instead and do it as often as needed without burdening the already burdened ntp servers around the globe. To have it never go beyond 5 seconds of lag I need to sync it with ntpdate as a cronjob every 5 minutes…
Community Veteran
Posts: 5,472
Thanks: 292
Fixes: 4
Registered: 11-08-2007

Re: System clock running slow using Mint 10

I wonder whether it is worth changing the real time clock battery, as looking at this it looks very easy to get at, and for the sake of a 50p battery it might be an easy fix
Community Veteran
Posts: 5,167
Thanks: 478
Fixes: 20
Registered: 10-06-2010

Re: System clock running slow using Mint 10

Quote from: custos
I think I have to get back to my original problem in that with my hardware I need to use an alternative clocksource. The hardware clock normally keeps good time, it is only when running Linux I have a problem. What puzzles me is why I can't use the same fix as I did before - why is tsc no longer available as it was with the older version (9 I think) of Xububtu?

What makes you think the tsc clocksource is not available? The hardware clock may still keep good time in Linux, but Linux doesn't use the hardware clock except for reading the date and time at bootup. After that, there should be much more accurate hardware, usually the cpu itself, available to keep time to microsecond accuracy (well, to quite a lot of microseconds anyway).
Here's what I get related to tsc in dmesg:
[    0.000000] Fast TSC calibration using PIT
[    3.250117] Marking TSC unstable due to TSC halts in idle
Some of the vaguely recent possibly related changes in the kernel include CONFIG_HZ=1000 - increasing the frequency of the system timer to improve system responsiveness, and CONFIG_NO_HZ - which allows a variable frequency system timer, for power savings. You could also try the nohz=off kernel parameter.
VileReynard
Seasoned Pro
Posts: 10,980
Thanks: 265
Fixes: 11
Registered: 01-09-2007

Re: System clock running slow using Mint 10

I have
Quote
jeremy@HECTOR:~$ dmesg | grep tsc
[  90.807552] Clocksource tsc unstable (delta = -206435260 ns)

Huh?