cancel
Showing results for 
Search instead for 
Did you mean: 

System Restore not working

Community Veteran
Posts: 1,012
Registered: 01-08-2007

System Restore not working

I have a Dell 6400 Laptop running Windows XP and for the past month or so whenever I run System Restore, although it appears to be working when the computer reboots it always says System Restore was unable to restore my computer to the selected date and has made no changes to my system and that I should try another date.
When I do this the same thing happens.      I have 'googled' the problem but all the free downloads, although they check the system, require payment to fix the problem.  I'm not prepared to do that as (a)  it may not work and (b) it's not that important an issue.
However I would be grateful if anyone here can point me in the right direction without getting too technical.
12 REPLIES
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

One thing to try is system restore in safe mode then on restart go to safe mode again
Community Veteran
Posts: 4,846
Thanks: 121
Fixes: 24
Registered: 14-07-2009

Re: System Restore not working

Several anti-virus programs include a self-protection feature which can stop System Restore from working unless you turn it off first.  These include Norton and Kaspersky.  I'm not sure if starting from Safe Mode will also overcome these self-protection mechanisms. 
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

It does in the case of Kaspersky
Community Veteran
Posts: 1,012
Registered: 01-08-2007

Re: System Restore not working

Thanks Oldjim.    Am trying it now on that laptop, seems to be working, but I'll let you know when it's complete.  It says it's restoring files.   You say though I have to open it up in Safe Mode upon completion.  Will it give me that option?
Community Veteran
Posts: 1,012
Registered: 01-08-2007

Re: System Restore not working

Thanks so much, Oldjim, it has done the job, but it didn't start up in Safe Mode.    When I look at System Restore it hasn't created a restore point so there is no record of it restoring my system to the date I selected.  Furthermore iPlayer Desktop will not download, though it will play, it tells me I need to reinstall it.
If i need to use System Restore again will I need to start in Safe Mode again?
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

You may well have to.
The reason for the iplayer is that it has removed all the registry entries and anything it stuck in the windows directory - in my case it even removed programs I had installed on the C drive but not the D drive so I suspect that it only creates a restore point in the windows drive
Community Veteran
Posts: 4,846
Thanks: 121
Fixes: 24
Registered: 14-07-2009

Re: System Restore not working

Quote from: Oldjim
.....in my case it even removed programs I had installed on the C drive but not the D drive so I suspect that it only creates a restore point in the windows drive

By default System Restore on XP covers all drives and I think Vista is the same.  On Windows 7 the default is that only the C drive is restored.  You can turn off drives from being covered by System Restore. 
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

You could be right - but on my Vista system I only have it on the C drive - it is switched off on all the other drives.
i probably changed it when I installed Vista as I didn't want a restore fiddling with  scripts, batch files, and other types of executable files on my computer other than on the C drive as I do have a lot of downloaded exe files which I want left alone - also I have a dual boot and restore can really mess that up if i let it get anywhere near the files on the other partitions
Community Veteran
Posts: 1,012
Registered: 01-08-2007

Re: System Restore not working

One other query.    I can't clear all my old System restore checkpoints as although it restored my system to the specified date, it didn't create a restore point.  When next it automatically creates a restore point, or if I were to create my own restore point now, I assume I could then successfully remove all the previous restore points and  my system would be left as it is now.
It may sound like a stupid question but I want to be 100% sure that is what would happen before I delete all my previous restore points which I believe I am able to do without having to start in Safe mode.
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

If you are happy with where you  are I would certainly create a restore point.
There is no real need to delete the old restore points as the system will add new restore points automatically and once the allocated disk space for restore points is used up it automatically drops off the oldest restore point every time it creates an new one
Community Veteran
Posts: 1,012
Registered: 01-08-2007

Re: System Restore not working

Thanks for that assurance.  I like to keep on top of my restore points.  Once I am entirely happy with the way my system is running. I usually delete all but the last one, around once a month.  It's just a habit I have to manage my hard disc space.
Community Veteran
Posts: 38,460
Thanks: 1,027
Fixes: 62
Registered: 15-06-2007

Re: System Restore not working

I don't do that and I found one benefit - a program wouldn't uninstall as the uninstall was corrupted and there was stuff scattered all over the registry.
Fortunately I could go back to the oldest restore point which was just before that program was installed.
Note that every windows update creates a restore point and it may be worth getting rid of a few of the intermediate ones to retain the older ones you want to keep