cancel
Showing results for 
Search instead for 
Did you mean: 

Plusnet Protect (McAfee) not displaying menu items correctly

sousclef
Newbie
Posts: 2
Registered: 29-01-2017

Plusnet Protect (McAfee) not displaying menu items correctly

My installation of Plusnet Protect is not displaying menu items correctly - see screen grab below.

The bottom right of the four larger squares should be entitled 'Your Subscription', but as you can see, just says 'Off'.

Of the three smaller squares on the right, the top one should read 'Data Protection and Backup' (not 'Parental Controls', as this is a duplicate of the bottom one), and the middle one should read 'PC and Home Network Tools' (not 'Help').

I have tried uninstalling, then running the McAfee complete product removal tool, then finally reinstalling, but this does not fix the problem.

Any ideasHuh?

Capture.JPG

2 REPLIES
rongtw
Seasoned Hero
Posts: 6,460
Thanks: 1,211
Fixes: 11
Registered: 01-12-2010

Re: Plusnet Protect (McAfee) not displaying menu items correctly

Sorry to say Sad

its a bit meh ,,, remove it and try one of the several free one around which are much better .

most people here dont use it , I just use window defender and Malwarebytes

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
sousclef
Newbie
Posts: 2
Registered: 29-01-2017

Re: Plusnet Protect (McAfee) not displaying menu items correctly

Belated reply.... I got rid of it. Currently using Windows Defender and testing out other options. Suffice to say my PC suddenly feels like it's running a whole lot more smoothly, and it's eliminated another problem I had with Chrome crashing, which would then prevent any browser from accessing the internet until a full reboot was done.