cancel
Showing results for 
Search instead for 
Did you mean: 

Open VPN - port 1194

tonkapc
Newbie
Posts: 3
Registered: 01-12-2015

Open VPN - port 1194

I have a PM Sagecom router (on Fibre broadband) with a fixed IP address. I've been having difficulty getting the router to open any ports. I have now succeeded in getting the thing to open up sorts, I've managed to open up 80, 554 and 8000 so far successfully. However any attempt to open un 1194 (for Open VPN) fails. If I check the port (using checkmyports.net) then 1194 always come sup as closed. Has anyone managed to get this working? I'm trying to get a pi on my network to act as an OpenVPN server but I cannot get any further until I have access via the 1194 port. Any advice would be appreciated.
Tonka
4 REPLIES
Moderator
Moderator
Posts: 18,697
Thanks: 1,951
Fixes: 247
Registered: 11-01-2008

Re: Open VPN - port 1194

Are you using udp by any chance?

Customer / Moderator / If it helped click the thumb / If it fixed it click 'This fixed my problem'

JonJon
Grafter
Posts: 91
Thanks: 5
Registered: 24-05-2009

Re: Open VPN - port 1194

Have you assigned your pi a static IP address?
Instead, change it to DHCP but get your router to assign a specific IP based on MAC address.
That way, you are port routing an IP that the router knows something about (as it has assigned it itself).
Worth giving it a try anyway!
JonJon.
tonkapc
Newbie
Posts: 3
Registered: 01-12-2015

Re: Open VPN - port 1194

I have a fixed IP from Plusnet and the router has been set (via the expert-user interface) to give a fixed IP to the pi. The router is set for DHCP.  I think that is consistent with what you are suggesting?Huh
Whilst this may help the pi receive the incoming traffic, surely this would not affect the ability for the router to open the port?Huh
I've tried UDP and TCP setting - still no success
Tonka
JonJon
Grafter
Posts: 91
Thanks: 5
Registered: 24-05-2009

Re: Open VPN - port 1194

That was certainly an issue with the default Thompson router - when I had manually set the pi to a static address, the forwarding wouldn't work because the router didn't know anything about that IP.
I think, in my case, it was a combination of getting that right & changing the router which fixed my issue.
JonJon