cancel
Showing results for 
Search instead for 
Did you mean: 

One for the experts

rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,531
Fixes: 12
Registered: 01-12-2010

One for the experts

Every now and again windows does not find my mouse Corsair M65 RGB pro .

have checked all normal things , and in power settings USB suspend is off , was told to check with a software call USBdview

and it shows a odd error but no one can help on the asus forum , so thought i would ask here on USB i get

PORT 15 Device general failure ? Roll eyes any ideas USB.PNG

 

 

hwinfo.PNG

 

 

 

 

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
6 REPLIES
Community Veteran
Posts: 5,237
Thanks: 1,321
Fixes: 31
Registered: 16-10-2014

Re: One for the experts

@rongtw - What other USB devices do you have as from looking at the images it would appear that another device has an issue and it is affecting the mouse with it being on the same bus.

Do you have a spare slot you can try?

rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,531
Fixes: 12
Registered: 01-12-2010

Re: One for the experts

@Mook  all i have is mouse and Keyboard , and they plugged into top 2  USB ports for KB and mouse

thats why i cant understand this ? lower 4 all unoccupied hs_MaximusVIHero_061.jpg

 

 

 

 

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Community Veteran
Posts: 5,237
Thanks: 1,321
Fixes: 31
Registered: 16-10-2014

Re: One for the experts

Have you tried connecting these devices to different ports? What about using the 2 USB ports to the right of the BIOS reset button. Depending on how often this occurs would really determine how long you would need to leave them in their new home. Worth a try?

rongtw
Seasoned Hero
Posts: 6,973
Thanks: 1,531
Fixes: 12
Registered: 01-12-2010

Re: One for the experts

@Mook  sorry i got wrong picture Sad     could the port 15 be a virtual USB ? Hero vii.jpeg

Asus ROG Hero Vii Z97 , Intel i5 4690k ,ROG Asus Strix 1070,
samsung 850evo 250gig , WD black 2 TB . Asus Phoebus sound ,
16 gig Avexir ram 2400 , water cooling Corsair H100i gtx ,
Corsair 750HXI Psu , Phanteks Enthoo pro case .
Community Veteran
Posts: 5,237
Thanks: 1,321
Fixes: 31
Registered: 16-10-2014

Re: One for the experts

@rongtw - I would suspect that would be the case with the majority of them, but there's nothing to stop you using the USB 3 ones to test.

nanotm
Pro
Posts: 5,685
Thanks: 111
Fixes: 1
Registered: 11-02-2013

Re: One for the experts

open device manager (in windows 10 right click the windows icon then select device manager from the pop up list) scroll through the list of usb devices and find the one(s) with a yellow icon on them right click them and select uninstall device restart windows it will take slightly longer than a normal boot as windows locates and installs the drivers, everything should be back to normal 

 

oh may not be the case but the usb slot closest to the ps2 mouse connector is for the mouse in most asus boards and sometimes they go wonkey if you plugged the keyboard and the mouse in the wrong slots (it took 4 rma's several years ago for tech support to figure out the problem) 

just because your paranoid doesn't mean they aren't out to get you